Please add the new brx_IN locale

Bug #874909 reported by Sanjib Narzary on 2011-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GLibC
Fix Released
Medium
langpack-locales (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Dear maintainers,

Please find attached the locale definition for brx_IN to be
considered for inclusion in Ubuntu.
I have submitted the same file in glibc also...

Thanks!
Sanjib Narzary

Created attachment 5976
New Locale bd_IN

Bodo language is an Indian Language recognized by Govt. of India and its spoken nearly 2 million people. This language uses Devanagari code as written script. This file is same as hi_IN and where hi_IN has been renamed as bd_IN. Thanks add this i need to see my language on open source products :)

Created attachment 5977
Bodo language locale for India

Yesterday saw http://tdil-dc.in/index.php?option=com_vertical&parentid=70&lang=en

(1) Initially CLDR had provision for building locale data for 15 Indian languages and with the TDIL efforts Bodo language has been included in CLDR 1.9.

Reference http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml

Bodo does not have 2-digit http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
also most of the LC_TIME field in earlier patch were just copy of mr_IN locale, actually it differs lot from Marathi http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml

Added <email address hidden> as a contributor in brx_IN file

Comment on attachment 5977
Bodo language locale for India

sir our bodo language uses Devanagari but not all bodo words are exactly like Hindi...
http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml
in this link what are generated from brx_IN is all Hindi words. which file to modify to exactly see the bodo words?

(In reply to comment #2)
> Comment on attachment 5977 [details]
> Bodo language locale for India
>
> sir our bodo language uses Devanagari but not all bodo words are exactly like
> Hindi...

Yes exactly.

> http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml
> in this link what are generated from brx_IN is all Hindi words. which file to
> modify to exactly see the bodo words?

http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml is standard CLDR file for Bodo language.
Based on this i have prepared brx_IN locale file, we should follow above file

copying some text from above file for you

<day type="sun">रबिबार</day> <day type="mon">समबार</day> <day type="tue">मंगलबार</day>
<day type="wed">बुदबार</day>
<day type="thu">बिसथिबार</day>
<day type="fri">सुखुरबार</day>
<day type="sat">सुनिबार</day>

sir the
> http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml
>4283 <posix>
>4284 <messages>
>4285 <yesstr>हाँ</yesstr>
>4286 <nostr>नहीं</nostr>
>4287 </messages>
>4288 </posix>

should be replace with

4283 <posix>
4284 <messages>
4285 <yesstr>नंगौ</yesstr>
4286 <nostr>नङा</nostr>
4287 </messages>
4288 </posix>

(In reply to comment #4)
> should be replace with
> 4285 <yesstr>नंगौ</yesstr>
> 4286 <nostr>नङा</nostr>

That's interesting.
Do you have any reference for this. i.e. dictionary image etc.
We can report bug against Unicode CLDR giving reference and ask them to correct it.

ok i will find all the words which have to be modified in the
> http://www.unicode.org/cldr/trac/browser/trunk/common/main/brx.xml
and submit back to here..including all the photo images of the the related words from some of the anglo bodo dictionary...with authors name, book title, publishers name and year of publication...

by the way brx_In is not listed here...
http://sourceware.org/git/?p=glibc.git;a=tree;f=localedata/locales;hb=HEAD
what i need to do to be listed in there??

Created attachment 5982
Bodo language locale for India

Updated as per suggestions Sanjib.

Once upstream developer commit brx_IN in git, it will appear at http://sourceware.org/git/?p=glibc.git;a=tree;f=localedata/locales;hb=HEAD it will take some time

waited for two days to commit but brx_IN is not listed in
http://sourceware.org/git/?p=glibc.git;a=tree;f=localedata/locales;hb=HEAD
normally how much days it will take to commit...

Sanjib Narzary (alayaran) wrote :
Sanjib Narzary (alayaran) wrote :

is anyone listening this thread??

tags: added: l10n
Martin Pitt (pitti) wrote :

Waiting a bit for upstream to comment/accept. I'll add an Ubuntu patch for it otherwise.

Changed in langpack-locales (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Wishlist
milestone: none → precise-alpha-2
status: New → Triaged
Changed in glibc:
importance: Unknown → Medium
status: Unknown → Confirmed

Comment on attachment 5982
Bodo language locale for India

>% Contributed by Pravin Satpute <email address hidden> and <email address hidden>
sir can you add my name here with my email Sanjib Narzary <email address hidden>

Sanjib Narzary (alayaran) wrote :

@Martin Pitt (pitti)
Thank You Sir for this kind information and Help.

Created attachment 6009
Bodo language locale for India

updated name.

wish you a very happy diwali...:)

Sanjib, Happy diwali to you as well :)
lets hope this will get committed soon in glibc upstream.

Martin Pitt (pitti) on 2011-11-16
Changed in langpack-locales (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package langpack-locales - 2.13+git20111116-1

---------------
langpack-locales (2.13+git20111116-1) precise; urgency=low

  * Update to current upstream glibc git head localedata.
  * Unfuzz patches for the current upstream version.
  * Add ubuntu-brx_IN.patch. (LP: #874909)
  * Add ubuntu-nl_BE-monetary.patch: Use Dutch monetary format for nl_BE.
    (LP: #586742)
  * Add ubuntu-en_ZA-decimal.patch: South Africa uses comma as a decimal
    separator. (LP: #887395)
  * debian/control: Bump Standards-Version to 3.9.2. No changes necessary.
  * Switch to 3.0 (quilt) source format.
 -- Martin Pitt <email address hidden> Wed, 16 Nov 2011 12:02:43 +0100

Changed in langpack-locales (Ubuntu):
status: Fix Committed → Fix Released
Sanjib Narzary (alayaran) wrote :

thank you for adding Bodo Language in Ubuntu language pack.

Sanjib Narzary (alayaran) wrote :

16 November is our literary day...hope this 16/11/2011 is the memorable day :) our team will be very happy to know this news..........

brx_In has been added in Ubuntu glibc today.
waiting for commit in glibc at sourceware too...

I think they patches there glibc package, but anyway it is more important to get it commit in upstream. then it will automatically go every OS using glibc. :)

I can try for Fedora but lets wait for upstream first, anyone here?

ok thank you for the information.i will wait for the commit.fedora and xo
is my first preference :)

On Thu, Nov 17, 2011 at 10:51 AM, pravin.d.s at gmail dot com <
<email address hidden>> wrote:

> http://sourceware.org/bugzilla/show_bug.cgi?id=13282
>
> --- Comment #15 from Pravin S <pravin.d.s at gmail dot com> 2011-11-17
> 05:21:05 UTC ---
> I think they patches there glibc package, but anyway it is more important
> to
> get it commit in upstream. then it will automatically go every OS using
> glibc.
> :)
>
> I can try for Fedora but lets wait for upstream first, anyone here?
>
> --
> Configure bugmail: http://sourceware.org/bugzilla/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>

yes sir, i was there in fedoraproject since from 2008.but due to less time effort i could not continue in the project actively. My email is <email address hidden> in fedoraproject. I was in the cvs l10n group.

I added the file.

thank you for commit.
Now only 3 locale remaining to complete 22 official Indian languages locale in glibc. (santali,manipuri and dogri).

Hoping to get that information soon and complete this important milestone :)

thank you @Ulrich Drepper for the commit

and thank you @Pravin S for you constant and steady help.

Changed in glibc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.