Request for new locale for Sindhi (Pakistan)

Bug #588910 reported by Abdul-Rahim Nizamani on 2010-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GLibC
Invalid
Medium
Ubuntu Translations
Medium
Unassigned
langpack-locales (Ubuntu)
Medium
Martin Pitt

Bug Description

The locale for Sindhi (India) is included in the Ubuntu by default, but the Sindhi (Pakistan) is not. Sindhi is spoken mainly in Pakistan, so this is the default locale for Sindhi language and needs to be included in the system.

We have updated the locale file sd_PK for the locale settings. Please guide me how can this be included in the system, so that language packs are built for this locale. As we have already started translating Ubuntu in Sindhi, we want to localize the Ubuntu in Sindhi language. And I was advised by someone to report the new locale as a bug in this package.

Kindly help!

I was advised by someone to report the bug for the inclusion of a new locale for
Sindhi (Pakistan). We the translation team have developed it, and have got the
file sd_PK (locale file) ready. Please guide me how can this be included in the
package, so that we can use this locale in the system.

Who is "the translation team"? Are you the GNU translation team for sd_PK, or a
more informal group?

You can attach the locale file to this bug. Please make sure it compiles without
errors, is well tested and follows the conventions of other locale files you can
find in glibc.

Created attachment 4829
Locale file for Sindhi (Pakistan)

Please find attached the locale file for Sindhi (Pakistan). (Locale sd_PK)

I am the moderator of the Sindhi Translation Team for Ubuntu (not the owner),
and we have newly started the translation team. But the team is not announced in
public to the Sindhi computing group, as we wanted to setup the basics before
that, which include inclusion of Sindhi locale, keyboard layout and fonts in the
system.

Abdul-Rahim Nizamani (ghaffari) wrote :

I have finalized the locale file for Sindhi (Pakistan) locale (sd_PK) and am attaching it here. Kindly include it in the supported locales.

Haven't heard anything yet. When is this bug going to be resolved?

Martin Pitt (pitti) on 2010-06-15
Changed in langpack-locales (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
David Planella (dpm) on 2010-06-15
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in glibc:
status: Unknown → Confirmed
Martin Pitt (pitti) on 2010-06-18
Changed in langpack-locales (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package langpack-locales - 2.11+git20100304-6

---------------
langpack-locales (2.11+git20100304-6) maverick; urgency=low

  * Add debian/source/format. Keep "1.0", since 3.0 is a pain for full source
    in revision control.
  * Add ubuntu-sd_PK.patch: Add sd_PK locale, thanks to Abdul-Rahim Nizamani!
    (LP: #588910)
 -- Martin Pitt <email address hidden> Fri, 18 Jun 2010 10:35:11 +0200

Changed in langpack-locales (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2010-06-18
Changed in ubuntu-translations:
status: Triaged → Fix Released

Look at the pa_PK file. You should use language-independent categories from
ur_PK and not copy them.

No update in 6+ months. Closing.

Changed in glibc:
importance: Unknown → Medium
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.