Japanese Kana ignored (treated as punctuation) in sorts

Bug #389739 reported by Bryce on 2009-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Low
langpack-locales (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Present in 9.10 and earlier down to at least 7.x

File name sorting has a nice feature where it ignores characters like [ and * at the beginning of file names, and sorts according to the first sortable character. i.e.

[a
*a
^a
[b
^b
*c

etc...This is nice, however:

Japanese Kana characters are incorrectly treated the same way, which causes them to be sorted in a completely arbitrary way. This does not happen when the locale is Japanese, but does for all other locales that I've tried. Kanji seem not to be affected, only Kana.

Note in the attached picture the way that the katakana "A" characters are treated exactly the same way as the brackets, asterisk, etc. Furthermore, the two folder names at the top are sorted incorrectly in relation to each other; which gets much worse if you have a lot of real file names (the sorting is completely arbitrary and useless).

The way files are sorted in the Japanese localisation is correct, though.

Bryce (zyzzyx1) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it and understanding how kana is supposed to be working could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Bryce (zyzzyx1) wrote :

From http://bugzilla.gnome.org/show_bug.cgi?id=586703:
> Comment #5 from Owen Taylor (glib developer, points: 25)
>2009-06-25 22:20 UTC
>Sounds like you should revisit the Ubuntu bug, then, and get it reassigned to
>the appropriate package.

They're saying it's not GNOME.

Sebastien Bacher (seb128) wrote :

reassigning to langpack-locales

affects: nautilus (Ubuntu) → langpack-locales (Ubuntu)
Changed in langpack-locales (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → New
Sebastien Bacher (seb128) wrote :

upstream comment

"GLib just uses libc's collation routines internally."

the issue is rather a locale one

Changed in nautilus:
status: Unknown → Invalid
Bryce (zyzzyx1) on 2009-11-01
description: updated

Bryce wrote:
> Japanese Kana characters are incorrectly treated the same way, which
> causes them to be sorted in a completely arbitrary way. This does not
> happen when the locale is Japanese, but does for all other locales that
> I've tried. Kanji seem not to be affected, only Kana.

[...]

> The way files are sorted in the Japanese localisation is correct,
> though.
>

Not sure if this can be fixed at all...
The sorting order for Kana (collation) is stored in the ja_JP locale
file. If you use any other locale than ja_JP, this information is of
course missing.

Changed in nautilus:
importance: Unknown → Low
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.