Ubuntu

clock applet has no 12 hr time

Reported by Alastair Porter on 2006-03-10
16
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
langpack-locales (Ubuntu)
Medium
Martin Pitt

Bug Description

Ubuntu Dapper Flight 4 + updates.

The clock applet (by default in the top right corner) no longer has an option to display the time in a 12hr format.

Steps to reproduce:
 Go to clock applet properties
 Try and change time format to 12 hr

Expected results:
  Able to change time format to 12 hr

Actual results:
  No 12 hr time format option

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What locale are you using? The changelog mentions that:

"2006-01-22 Vincent Untz <email address hidden>

        Don't offer the 12-hour format to the user if his locale don't support
        it (strftime("%p") == ""). Fix bug #320156

        * (format_changed): check if we support AM/PM and if we don't and it's
        the new format, just use 24-hour as format
        (fill_clock_applet): ditto
        (set_format_cb): small tweak for when we don't support AM/PM
        (display_properties_dialog): don't show the 12-hour option if we don't
        support AM/PM, small tweak when initialize the current value"

Changed in gnome-applets:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

alastair@saturn:~$ locale
LANG=en_NZ.UTF-8
LANGUAGE=en_NZ:en_US:en_GB:en
LC_CTYPE="en_NZ.UTF-8"
LC_NUMERIC="en_NZ.UTF-8"
LC_TIME="en_NZ.UTF-8"
LC_COLLATE="en_NZ.UTF-8"
LC_MONETARY="en_NZ.UTF-8"
LC_MESSAGES="en_NZ.UTF-8"
LC_PAPER="en_NZ.UTF-8"
LC_NAME="en_NZ.UTF-8"
LC_ADDRESS="en_NZ.UTF-8"
LC_TELEPHONE="en_NZ.UTF-8"
LC_MEASUREMENT="en_NZ.UTF-8"
LC_IDENTIFICATION="en_NZ.UTF-8"
LC_ALL=

This appears to be a New Zealand specific bug.
There is a report filed in the debian tracker related to this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=356328

Sebastien Bacher (seb128) wrote :

Thank you for pointing the locales bug, reassigning. Martin, I mark that to fix for dapper since there is a trivial patch. Let me know if you are not the right person for locales bugs assigning!

Changed in gnome-panel:
assignee: desktop-bugs → pitti
status: Needs Info → Confirmed
Martin Pitt (pitti) wrote :

@Seb: that's fine, I'll fix it soon.

Martin Pitt (pitti) on 2006-03-20
Changed in locales:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

 langpack-locales (2.3.12) dapper; urgency=low
 .
   * locales/en_NZ: Add AM/PM definition (Malone #34262)
   * locales/tr_TR: Fix stray space in int_curr_symbol (Malone #34738)
   * locales/eo: Rename to eo_XX, since that's the format that other programs
     expect (Malone #23435)
   * locales/es_CO: Change standard paper size from A4 to US Letter. (Malone
     #27622)

Changed in langpack-locales:
status: In Progress → Fix Released
Kris Marsh (moogman) wrote :

Sorry. I also see this in Dapper 5, apt-get dist-updated with GB locale.

moogman@gooblut:~$ locale
LANG=en_GB.UTF-8
LANGUAGE=en_GB:en_US:en_GB:en
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

Sebastien Bacher (seb128) wrote :

Please open a different bug if you have a different issue, yours is about en_GB locale which is fixed for Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=240901

Martin, you might want to patch en_GB too

Martin Pitt (pitti) wrote :

> Martin, you might want to patch en_GB too

Done:

 langpack-locales (2.3.14) dapper; urgency=low
 .
   * locales/{en,cy}_GB: Add AM/PM definition. (See Malone #34262).

Thanks Martin! (And sorry I didn't create another bug for this).

On 10/04/06, Martin Pitt <email address hidden> wrote:
> > Martin, you might want to patch en_GB too
>
> Done:
>
> langpack-locales (2.3.14) dapper; urgency=low
> .
> * locales/{en,cy}_GB: Add AM/PM definition. (See Malone #34262).
>
> --
> clock applet has no 12 hr time
> https://launchpad.net/malone/bugs/34262
>

Edmond Thiebaud (thiebaude) wrote :

I'am using Kubuntu 7.10, and I can't change the clock time from 24hr to 12hr, i tried everything.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.