Support latin locale

Bug #234105 reported by Robert Collins on 2008-05-22
4
Affects Status Importance Assigned to Milestone
GLibC
Won't Fix
Wishlist
langpack-locales (Ubuntu)
Undecided
Martin Pitt

Bug Description

We do translations to latin in launchpad, but don't generate a Latin locale (because there is none :).

I've created a simple one based on the en_AU locale (but as my Latin is still weak, it probably is wrong - however one hopes that a more fluent Latin user will notice and complain once they have the option to choose Latin!).

Robert Collins (lifeless) wrote :
Martin Pitt (pitti) wrote :

Taking for sponsoring, but this should be passed to upstream first. I'll do that, unless you beat me to it:

http://sources.redhat.com/bugzilla/buglist.cgi?product=glibc&component=localedata

Changed in langpack-locales:
assignee: nobody → pitti
status: New → In Progress

Robert Collins recently created a locale for Latin. Of course the choice of a
corresponding country is pretty arbitrary here, given that it is a dead
language. He based it on en_AU, so I called it la_AU for now.

Do you see a possibility to make this more generic? Maybe provide a "la" locale
based on POSIX, and base la_AU (and maybe other country specific contributions)
based on "la"?

Thanks!

Created attachment 2767
la_AU locale definition (first cut)

Martin Pitt (pitti) wrote :

Forwarded upstream. Waiting for upstream comments before incorporating this to avoid incompatibilities in the future. Thanks!

Changed in langpack-locales:
status: In Progress → Triaged
Martin Pitt (pitti) wrote :

Note to self: After this bug is solved, take bug 234101.

Changed in glibc:
status: Unknown → Confirmed

On Fri, 2008-05-30 at 10:21 +0000, Martin Pitt wrote:
> Forwarded upstream. Waiting for upstream comments before incorporating
> this to avoid incompatibilities in the future. Thanks!

Thanks Martin.

In the interim, for folk that want to see the result of their
translation efforts, my ppa has builds of both langpack-locales and gdm:

https://edge.launchpad.net/~lifeless/+archive

--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

No, this is just another nonsense locale like all the artificial languages.

Martin Pitt (pitti) wrote :

Hm, Ulrich Drepper rejected this locale in his inimitably objective and friendly way ("No, this is just another nonsense locale like all the artificial languages."). So we'll just maintain this on our own then.

Changed in langpack-locales:
status: Triaged → In Progress
Changed in glibc:
status: Confirmed → Won't Fix
Martin Pitt (pitti) wrote :

I applied the patch with renaming la to la_AU (since it is country specific) and some minor cleanup. Test script running now.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package langpack-locales - 2.7.9-5

---------------
langpack-locales (2.7.9-5) intrepid; urgency=low

  * Add debian/patches/la_AU.patch: Add Latin/Australia locale, thanks to
    Robert Collins! (Rejected upstream). (LP: #234105)

 -- Martin Pitt <email address hidden> Wed, 18 Jun 2008 12:45:43 +0200

Changed in langpack-locales:
status: In Progress → Fix Released
Changed in glibc:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.