No Belarusian Latin locale generated

Bug #157654 reported by Ihar Hrachyshka on 2007-10-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
langpack-locales (Ubuntu)
Wishlist
Unassigned

Bug Description

There is a new l10n effort made in Belarusian l10n community - translation of GNOME and other packages into Belarusian Latin (be_BY.UTF-8@latin locale). Though even when "Byelorussian" language is chosed in Language Selector and appropriate packages with gettext files are installed, there is no be_BY.UTF-8@latin locale generated and that's why a user can't use this language variant for Ubuntu UI. After some investigation, I found that to use it a person should edit /var/lib/locales/supported.d/be to be like that:
booxter@booxter-laptop:~$ cat /var/lib/locales/supported.d/be
be_BY.UTF-8 UTF-8
be_BY.UTF-8@latin UTF-8
be_BY.UTF-8@classic UTF-8
booxter@booxter-laptop:~$
and then run "sudo locale-gen" to reflect the changes. This kind of changes should be done automatically after Byelorussian language is chosen in Language Selector.
PS: And we should also fix bug #119122 too I think.

Is there any chance to see this fixed and running for Ubuntu 8.04?

Caroline Ford (secretlondon) wrote :

new -> confirmed

We don't support Belarusian langauge in the latin alphabet as it stands.

Arne Goetje (arnegoetje) wrote :

At least in 9.04 the be_BY@latin locale is present.

Changed in ubuntu:
status: Confirmed → Fix Released

be_BY@latin, not be_BY.UTF-8@latin
The problem is that some programs don't work correctly without UTF-8 part explicitly specified.

Changed in ubuntu:
status: Fix Released → Confirmed
Luke Faraone (lfaraone) on 2009-10-07
affects: ubuntu → langpack-locales (Ubuntu)
Changed in langpack-locales (Ubuntu):
importance: Undecided → Wishlist
Martin Pitt (pitti) wrote :

It seems this was fixed a while ago?

grep ^be_BY /usr/share/i18n/SUPPORTED
be_BY.UTF-8 UTF-8
be_BY CP1251
be_BY@latin UTF-8

Changed in langpack-locales (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers