Can't type Persian (farsi)

Bug #1314030 reported by costales on 2014-04-29
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
webbrowser-app
Invalid
Low
Unassigned
langpack-locales (Ubuntu)
Undecided
Unassigned

Bug Description

I can't type Persian (farsi) in webbrowser-app!! (Can send English messages only)

costales (costales) on 2014-04-29
Changed in unity-webapps-telegram:
status: New → Invalid

Le 29/04/2014 07:59, costales a écrit :
> Public bug reported:
>
> I can't type Persian (farsi) in webbrowser-app!! (Can send English
> messages only)
What type of input method are you using? I guess it's something more
elaborate than plain dead key support as I can type accentuated French
characters in Gmail currently.

What do you mean of what type of input method?
I added Persian from Language Support in settings. And I can type Persian in any program (i.e. LibreOffice, Chromium (Telegram app fro Chromium too), gedit etc.).

Maksim Sokolski (misokolsky) wrote :

I have the same issue but I can give some hint - when webapps opening with active english layout it type only in english, if with any other language (farsi, ukrainian etc.) - it type only in this layout.

David Barth (dbarth) on 2014-09-29
tags: added: desktop
Changed in webbrowser-app:
importance: Undecided → Low
status: New → Triaged
Farahmand (civilforyou) wrote :

I have the same issue with Chromium and Chrome browsers. Moreover I can't open any file that has a Persian name. It's so weird. The message is:

""
/home/USERNAME/SOME_DIRECTORY/????? ??? does not exist.
""

Farahmand (civilforyou) wrote :

I believe that it's a "locale" bug. When I changed my country to "Iran" the problem arose and the language was "en_IR" which is absolutely wrong. When I changed it to "System Country (United States of America)" the issue removed and the language is "en_US" which is valid.

So for a quick solution, go to "System Settings" -> "Locale" and set the country to "System Country" and click the "Apply" button. Then log out or restart your system.

Tags: Kubuntu, Ubuntu, KDE

Farahmand (civilforyou) wrote :

This is a locale bug.

affects: unity-webapps-telegram → langpack-locales (Ubuntu)
Changed in langpack-locales (Ubuntu):
assignee: nobody → Farahmand (civilforyou)
status: Invalid → New
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2014-10-06 21:20, Farahmand wrote:
> This is a locale bug.

No. The fact that the Kubuntu GUI allows you to set invalid language-country combinations has nothing to do with the langpack-locales package.

Besides, the bug reporter has unsubscribed himself. Assuming that possible problems have been fixed.

Changed in langpack-locales (Ubuntu):
assignee: Farahmand (civilforyou) → nobody
status: New → Invalid
Changed in webbrowser-app:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions