landscape-sysinfo - lacks a man page or other documentation

Bug #303274 reported by Jonathan Marsden on 2008-11-28
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Landscape Client
Low
Chris Glass
Landscape Server
Low
Unassigned
landscape-client (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Stefan W.
Nominated for Lucid by Stefan W.

Bug Description

Binary package hint: landscape-common

Ubuntu Release: Ubuntu 8.10 Intrepid

Package Version: landscape-common 1.0.23-0ubuntu0.8.10.1

How to Duplicate:

man landscape-sysinfo

Expected Behaviour: This should display a man page.

Actual Behaviour: No man page exists, so man landscape-sysinfo outputs

No manual entry for landscape-sysinfo
See 'man 7 undocumented' for help when manual pages are not available.

Further Information:

The lack of a man page is a bug per Debian policy 12.1.

Looking for sources of information (per man 7 undocumented) from which to construct one, there is no usage information in /usr/share/doc/landscape-common/ either, beyond a copyright file and a changelog.

dpkg -L landscape-common does not reveal anything looking remotely like documentation. Further, dpkg -l | grep landscape reveals only landscape-common, so there is apparently no landscape-doc package readily available either.

That landscape-sysconfig can be configured is clear from the presence of the /etc/landscape directory in the package, but no example client.conf file is provided, so it is currently impractical to work on configuring this application unless you read the Python source code itself. Some (perhaps most) users will be unable or unwilling to read and understand the source code in order to configure the application.

An example /etc/landscape/client.conf file (posted by Kees in a comment to LP: #268447 ) is:

[sysinfo]
exclude_sysinfo_plugins = LandscapeLink

The filename client.conf is perhaps not ideal here either, in that there may be other client apps on the system with configuration files! Consider man 5 client.conf for example (it displays a man page from cups!). Perhaps this landscape config file could be renamed to include the application name, such as landscape-client.conf, since there is unlikely to be a name collision when doing a (hypothetical) man 5 landscape-client.conf

Related branches

Changed in landscape:
importance: Undecided → Low
milestone: none → mountainview
Changed in landscape-client:
status: New → Confirmed
Andreas Hasenack (ahasenack) wrote :

Let's try to decouple client bugs from server bugs.

Changed in landscape:
status: New → Invalid
Changed in landscape-client:
importance: Undecided → Low
milestone: none → 1.0.x
Changed in landscape-client:
milestone: 1.0.x → 1.5.4
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in landscape-client:
milestone: 1.5.4 → 1.5.5
Changed in landscape-client:
milestone: 1.5.5 → 1.5.6
Changed in landscape-client:
milestone: 1.5.6 → 1.6.0
Changed in landscape-client:
milestone: 1.6.0 → 10.11
Changed in landscape-client:
milestone: 10.11 → 10.12
Jamu Kakar (jkakar) on 2010-11-22
Changed in landscape-client:
milestone: 10.12 → later
Jonathan Marsden (jmarsden) wrote :

More than two years, and nine status changes, have gone by... but still no manpage?

Is writing a man page really much more work than pushing the status of the bug out every single release? :)

Is there documentation for landscape-sysinfo in some other format, and if so, where can it be found?

Andreas Hasenack (ahasenack) wrote :

The only other documentation about the sysinfo tool is its help page:

$ landscape-sysinfo -h
Usage: landscape-sysinfo [options]

Options:
  --version show program's version number and exit
  -h, --help show this help message and exit
  -c FILE, --config=FILE
                        Use config from this file (any command line options
                        override settings from the file) (default:
                        '/etc/landscape/client.conf').
  -d PATH, --data-path=PATH
                        The directory to store data files in (default:
                        '/var/lib/landscape/client/').
  -q, --quiet Do not log to the standard output.
  -l FILE, --log-dir=FILE
                        The directory to write log files to (default:
                        '/var/log/landscape').
  --log-level=LOG_LEVEL
                        One of debug, info, warning, error or critical.
  --ignore-sigint Ignore interrupt signals.
  --ignore-sigusr1 Ignore SIGUSR1 signal to rotate logs.
  --sysinfo-plugins=PLUGIN_LIST
                        Comma-delimited list of sysinfo plugins to use.
                        Default is to use all plugins.
  --exclude-sysinfo-plugins=PLUGIN_LIST
                        Comma-delimited list of sysinfo plugins to NOT use.
                        This always take precedence over plugins to include.

Default plugins: Load, Disk, Memory, Temperature, Processes, LoggedInUsers,
LandscapeLink, Network

Many of those options are not really useful for an end user. The most important ones are about the plugins I suppose, specially because some people prefer to disable the LandscapeLink one.

Jonathan Marsden (jmarsden) wrote :

OK, let's see if we can get things rolling a little here.

Please find attached a very basic landscale-sysinfo.1 man page.

It would be a lot more useful if it included a section on configuration which described the config file format and includes an example, but right now I lack the time and inclination to learn enough about the config file to confidently write that section. Perhaps someone else can add that?

Even as is, it's probably better than nothing.

Jonathan

Andreas Hasenack (ahasenack) wrote :

Thanks, I'll take a look.

Changed in landscape-client:
milestone: later → 11.02
Changed in landscape-client:
status: New → In Progress
Changed in landscape-client:
milestone: 11.02 → 11.03
Changed in landscape-client:
milestone: 11.03 → 11.04
Changed in landscape-client:
status: In Progress → Incomplete
Changed in landscape-client:
milestone: 11.04 → 11.05
Changed in landscape-client:
milestone: 11.05 → 11.06.1
Changed in landscape-client:
milestone: 11.06.1 → backlog
Chris Glass (tribaal) wrote :

Since I'm already doing a pass on the client I'll take the opportunity to fix this.
I'll take the man page from Andreas's branch and make it a txt file (so that we can regenerate it with the same mechanism than other man pages).

Changed in landscape-client:
assignee: Andreas Hasenack (ahasenack) → Chris Glass (tribaal)
status: Incomplete → In Progress
Chris Glass (tribaal) on 2012-09-20
Changed in landscape-client:
status: In Progress → Fix Committed
Changed in landscape-client (Ubuntu):
status: Confirmed → Fix Committed
Changed in landscape-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers