landscape-sysinfo shows usage of /home instead of the root directory

Bug #1499104 reported by Danilcha on 2015-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Landscape Client
Undecided
Dave Jones
landscape-client (Ubuntu)
Wishlist
Dave Jones

Bug Description

I'm on a VDS, Ubuntu 14.04. I only have one real filesystem mounted, and it's mounted on '/'. However, the landscape-sysinfo (and the motd message) writes: Usage of /home: unknown.

Danilcha (danilcha) on 2015-10-04
description: updated
Danilcha (danilcha) wrote :

$ mount
/vz/private/10073 on / type simfs (rw,relatime,usrquota,grpquota)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
none on /dev type devtmpfs (rw,nosuid,noexec,relatime,mode=755)
none on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
none on /sys/fs/cgroup type tmpfs (rw,relatime,size=4k,mode=755)
none on /run type tmpfs (rw,nosuid,noexec,relatime,size=104860k,mode=755)
none on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
none on /run/shm type tmpfs (rw,relatime)
none on /run/user type tmpfs (rw,nosuid,nodev,noexec,relatime,size=102400k,mode=755)

$ landscape-sysinfo --version
14.12-0ubuntu0.14.04

Danilcha (danilcha) wrote :

Still the same on 16.03+bzr834-0ubuntu2.16.04.4

Dave Jones (waveform) wrote :

I suspect this is due to the unusual "simfs" file-system not being in landscape's whitelist of file-systems that are "safe" to probe. I'll take a look at it.

Dave Jones (waveform) on 2018-05-03
Changed in landscape-client (Ubuntu):
assignee: nobody → Dave Jones (waveform)
status: New → In Progress
Dave Jones (waveform) wrote :
Changed in landscape-client:
assignee: nobody → Dave Jones (waveform)
status: New → In Progress
Mathew Hodson (mathew-hodson) wrote :
tags: added: patch-accepted-upstream
Changed in landscape-client:
status: In Progress → Fix Committed
Changed in landscape-client (Ubuntu):
importance: Undecided → Wishlist
Krzysztof Kulesza (prezeskk) wrote :

The same error is when root filesystem is btrfs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions