lam4: Library is improperly linked

Bug #9750 reported by Debian Bug Importer on 2004-10-30
4
Affects Status Importance Assigned to Milestone
lam (Debian)
Fix Released
Unknown
lam (Ubuntu)
High
Matthias Klose

Bug Description

Automatically imported from Debian bug report #278968 http://bugs.debian.org/278968

Debian Bug Importer (debzilla) wrote :

Automatically imported from Debian bug report #278968 http://bugs.debian.org/278968

Debian Bug Importer (debzilla) wrote :

Message-ID: <email address hidden>
Date: Sat, 30 Oct 2004 10:38:30 -0700
From: Daniel Schepler <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: lam4: Library is improperly linked

Package: lam4
Version: 7.1.1-1
Severity: serious
Justification: Sarge RC policy, 5(f).3

frobnitz:/# ldd -r /usr/lib/liblam.so.4.0
        linux-gate.so.1 => (0x00000000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x400f1000)
        libutil.so.1 => /lib/tls/libutil.so.1 (0x40100000)
        libc.so.6 => /lib/tls/libc.so.6 (0x40104000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x41000000)
undefined symbol: dlerror (/usr/lib/liblam.so.4.0)
undefined symbol: dlclose (/usr/lib/liblam.so.4.0)
undefined symbol: dlopen (/usr/lib/liblam.so.4.0)
undefined symbol: dlsym (/usr/lib/liblam.so.4.0)

So the library needs to be linked against -ldl.

This is causing build failures in blacs-mpi.
--
Daniel Schepler "Please don't disillusion me. I
<email address hidden> haven't had breakfast yet."
                                 -- Orson Scott Card

Source: lam
Source-Version: 7.1.1-2

We believe that the bug you reported is fixed in the latest version of
lam, which is due to be installed in the Debian FTP archive:

lam-mpidoc_7.1.1-2_all.deb
  to pool/main/l/lam/lam-mpidoc_7.1.1-2_all.deb
lam-runtime_7.1.1-2_i386.deb
  to pool/main/l/lam/lam-runtime_7.1.1-2_i386.deb
lam4-dev_7.1.1-2_i386.deb
  to pool/main/l/lam/lam4-dev_7.1.1-2_i386.deb
lam4_7.1.1-2_i386.deb
  to pool/main/l/lam/lam4_7.1.1-2_i386.deb
lam_7.1.1-2.diff.gz
  to pool/main/l/lam/lam_7.1.1-2.diff.gz
lam_7.1.1-2.dsc
  to pool/main/l/lam/lam_7.1.1-2.dsc

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Camm Maguire <email address hidden> (supplier of updated lam package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 30 Oct 2004 21:55:55 +0000
Source: lam
Binary: lam4 lam-runtime lam-mpidoc lam4-dev
Architecture: source i386 all
Version: 7.1.1-2
Distribution: unstable
Urgency: high
Maintainer: Camm Maguire <email address hidden>
Changed-By: Camm Maguire <email address hidden>
Description:
 lam-mpidoc - Documentation for the Message Passing Interface standard
 lam-runtime - LAM runtime environment for executing parallel programs
 lam4 - Shared libraries used by LAM parallel programs
 lam4-dev - Development of parallel programs using LAM
Closes: 278968
Changes:
 lam (7.1.1-2) unstable; urgency=high
 .
   * Link liblam against -ldl, Closes: #278968.
Files:
 c77d15b98e131533aa616f47b7cde175 638 devel extra lam_7.1.1-2.dsc
 a4f0769c1b62cfd9a3bf809a76e94592 161835 devel extra lam_7.1.1-2.diff.gz
 41a83ca8b43dda98d2753a3a77e77d89 1872452 devel extra lam4-dev_7.1.1-2_i386.deb
 db0754fdeb120e5c0a95019b02d41272 534714 libs extra lam4_7.1.1-2_i386.deb
 9f15c341227a2302034e617ef37a543c 241308 utils extra lam-runtime_7.1.1-2_i386.deb
 ba156f3e9779aef8dd97984dbdd73b8f 299252 doc extra lam-mpidoc_7.1.1-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBhDuxczG1wFfwRdwRAuL1AJ4rtAXbuzDLq/si8W2ddeIZyD1ZHQCgr2eV
Q2803Z41cIocgpXB96MHXgw=
=B2BH
-----END PGP SIGNATURE-----

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Sat, 30 Oct 2004 21:32:13 -0400
From: Camm Maguire <email address hidden>
To: <email address hidden>
Subject: Bug#278968: fixed in lam 7.1.1-2

Source: lam
Source-Version: 7.1.1-2

We believe that the bug you reported is fixed in the latest version of
lam, which is due to be installed in the Debian FTP archive:

lam-mpidoc_7.1.1-2_all.deb
  to pool/main/l/lam/lam-mpidoc_7.1.1-2_all.deb
lam-runtime_7.1.1-2_i386.deb
  to pool/main/l/lam/lam-runtime_7.1.1-2_i386.deb
lam4-dev_7.1.1-2_i386.deb
  to pool/main/l/lam/lam4-dev_7.1.1-2_i386.deb
lam4_7.1.1-2_i386.deb
  to pool/main/l/lam/lam4_7.1.1-2_i386.deb
lam_7.1.1-2.diff.gz
  to pool/main/l/lam/lam_7.1.1-2.diff.gz
lam_7.1.1-2.dsc
  to pool/main/l/lam/lam_7.1.1-2.dsc

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Camm Maguire <email address hidden> (supplier of updated lam package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sat, 30 Oct 2004 21:55:55 +0000
Source: lam
Binary: lam4 lam-runtime lam-mpidoc lam4-dev
Architecture: source i386 all
Version: 7.1.1-2
Distribution: unstable
Urgency: high
Maintainer: Camm Maguire <email address hidden>
Changed-By: Camm Maguire <email address hidden>
Description:
 lam-mpidoc - Documentation for the Message Passing Interface standard
 lam-runtime - LAM runtime environment for executing parallel programs
 lam4 - Shared libraries used by LAM parallel programs
 lam4-dev - Development of parallel programs using LAM
Closes: 278968
Changes:
 lam (7.1.1-2) unstable; urgency=high
 .
   * Link liblam against -ldl, Closes: #278968.
Files:
 c77d15b98e131533aa616f47b7cde175 638 devel extra lam_7.1.1-2.dsc
 a4f0769c1b62cfd9a3bf809a76e94592 161835 devel extra lam_7.1.1-2.diff.gz
 41a83ca8b43dda98d2753a3a77e77d89 1872452 devel extra lam4-dev_7.1.1-2_i386.deb
 db0754fdeb120e5c0a95019b02d41272 534714 libs extra lam4_7.1.1-2_i386.deb
 9f15c341227a2302034e617ef37a543c 241308 utils extra lam-runtime_7.1.1-2_i386.deb
 ba156f3e9779aef8dd97984dbdd73b8f 299252 doc extra lam-mpidoc_7.1.1-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBhDuxczG1wFfwRdwRAuL1AJ4rtAXbuzDLq/si8W2ddeIZyD1ZHQCgr2eV
Q2803Z41cIocgpXB96MHXgw=
=B2BH
-----END PGP SIGNATURE-----

Matthias Klose (doko) wrote :

fixed in lam (7.1.1-2)

Changed in lam:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.