Kubuntu/Crystal: minimised windows do not resize correctly

Bug #82870 reported by Michael on 2007-02-02
4
Affects Status Importance Assigned to Milestone
kwin-style-crystal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kwin-style-crystal

When a minimised window resizes itself in Kubuntu-Edgy with the Crystal window decorations, the WM clipping area is not adjusted. The following small programme illustrates this:

#include <X11/Xlib.h>
#include <assert.h>
#include <unistd.h>
#include <stdio.h>

#define NIL (0)

int main()
{

    Display *dpy = XOpenDisplay(NIL);
    assert(dpy);

    int blackColor = BlackPixel(dpy, DefaultScreen(dpy));
    Window w = XCreateSimpleWindow(dpy, DefaultRootWindow(dpy), 0, 0,
                                   200, 100, 0, blackColor, blackColor);
    XMapWindow(dpy, w);
    XFlush(dpy);
    printf("The window will be resized when you press [ENTER].\n");
    printf("Please minimize the window first. Then press [ENTER] to continue...
");
    getchar();
    XResizeWindow(dpy, w, 300, 100);
    XFlush(dpy);
    printf("Now maximize the window again, and look what happened!\n");
    printf("Press [ENTER] to exit (!)\n");
    getchar();
    return 0;
}

Michael (michaeljt) wrote :

This is a picture of what it looks like.

bq (balique) wrote :

I found that this problem occurs also when launching a window on a different desktop.

Example :
 * I have set in KDE preferences that window OBJECT NAVIGATOR should open on a desktop 2
 * I launch this program/window from desktop 5
 * Window gets incorrectly clipped - this can be seen on the snapshot attached

- note : with "plastik" theme (or others) this does not occur.
- note : I am able to reproduce this as needed
- note : For me it happens also when a java applet from firefox opens a separate window and I am at that time at a different desktop.

If possible I think that this bug should be renamed to something like Kubuntu - Crystal theme clipping problem, because it looks to be more general than minimizing related.

Jonathan Davies (jpds) wrote :

Can you please test this test with the lastest upload of the package: 1.0.5-0ubuntu1 - and see if the problem remains?

Changed in kwin-style-crystal:
status: New → Triaged
Michael (michaeljt) wrote :

I still see this problem with today's Hardy package installed on a Gutsy system.

Michael (michaeljt) wrote :

BTW, can the package maintainers actually reproduce this?

Michael (michaeljt) wrote :

Sorry, take back the last comment but one - Crystal was not properly loaded when I did the test, it does indeed work with the new version.

Jonathan Thomas (echidnaman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in kwin-style-crystal (Ubuntu):
status: Triaged → Incomplete
Michael (michaeljt) wrote :

I no longer use KDE, so this is not relevant to me. If you don't know of anyone else affected by this you might want to close the bug.

Jonathan Thomas (echidnaman) wrote :

Closing, thanks for the response.

Changed in kwin-style-crystal (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers