kwallet wants to migrate empty kwallet4

Bug #1434052 reported by Jonathan Riddell on 2015-03-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
kwallet-kf5 (Ubuntu)
Low
Unassigned
Vivid
Low
Unassigned
Wily
Undecided
Unassigned

Bug Description

On a fresh install if you connect to a network the first thing that pops up is a dialog to migrate kwallet4. But as a new users there should be nothing in kwallet4.

This may be because kubuntu-settings is making an empty kwallet4, I'll upload a new kubuntu-settings without this to try it out.

TEST CASE:
Add a new user
log in
if you get the kwallet migration dialog on first login you have failed

Jonathan Riddell (jr) on 2015-03-19
Changed in ubuntu:
milestone: none → ubuntu-15.04
tags: added: kubuntu

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1434052/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Jonathan Riddell (jr) wrote :

I uploaded kubuntu-settings which may fix this, need to be checked

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Sherif (ali-sherif10) wrote :

I guess it happened to me too.
Distribution: Kubuntu 15.04.

tags: added: vivid
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in ubuntu:
importance: Undecided → Low
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1434052

tags: added: iso-testing
affects: ubuntu → kubuntu-meta (Ubuntu)
Martin Pitt (pitti) on 2015-04-22
Changed in kubuntu-meta (Ubuntu):
milestone: ubuntu-15.04 → none
Jonathan Riddell (jr) on 2015-04-22
Changed in kubuntu-meta (Ubuntu):
milestone: none → ubuntu-15.10
Jonathan Riddell (jr) wrote :

Uploaded 5.9.0-0ubuntu1.1 to vivid with a patch from upstream now in unapproved queue awaiting approval

http://quickgit.kde.org/?p=kwallet.git&a=commitdiff&h=abb22c194f3b5650f51dce97f2e7ad64c2c33861&hp=5abf45209062d951925199aaccab5e98c05cbca1

description: updated
Jonathan Riddell (jr) wrote :

Wibbly Wallnut will get it in frameworks 5.10

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Hello Jonathan, or anyone else affected,

Accepted into utopic-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

affects: kubuntu-meta (Ubuntu Vivid) → kwallet-kf5 (Ubuntu Vivid)
Changed in kwallet-kf5 (Ubuntu Vivid):
milestone: ubuntu-15.10 → none
tags: added: verification-needed
Changed in kwallet-kf5 (Ubuntu Vivid):
status: Confirmed → In Progress
YAFU (yafu) wrote :

Hello. I did a fresh install one week ago and I'm having this problem:
https://bugs.launchpad.net/ubuntu/+source/kwallet/+bug/1443685
I mention this in case it is related to this report.

Buzzing Robot (buzzingrobot) wrote :

Since I filed what seems to an identical bug (https://bugs.launchpad.net/ubuntu/+source/kwalletmanager/+bug/1446616) I installed 3 kwallet packages from proposed (libkf5wallet-bin, libkf5wallet5, libkwalletbackend5-5)on a new install from the 15.04 release image.

I am still being prompted to migrate a wallet. Launching Muon Update Manager triggers the migration popup. I close the popup. Subsequently in the same session, launching Muon Update Manager does not trigger the migration popup. After a logout or a reboot, it's back.

I was able to configure an account in KMail, via the wizard, without triggering the migration popup. Subsequently, launching KMail does trigger a request to enter a password to open the 'kdewallet' wallet. This repeats each time KMail launches.

Jonathan Riddell (jr) wrote :

I installed the new packages libkf5wallet5:amd64 (5.9.0-0ubuntu1.1)

I created a new user and logged in

there was no prompt to transition to kf5 wallet

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kwallet-kf5 - 5.9.0-0ubuntu1.1

---------------
kwallet-kf5 (5.9.0-0ubuntu1.1) vivid; urgency=medium

  * Add upstream_check-empty-wallet-migration.diff LP: #1434052
 -- Jonathan Riddell <email address hidden> Thu, 23 Apr 2015 15:28:12 +0200

Changed in kwallet-kf5 (Ubuntu Vivid):
status: In Progress → Fix Released

The verification of the Stable Release Update for kwallet-kf5 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

giacof (giacof) wrote :

I have installed the package libkf5wallet5:amd64 version 5.9.0-0ubuntu1.1 and this issue is NOT fixed to me.

As a consequence, I cannot connect to any encrypted Wifi network, as Network Manager keeps asking for the password forever (the passwork is 100% correct as I chose it on my own network).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kwallet-kf5 - 5.10.0-0ubuntu2

---------------
kwallet-kf5 (5.10.0-0ubuntu2) wily; urgency=medium

  * libkf5wallet-data Breaks/Replaces libkf5wallet5 (<< 5.10)

 -- Jose Manuel Santamaria Lema <email address hidden> Mon, 08 Jun 2015 11:06:38 +0200

Changed in kwallet-kf5 (Ubuntu Wily):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.