package kvm-source 1:84+dfsg-0ubuntu11 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Bug #394953 reported by Kenyon Ralph on 2009-07-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Low
Dustin Kirkland 
Jaunty
Low
Unassigned

Bug Description

Binary package hint: kvm

This might be the same as bug #394879.

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess post-installation script returned error exit status 1
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
MachineType: ACCS CAIDA Network Monitor
Package: kvm-source 1:84+dfsg-0ubuntu11
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.28-13-server root=UUID=f569b70e-7bbc-40f7-90b4-f154b662066e ro quiet splash
ProcVersionSignature: Ubuntu 2.6.28-13.45-server
SourcePackage: kvm
Title: package kvm-source 1:84+dfsg-0ubuntu11 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Kenyon Ralph (kralph) wrote :
Dustin Kirkland  (kirkland) wrote :

This a problem that gets reported repeatedly. I have a fix uploading to jaunty-proposed, in conjunction with a much higher SRU.

The kvm-source package is a dkms build of the kvm module. In order to build this, you *must* have the kernel headers installed for any kernel that you want to build kvm and boot.

Currently, we're depending on "linux-headers-server | linux-headers-generic | linux-headers".

This isn't good enough, though, as the user might have linux-headers and linux-headers-generic installed, but is running the linux-server kernel. In which, the dkms build fails, and reports the following helpful, informative message:

*************************************************

ERROR: Missing kernel headers.

You appear to have at least some kernel headers

installed, but you do not have the necessary

headers to build kvm-source against this kernel.

You might try installing the meta package:

 $ sudo apt-get install linux-headers-server

or specifically

 $ sudo apt-get install linux-headers-2.6.28-13-server

to obtain the necessary build dependencies.

*************************************************

This message tells users exactly how to solve the problem, however we still get bug reports by the truckload.

Thus, I'm proposing that we depend on all of "linux-headers-server, linux-headers-generic, linux-headers". This will involve installing extra headers on some systems. However, this is contained to users installing kvm-source, and will help avoid a lot of headaches.

Proposing for SRU, in conjunction with Bug #359447 and Bug #382077.

:-Dustin

Changed in kvm (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
importance: Undecided → Low
milestone: none → jaunty-updates
status: New → In Progress
Changed in kvm (Ubuntu Jaunty):
importance: Undecided → Low
milestone: none → jaunty-updates
status: New → Confirmed
Changed in kvm (Ubuntu Jaunty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:84+dfsg-0ubuntu15

---------------
kvm (1:84+dfsg-0ubuntu15) karmic; urgency=low

  * Cherry-pick qcow2 corruption patch from upstream git
    - Fix-at-least-one-cause-of-qcow2-corruption.-Nolan.patch
  * Cherry-pick dma error handling patch from upstream git, LP: #359447
    - Fix-DMA-API-when-handling-an-immediate-error-from-bl.patch
  * debian/control: depend on linux-server and linux-generic headers;
    this may be a bit overkill, as you only need one of the two,
    however, we don't know which one of the two until postinst;
    because of this, we get *tons* of bug reports about kvm-source not
    being able to build because of missing headers (even though we print
    a helpful warning message in postinst), LP: #394953
  * debian/kvm-source.postinst: touch reboot-required to ensure that
    the new kvm module gets loaded and running

 -- Dustin Kirkland <email address hidden> Tue, 07 Jul 2009 14:06:52 -0500

Changed in kvm (Ubuntu):
status: In Progress → Fix Released

On 2009-07-07T18:52:44-0000, Dustin Kirkland <email address hidden> wrote:
>This message tells users exactly how to solve the problem, however we
>still get bug reports by the truckload.

I think this is because apport suggests to report a bug when the
installation fails. It doesn't know about the helpful message.

Martin Pitt (pitti) wrote :

No, it's because the package fails to install. This should be avoided at all costs, the message should rather say how to fix the problem (install missing packages) and then manually start the build process. Or, already fail in the preinst, so that you don't end up with unconfigured packages in your system. However, I'm fine with adding all the -headers dependencies.

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted kvm into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Dustin Kirkland  (kirkland) wrote :

To verify this, you will need a rather trim system, without kvm, build-essential, dkms, or much along the lines of kernel headers. Enable -proposed and 'apt-get install kvm-source'. That should pull in a stack of build dependencies and headers, and the kvm module should then build, using dkms.

:-Dustin

On 2009-07-10T12:36:26-0000, Dustin Kirkland <email address hidden> wrote:
>To verify this, you will need a rather trim system, without kvm, build-
>essential, dkms, or much along the lines of kernel headers. Enable
>-proposed and 'apt-get install kvm-source'. That should pull in a stack
>of build dependencies and headers, and the kvm module should then build,
>using dkms.

I should be able to verify this fix with a fresh server install next
week.

Kenyon Ralph (kralph) wrote :

I just installed kvm-source 1:84+dfsg-0ubuntu15 on a latest karmic server install. It installed cleanly.

tags: added: verification-done
removed: verification-needed
Kenyon Ralph (kralph) wrote :

Just installed kvm-source 1:84+dfsg-0ubuntu12.3 from jaunty-proposed on a fresh jaunty server install with all updates. Installed cleanly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:84+dfsg-0ubuntu12.3

---------------
kvm (1:84+dfsg-0ubuntu12.3) jaunty-proposed; urgency=low

  * Cherry-pick qcow2 corruption patch from upstream git
    - Fix-at-least-one-cause-of-qcow2-corruption.-Nolan.patch,
    LP: #392295
  * Cherry-pick patch series from upstream to fix segfaults when
    cancelling DMA operations in virtual machines. LP: #359447
  * Cherry-pick dma error handling patch from upstream git, LP: #359447
    - Fix-DMA-API-when-handling-an-immediate-error-from-bl.patch
  * debian/control: depend on linux-server and linux-generic headers;
    this may be a bit overkill, as you only need one of the two,
    however, we don't know which one of the two until postinst;
    because of this, we get *tons* of bug reports about kvm-source not
    being able to build because of missing headers (even though we print
    a helpful warning message in postinst), LP: #394953
  * debian/kvm-source.postinst: touch reboot-required to ensure that
    the new kvm module gets loaded and running
  * debian/source_kvm.py: only collect packages related to kvm for apport,
    LP: #382077

 -- Dustin Kirkland <email address hidden> Tue, 07 Jul 2009 14:22:26 -0500

Changed in kvm (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers