Ubuntu

Kvm-84 qcow2 problems

Reported by Frank Groeneveld on 2009-06-25
6
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
High
Dustin Kirkland 
Jaunty
High
Unassigned

Bug Description

Binary package hint: kvm

After installing the update from #361938, one of my virtual machines appeared to have a corrupt qcow2 image. Fsck just kept on fixing the same errors, so I decided to do a reinstall for that vm.
After creating a new qcow2 image and starting the installer, after the partitioning phase the installer fails to mount any vda devices. These errors show up in dmesg:
[ 187.756390] end_request: I/O error, dev vda, sector 20047866

I tried to do a reinstall on a raw file and that finished succesfully. I convert the raw image to qcow2 and tried to boot that, but it hangs after the filesystem check (which doesn't find any errors).

My other "old" qcow2 virtual machine that did not get corrupt seems fine.

Changed in kvm (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Hi Frank-

I just uploaded a new kvm to karmic that has a cherry pick which should fix this issue. Marking 'Fix Released'.

:-Dustin

Changed in kvm (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Dustin Kirkland  (kirkland) wrote :

Also, there's an upload of kvm-84 in jaunty-proposed which should fix this as well as several other bugs (392295, 359447, 394953, 382077).

I'm marking this high. Please test that package if you're able.

:-Dustin

Changed in kvm (Ubuntu Jaunty):
importance: Undecided → High
milestone: none → jaunty-updates
status: New → Fix Committed

You meant the kvm from the ppa? I installed it an I'm now able to boot from qcow2 devices again. Thanks for fixing this! Keep up the good work.

On Tue, Jul 7, 2009 at 3:18 PM, Frank
Groeneveld<email address hidden> wrote:
> You meant the kvm from the ppa? I installed it an I'm now able to boot
> from qcow2 devices again. Thanks for fixing this! Keep up the good work.

Yes, thanks. Awesome!

Once this build makes it into jaunty-proposed, I'd appreciate it if
you'd circle back test that package, and add a note. That will help
get the SRU through.

Thanks,
:-Dustin

> Once this build makes it into jaunty-proposed, I'd appreciate it if
> you'd circle back test that package, and add a note. That will help
> get the SRU through.

Sure, but I'm running Hardy (8.04 LTS) :p

Frank

Martin Pitt (pitti) wrote :

Accepted kvm into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Dustin Kirkland  (kirkland) wrote :

Martin-

 * This bug was reported and commented on by a single reporter.
 * I found an upstream git commit message that specifically matched his concern.
 * The reporter tested this package with the new patch in a PPA building it specifically for Hardy.
 * The reporter confirmed the fix there.
 * The -proposed SRU package included that patch.

I'm not confident that we will find another individual experiencing this particular problem, who can confirm the fix, in a reasonable amount of time.

In this case, is it reasonable to accept verification of the fix as published in the PPA built for Hardy?

:-Dustin

Martin Pitt (pitti) wrote :

Ideally the reporter could test the actual .debs in jaunty-proposed.

If that's not possible, I'm also okay with someone else giving the jaunty-proposed .debs a good regression test beating. We need to ensure that the packages have been built correctly (we did have cases where an underlying toolchain or library ABI change completely broke the packages).

Dustin Kirkland  (kirkland) wrote :

Frank,

Any idea how I might try to reproduce this error?

Do you happen to have a qcow2 image that you were seeing this problem on, that you would be willing to share with me? (ie, an image with no sensitive data)?

:-Dustin

As Dustin said, I'm not able to test them in anything but Hardy.
The images are quite big (> 18gb), although they have a lot less
actual data, so I think it would be hard to share them with you,
Dustin. Or do you happen to know a tool to "shrink" the actual usage
down?

Frank

I think the way to reproduce this is: install hardy in the VM, update the kernel, see if it boots. This is basically what failed for me. Also, be sure to use virtio for network and disk (as I did).
You can even try to run the old version from the ppa, to see if you can reproduce my bug and than upgrade and try if it's fixed.

Today I had temporary access to another computer with VT, running Jaunty. I couldn't reproduce the bug I had on Hardy with the default installed version, but I also didn't find any problems with the -proposed version.

Frank

Martin Pitt (pitti) wrote :

The update was tested in the three other bugs, and this patch was confirmed to work on hardy. I think that is a sufficient basis to consider this verified.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:84+dfsg-0ubuntu12.3

---------------
kvm (1:84+dfsg-0ubuntu12.3) jaunty-proposed; urgency=low

  * Cherry-pick qcow2 corruption patch from upstream git
    - Fix-at-least-one-cause-of-qcow2-corruption.-Nolan.patch,
    LP: #392295
  * Cherry-pick patch series from upstream to fix segfaults when
    cancelling DMA operations in virtual machines. LP: #359447
  * Cherry-pick dma error handling patch from upstream git, LP: #359447
    - Fix-DMA-API-when-handling-an-immediate-error-from-bl.patch
  * debian/control: depend on linux-server and linux-generic headers;
    this may be a bit overkill, as you only need one of the two,
    however, we don't know which one of the two until postinst;
    because of this, we get *tons* of bug reports about kvm-source not
    being able to build because of missing headers (even though we print
    a helpful warning message in postinst), LP: #394953
  * debian/kvm-source.postinst: touch reboot-required to ensure that
    the new kvm module gets loaded and running
  * debian/source_kvm.py: only collect packages related to kvm for apport,
    LP: #382077

 -- Dustin Kirkland <email address hidden> Tue, 07 Jul 2009 14:22:26 -0500

Changed in kvm (Ubuntu Jaunty):
status: Fix Committed → Fix Released
nentis (krisa-opensourcery) wrote :

This week I applied the latest updates to 9.04 which included this KVM update (1:84+dfsg-0ubuntu12.3) supposedly fixing a qcow2 corruption issue.

It wasn't until after I applied these updates that I started having IO errors inside my VM guests which were qcow2. Has anyone else experience this? I can send more data if needed.

Martin Pitt (pitti) wrote :

nentis, do you have some details about that? Such as /var/log/kern.log from the guest?

You got these errors because the image was corrupt already, but the
old unpatched version couldn't see that. I had the same with my old
images.

Frank

2009/7/29 Martin Pitt <email address hidden>:
> nentis, do you have some  details about that? Such as /var/log/kern.log
> from the guest?
>
> --
> Kvm-84 qcow2 problems
> https://bugs.launchpad.net/bugs/392295
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers