Ubuntu

keyboard arrows keys doesn't working (evdev problem)

Reported by Bruno Ribeiro on 2009-05-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Low
Unassigned

Bug Description

Package: kvm
Version: 1:84+dfsg-0ubuntu11
Distro: Ubuntu 9.04 amd64

My keyboard arrows doesn't woking on kvm, even if I connect with vnc.
In SDL mode it gives the following message every time I press an arrow key:
qemu: warning: unknown keycodes `evdev(abnt2)_aliases(qwerty)'

Soren Hansen (soren) wrote :

Which VNC client did you use and how did you invoke kvm?

Hugo Melo (hugo-melo) wrote :

Had this same issue running a qemu with kqemu:
# sudo qemu -hda /dev/sda -m 800
On the grub menu, I coudn't use arrow keys and got the same message. Off course, using a keyboard layout abnt2. After that I typed:
# setxkbmap -layout us -model us
 and restarted qemu command. Worked fine!
I am running Intrepid:

Hugo Melo (hugo-melo) wrote :

dmesg

Changed in kvm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

I invoke kvm with: kvm -hda /home/bruno/kvm/example.img -net user -net nic -localtime, I'm not using vnc to see my kvm console, I'm using SDL.

I'm sorry by my answer delay, I don't see the last question about how I invoke kvm.

Changed in kvm (Ubuntu):
status: Incomplete → New
Chuck Short (zulcss) on 2009-10-14
Changed in kvm (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers