package kvm-source 1:84+dfsg-0ubuntu7 failed to install/upgrade:

Bug #341159 reported by Michael Vogt on 2009-03-11
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dkms (Ubuntu)
High
Dustin Kirkland 
Jaunty
High
Dustin Kirkland 
kvm (Ubuntu)
High
Dustin Kirkland 
Jaunty
High
Dustin Kirkland 
linux (Ubuntu)
Undecided
Dustin Kirkland 
Jaunty
Undecided
Dustin Kirkland 

Bug Description

Binary package hint: kvm

Happend during a intrepid->hardy upgrade

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage:
 ErrorMessage: subprocess post-installation script returned error exit status 10
Package: kvm-source 1:84+dfsg-0ubuntu7
PackageArchitecture: all
SourcePackage: kvm
Title: package kvm-source 1:84+dfsg-0ubuntu7 failed to install/upgrade:
Uname: Linux 2.6.27-11-generic i686

Related branches

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

From the log:

Setting up kvm-source (1:84+dfsg-0ubuntu7) ...
Removing all [kvm-84] DKMS Modules
Error! There are no instances of module: kvm
84 located in the DKMS tree.
Done.
Adding [kvm-84] Module to DKMS build system
Doing initial module build
Error! Bad return status for module build on kernel: 2.6.27-11-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/kvm/84/build/ for more information.
dpkg: error processing kvm-source (--configure):
 subprocess post-installation script returned error exit status 10

Colin Watson (cjwatson) on 2009-03-11
Changed in kvm:
importance: Undecided → High

Hrm, I thought I had fixed this ...

dkms baffles me sometimes. I'll take a deeper look.

:-Dustin

Changed in kvm:
assignee: nobody → kirkland
status: New → Triaged
Dustin Kirkland  (kirkland) wrote :

Okay, Michael-

This is a nasty one ...

kvm-source is going to need the linux-headers for the kernel you're currently running, as well as any others you have installed.

A distro-upgrade (or anytime you're upgrading the kernel, too) compounds the problem. You're running one kernel, but you need to ensure that you have the headers for the new kernel too.

I'm going to sort-of alleviate the problem in kvm by adding a dpkg --status check for linux-headers-`uname -r`, and if not present, then print an informational statement about the problem, and recommend a command that will install the required dependencies.

I'm going to also set this bug as affecting dkms, and add a suggestion there too.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

Mario-

What would you think about dkms depending on all of:
 linux-headers-rt, linux-headers-virtual, linux-headers-server, linux-headers-generic

For the most part, the additional headers will just install a bunch of symlinks, and should not require a bunch of additional disk space.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

I've attached a patch, which adds
 * linux-headers-rt, linux-headers-virtual, linux-headers-server
to the Recommends.

Mario, what do you think?

:-Dustin

Changed in dkms:
assignee: nobody → kirkland
importance: Undecided → High
status: New → Triaged
Changed in kvm:
status: Triaged → Fix Committed
Mario Limonciello (superm1) wrote :

Dustin:

I don't think that's a good idea. Because recommends are installed by
default, it will pull in a lot of headers that are not necessary on a
majority of user's systems.

On Wed, Mar 11, 2009 at 18:45, Dustin Kirkland <email address hidden>wrote:

> I've attached a patch, which adds
> * linux-headers-rt, linux-headers-virtual, linux-headers-server
> to the Recommends.
>
> Mario, what do you think?
>
> :-Dustin
>
> ** Attachment added: "out.diff"
> http://launchpadlibrarian.net/23766611/out.diff
>
> ** Changed in: dkms (Ubuntu Jaunty)
> Importance: Undecided => High
> Assignee: (unassigned) => Dustin Kirkland (kirkland)
> Status: New => Triaged
>
> --
> package kvm-source 1:84+dfsg-0ubuntu7 failed to install/upgrade:
> https://bugs.launchpad.net/bugs/341159
> You received this bug notification because you are subscribed to dkms in
> ubuntu.
>

--
Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

I would rather see those headers as recommends for the appropriate kernel meta packages. That way if someone adds the server kernel via the meta package, they get the server headers, etc.

Dustin Kirkland  (kirkland) wrote :

Mario/Tim-

You guys are going to have to duke this out ...

I'm going to mark Bug #341405 a duplicate of this one.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

Mario-

The downside of latching the headers onto the kernel is that it automatically adds 75MB of headers to a given install, even if DKMS is not used.

Tough one...

:-Dustin

Mario Limonciello (superm1) wrote :

Dustin:

Well look at it this way. Look at the rdepends of linux-headers-generic.
It's pulled in by all the desktop packages. So the argument's two sides
then end up being:

1) Add a bunch of unnecessary dependencies to *all* desktop installs that
use DKMS.
2) Add appropriate dependencies to meta packages of any possible kernel
meta, and don't need to worry about headers being installed on systems since
they are there by default now for all situations.

On Wed, Mar 11, 2009 at 21:31, Dustin Kirkland <email address hidden>wrote:

> Mario-
>
> The downside of latching the headers onto the kernel is that it
> automatically adds 75MB of headers to a given install, even if DKMS is
> not used.
>
> Tough one...
>
> :-Dustin
>
> --
> package kvm-source 1:84+dfsg-0ubuntu7 failed to install/upgrade:
> https://bugs.launchpad.net/bugs/341159
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Mario Limonciello
<email address hidden>

Dustin Kirkland  (kirkland) wrote :

On Wed, Mar 11, 2009 at 9:56 PM, Mario Limonciello <email address hidden> wrote:
> 2) Add appropriate dependencies to meta packages of any possible kernel
> meta, and don't need to worry about headers being installed on systems since
> they are there by default now for all situations.

The issue with this is it adds 75MB to the server footprint, which is
only ~500MB to start with. I'll talk it over with the server team and
see what they think about this tradeoff.

:-Dustin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:84+dfsg-0ubuntu8

---------------
kvm (1:84+dfsg-0ubuntu8) jaunty; urgency=low

  * debian/patches/dkmsify.patch: handle i686 arch properly, LP: #333632
  * debian/control: kvm-source needs kernel headers
  * debian/kvm-source.postinst: check if necessary headers are installed;
    if not, print a handy error message with instructions, LP: #341159
  * debian/kvm.init: use proper lsb begin/end message logging for cleaner
    usplash interaction, LP: #275009
  * debian/rules, debian/control: Enable pulseaudio audio driver, LP: #304649

 -- Dustin Kirkland <email address hidden> Thu, 12 Mar 2009 00:17:04 -0500

Changed in kvm:
status: Fix Committed → Fix Released
Pete Graner (pgraner) on 2009-03-20
Changed in linux:
assignee: nobody → kirkland
Changed in linux (Ubuntu Jaunty):
status: New → Won't Fix
Changed in dkms (Ubuntu Jaunty):
status: Triaged → Won't Fix
Changed in dkms (Ubuntu):
status: Triaged → Won't Fix
Changed in linux (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches