Intrepid fails to install onto virtio block device

Bug #279754 reported by Niklas Hagman on 2008-10-07
4
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
High
Dustin Kirkland 

Bug Description

Binary package hint: kvm

Installing intrepid beta1 onto a virtio enabled block device, and it fails under the stage "Installing Base System".

/dev/vda (virtio) + intrepid = not working
/dev/hda (normal) + intrepid = working

Have tried raw disk (lv, lvm) and image disk (qcow2).
Using ubuntu 8.10 beta1
kvm-75 compiled from source

Niklas Hagman (blinkiz) wrote :
Niklas Hagman (blinkiz) wrote :

Temporary solution for this is to install intrepid without having the virtual hard drive accessed the virtio way. Just plain simple /dev/hda type. After installation is finish, I shutdown the machine and switch to virtio block device. The change to /dev/vda is not a problem because UUID is used.

Hardy can be installed with virtio enabled.
Intrepid network works under the installation with virtio-net enabled.
Intrepid partitioning under the installation works with virtio enabled.

I will need to reinstall a machine with Intrepid/LVM to reproduce
this. Give me a day or two.

:-Dustin

Niklas Hagman (blinkiz) wrote :

Using a simple image file as block device and the installation will also fail. No need for LVM to reproduce this. I used the default "raw" as file format for the image file.

On Tue, Oct 7, 2008 at 4:15 PM, Blinkiz <email address hidden> wrote:
> Using a simple image file as block device and the installation will also
> fail. No need for LVM to reproduce this. I used the default "raw" as
> file format for the image file.

Can you give me step-by-step instructions?

I'm starting with:
 $ qemu-img create -f qcow2 foo.img 2G

Then kvm ..... something.
 $ kvm -m 256 -hda foo.img

I'm guessing something else needs to be used there for virtio.

:-Dustin

On Tue, Oct 07, 2008 at 10:12:41PM -0000, Dustin Kirkland wrote:
> On Tue, Oct 7, 2008 at 4:15 PM, Blinkiz <email address hidden> wrote:
> > Using a simple image file as block device and the installation will also
> > fail. No need for LVM to reproduce this. I used the default "raw" as
> > file format for the image file.
>
> Can you give me step-by-step instructions?
>
> I'm starting with:
> $ qemu-img create -f qcow2 foo.img 2G
>
> Then kvm ..... something.
> $ kvm -m 256 -hda foo.img

Try:

 kvm -m 256 -drive file=foo.img,if=virtio

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Niklas Hagman (blinkiz) wrote :

> Can you give me step-by-step instructions?
Sure. I should have done it from the beginning of this bug report. Sorry about that.

-- Steps to reproduce --
* Create a new image file with "qemu-img create myfile.img 5G". Default should be "raw". You can check it with "qemu-img info myfile.img".
* Start kvm. "sudo kvm -drive file=myfile.img,if=virtio,boot=on -drive file=../iso/ubuntu-8.10-beta-server-i386.iso,media=cdrom -boot d"

  • syslog Edit (668.1 KiB, application/octet-stream; name=syslog)

Okay, thanks for the instructions. I have reproduced the problem.

I'm posting the syslog here.

:-Dustin

Niklas Hagman (blinkiz) on 2008-10-09
Changed in kvm:
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :
  • syslog Edit (2.6 MiB, application/octet-stream; name=syslog)

I just downloaded the latest daily iso, including Colin's fix.

67aca2a9b4186ec7d2a506f508ca6433 intrepid-server-amd64.iso

The virtio disk is once again detected by the installer. That's good.

The installation proceeds without incident, and completes successfully.

However, the installed system is unbootable (either as a virtio
device, or regular disk). This looks to be an issue with the
bootloader.

I'm attaching a debug /var/log/syslog. I don't see anything obvious
in here yet. I'm going to run grub-installer by hand and inject some
debug information next.

:-Dustin

Niklas Hagman (blinkiz) wrote :

Also tried latest (67aca2a9b4186ec7d2a506f508ca6433) but I get stuck when the installer is "Retrieving libc6-udeb" under the process "Loading additional components".

Mathias Gug (mathiaz) on 2008-10-10
Changed in kvm:
assignee: nobody → kirkland
importance: Undecided → Medium
milestone: none → ubuntu-8.10
status: Confirmed → Triaged
importance: Medium → High
Dustin Kirkland  (kirkland) wrote :

The current bug, as described is fixed.

Using today's server ISO, I was able to perform multiple installations, to completion on virtio devices.

I'm marking this bug as "fix released".

That is not the end of the story, though. I have opened a new bug, Bug #281492, as the grub installer seems to be buggy when installing to a virtio disk. Hence, installed systems are not yet bootable. I'm currently working this. Please post relevant comments to that bug.

:-Dustin

Changed in kvm:
status: Triaged → Fix Released
Niklas Hagman (blinkiz) wrote :

Yeah, can also confirm that this is fixed. Having the same problem with bug #281492 as Dustin.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers