KVM init script screws with usplash

Bug #275009 reported by Hernando Torque on 2008-09-27
2
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Low
Dustin Kirkland 

Bug Description

When booting with usplash in verbose mode the kvm log line is out of place and destroys the clean look of the boot process.

This is caused by the calls of log_failure_msg and log_success_msg (/etc/lsb-base-logging.sh) in /etc/init.d/kvm which will turn those long descriptions to status strings for usplash via usplash_write "STATUS $*".

Using Hardy 8.04.1 with kvm 1:62+dfsg-0ubuntu8.

Edit: After fixing another glitch this still is a problem => so this report isn't invalid.

Related branches

Changed in kvm:
status: New → Invalid
description: updated
Changed in kvm:
status: Invalid → New
description: updated
Hernando Torque (htorque) wrote :

Also a problem on an up-to-date Intrepid test machine.

Not a big deal but reduces the existence of a graphical boot screen to absurdity.

I disabled the messages, adding log_begin_msg/log_end_msg would be a more desirable I guess but as I'm not familiar enough with the whole logging process I won't add a patch.

On Sat, Sep 27, 2008 at 12:29:15AM -0000, Hernando Torque wrote:
> When booting with usplash in verbose mode the kvm log line is out of
> place and destroys the clean look of the boot process.

What exactly is the text you're seeing in the bootsplash?

Hernando Torque (htorque) wrote :

Well, one of the log messages defined in /etc/init.d/kvm.

I attached a video clip of one the machines boot process (altered the usplash theme to make it more clear).

Two different Intrepid machines (one doesn't support kvm) and one hardy laptop - they all show this behavior. /etc/init.d/checkrootfs.sh and /lib/init/usplash-fsck-functions.sh also cause problems.

I'll fix this after the beta is out.

Hernando Torque (htorque) wrote :

Thanks! I attached a patch how I changed it locally. Maybe you want to log the detailed messages somewhere else but as I said I'm not too familiar with the logging process.

Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "kvm_log.patch" was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. Thanks for your contribution Hernando Torque!

Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "kvm_init_script.avi" was not flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug and this attachment is one! Subsequently, I've checked the patch flag for it. In the future when submitting patches please use the patch checkbox as there are some Launchpad searches that use this feature. Thanks for your contribution Hernando Torque!

Brian Murray (brian-murray) wrote :

Soren could you look at this for Jaunty?

Changed in kvm:
importance: Undecided → Low
status: New → Triaged
Hernando Torque (htorque) wrote :

I didn't flag it as patch since Soren Hansen already said he'll fix it. Fixing this is a drop in the bucket anyway, Plymouth seems to be more robust when it comes down to verbose mode.

Dustin Kirkland  (kirkland) wrote :

Thanks for the report, and the patch.

I'm sorry Soren never got around to committing this patch sooner.

I'm applying it and committing it Jaunty now. This will be released after the Alpha6 freeze is over.

Cheers,
:-Dustin

Changed in kvm:
assignee: nobody → kirkland
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:84+dfsg-0ubuntu8

---------------
kvm (1:84+dfsg-0ubuntu8) jaunty; urgency=low

  * debian/patches/dkmsify.patch: handle i686 arch properly, LP: #333632
  * debian/control: kvm-source needs kernel headers
  * debian/kvm-source.postinst: check if necessary headers are installed;
    if not, print a handy error message with instructions, LP: #341159
  * debian/kvm.init: use proper lsb begin/end message logging for cleaner
    usplash interaction, LP: #275009
  * debian/rules, debian/control: Enable pulseaudio audio driver, LP: #304649

 -- Dustin Kirkland <email address hidden> Thu, 12 Mar 2009 00:17:04 -0500

Changed in kvm:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers