occasional boot hangs after installs with kvm smp

Bug #221059 reported by Jamie Strandboge on 2008-04-23
2
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Undecided
Unassigned

Bug Description

Doing iso testing with Ubuntu Server amd64 [20080423.2] from http://iso.qa.ubuntu.com/qatracker/info/1612 using kvm with a 64bit, 2 vcpu, 128M ram, 1G non-preallocated disk, Ubuntu/Hardy install.

I have performed several installs with no issues. However, one time on the 1st reboot after a default installation, the boot hung with only:

Kernel alive
kernel direct mapping tables up to 100000000 @ 8000-d000

displayed on the screen. Subsequent reboots were fine. I did wait at least 10 minutes without it starting.

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Jamie Strandboge (jdstrand) wrote :

I gave everything that is needed-- perform a hardy install with the above parameters for the vm.

Jamie Strandboge (jdstrand) wrote :

I am remarking as 'new' as all the information is present. I also cannot confirm that this is a 'linux' bug-- it could be kvm.

The bug is reproducible in that I have seen it happen in several installs with this ISO. However, it is not always the 'first reboot'. It is 'occasionally on boot', so I updated the description as such.

Changed in linux:
status: Incomplete → New
Jamie Strandboge (jdstrand) wrote :

Re-assigning to kvm as this seems the more likely candidate right now.

Rick Clark (dendrobates) wrote :

hmm... This occurred regularly with the 7.10 version of kvm. Perhaps 50% of the time. I haven't seen it yet in Hardy.

Jamie Strandboge (jdstrand) wrote :

I was testing this with -server kernel on the host as well as guest, and still got hangs-- but one time I hit the soft lockup bug 221032, so this bug may be related to that one.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? If it is, feel free to change its status to confirmed since the report appears to contain enough information for a developer to begin work. Thanks in advance.

(To Clarify: My initial question was more about *has it happened more than once* not about the steps, which you are correct in saying are present. Too much triaging and I forget to customize the generic reproducibility comment. Sorry about that.)

Jamie Strandboge (jdstrand) wrote :

Marking as Fix Released since I haven't seen this happen during the Jaunty cycle.

Changed in kvm:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers