Ubuntu

32-bit binaries fail in 64-bit kvm (breaks grub installation)

Reported by to be removed on 2008-04-18
4
Affects Status Importance Assigned to Milestone
kvm (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: grub

I'm doing QA testing on hardy images as of today, testing various images on kvm. For the Ubuntu desktop amd64 cd, and Kubuntu amd64 DVD installation both fail at grub installation, saying ""Executing 'grub-install (hd0)' failed. This is a fatal error.". This seems to be completely repeatable. Steps to repeate:

* qemu-img create -f qcow2 foo.qemu 100G
* kvm -m 1024 -hda foo.qemu -cdrom /path/to/the.iso -boot d
* install as normally

Henrik Omma tells me on IRC that he has just managed to complete an installation with Ubuntu amd64 server in KVM, so it is probably not a KVM problem.

The md5sums of the images:

84bcc78154076ca4f2306319c73c186a ubuntu/hardy-desktop-amd64.iso
20f60ad776224ac3b8fd3047ae949880 kubuntu/hardy-dvd-amd64.iso

I'll be happy to provide any logs you may require, or the entire (failed) qemu image, which is around 524 megabytes (lzma compressed).

This seems possibly related to #218112, but since that seems to have been fixed, this might be a new problem.

Related branches

Henrik Nilsen Omma (henrik) wrote :
Changed in grub:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :
Colin Watson (cjwatson) wrote :

The actual error here is not shown in the debug file, but I expect it would be in /var/log/syslog.

Colin Watson (cjwatson) wrote :

I don't think it's obvious that this is the same bug as in 181812, even though they have the same symptoms. (GRUB might fail to install for several different reasons.)

Henrik Nilsen Omma (henrik) wrote :
Colin Watson (cjwatson) wrote :

Soren says that any i386 binary run from the amd64 live environment fails in the same way, which seems pretty terrible. Bumping to critical.

Changed in linux:
importance: Undecided → Critical
Colin Watson (cjwatson) wrote :

Also apparently just in kvm.

Soren Hansen (soren) wrote :

This turned out to be a bug in kvm's vmport implementation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kvm - 1:62+dfsg-0ubuntu6

---------------
kvm (1:62+dfsg-0ubuntu6) hardy; urgency=low

  * vmport_save_regs.patch:
    - Only save and restore eax, ebx, ecx, edx, esi, and edi registers in
      vmport_ioport_read.
      (LP: #219165)

 -- Soren Hansen <email address hidden> Sat, 19 Apr 2008 01:47:15 +0200

Changed in kvm:
status: Confirmed → Fix Released
jason tower (jtower) wrote :

i have kvm 1:62+dfsg-0ubuntu6 installed (hardy 64bit) and still experience the grub failure when installing hardy 32bit

Nick Barcet (nijaba) on 2008-04-21
Changed in kvm:
status: Fix Released → New
Soren Hansen (soren) on 2008-04-21
Changed in kvm:
status: New → Incomplete
Soren Hansen (soren) wrote :

I cannot reproduce this. I just completed a succesful install of i386 desktop. Anyone else?

to be removed (liw) wrote :

I just completed a successful i386 desktop install, too, with current hardy version of kvm.

Henrik Nilsen Omma (henrik) wrote :

Works fine here as well now. -> Fix Released.

Changed in kvm:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers