kvm crashes on load on Intel CPUs (exception 12)

Bug #107172 reported by Christian Schürer-Waldheim on 2007-04-17
70
Affects Status Importance Assigned to Milestone
gfxboot (Ubuntu)
Low
Unassigned
kvm (Ubuntu)
High
Ubuntu Server Team

Bug Description

Binary package hint: kvm

I've kvm (16-1ubuntu2) installed. When I try to install the ubuntu server (feisty) CD image, the following error message is printed:

exception 12 (0)
rax 000000000000051f rbx 0000000000040080 rcx 0000000000002000 rdx 0000000000016400
rsi 00000000ffff0800 rdi 0000000000040000 rsp 0000000000087bdc rbp 0000000000000000
r8 0000000000000000 r9 0000000000000000 r10 0000000000000000 r11 0000000000000000
r12 0000000000000000 r13 0000000000000000 r14 0000000000000000 r15 0000000000000000
rip 000000000000a4bc rflags 00033206
cs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ds 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
es 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ss 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
fs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
gs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
tr 0000 (20850000/00002088 p 1 dpl 0 db 0 s 0 type b l 0 g 0 avl 0)
ldt 0000 (00000000/0000ffff p 1 dpl 0 db 0 s 0 type 2 l 0 g 0 avl 0)
gdt fa4d1/37
idt 0/3ff
cr0 60000010 cr2 0 cr3 0 cr4 0 cr8 0 efer 0
Aborted (core dumped)

With kvm 18-1ubuntu1 I didn't get this error message, but kvm didn't work with this version.

To sum up: version 18 can't use the kernels kvm module, and version 16 crashes.

edschofield (schofield) wrote :

I can reproduce this every time with kvm_16-1ubuntu2 on an HP Compaq dc7700p desktop system with Intel VT enabled in the BIOS (v2.09) running Feisty x86_64 (kernel 2.6.20-15). This happens with out without -no-acpi or -no-rtc.

My system log has hundreds of lines like the following:
[ 3271.013496] rtc: lost some interrupts at 1024Hz.

with the occasional:
[ 3229.167184] kvm: msrs: 6

A gdb backtrace is attached (but it's probably useless, since kvm is compiled without debugging symbols).

edschofield (schofield) on 2007-04-19
Changed in kvm:
status: Unconfirmed → Confirmed
edschofield (schofield) wrote :

This is a known problem with Intel CPUs:

http://kvm.qumranet.com/kvmwiki/Intel_Real_Mode_Emulation_Problems

This also seems to affect the latest upstream versions (e.g. kvm-19).

Chuck Short (zulcss) on 2007-07-01
Changed in linux-source-2.6.22:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Can the server team please have a look to see what more information we need on this bug?

Changed in kvm:
assignee: nobody → ubuntu-server
importance: Undecided → High
Ante Karamatić (ivoks) wrote :

This is caused by ubuntu splash inside isolinux. Remastering CD with commented GFXBOOT in isolinux/isolinux.cfg solves the issue.

Is this also why WinXP dies when I get to the initial splash screen? I can run WinXP with VMWare, but not KVM.

Jon Anderson wrote:

> Is this also why WinXP dies when I get to the initial splash screen? I
> can run WinXP with VMWare, but not KVM.

I doubt. Try with -no-acpi.

I did/do.

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team
Rick Clark (dendrobates) wrote :

This is a problem with gfxboot. Although it would be nice if kvm handled it instead of dumping core. It has been fixed for Hardy.

The work around is to install with qemu instead of kvm. You can then boot the image with kvm.

Changed in linux-source-2.6.22:
assignee: ubuntu-kernel-team → nobody
importance: Undecided → Low
status: Confirmed → Won't Fix
Soren Hansen (soren) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Hardy Heron.

Changed in kvm:
status: Confirmed → Fix Released
mevdschee (mevdschee) wrote :

I got Exception 13 after the first reboot during the windows xp install

see: https://bugs.launchpad.net/ubuntu/+source/kvm/+bug/105195

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments