Kubuntu registers itself in /boot/grub/menu.lst as Ubuntu

Bug #366535 reported by lunix on 2009-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kubuntu-settings (Ubuntu)
Wishlist
Harald Sitter

Bug Description

Binary package hint: grub-choose-default

I installed Ubuntu first and then Kubuntu as a dual boot on a 160-GB harddrive.
All went well.

The only problem is that Kubuntu registers itself in /boot/grub/menu.lst as Ubuntu
so I have two Ubuntu's and I can't determine which is which without actually
booting them.

This is trivial I realize since anyone that knows how can edit menu.lst but
none the less it makes it confusing.

Kjell Braden (afflux) wrote :

Thanks for your time to report this bug. I'll change the affected package to grub, as grub-choose-default only is a piece of software which changes the current "default" setting (ie. the entry that gets bootet next time) in grub's menu.lst. Feel free to report any further bugs you may find.

affects: grub-choose-default (Ubuntu) → grub (Ubuntu)
Changed in grub (Ubuntu):
importance: Undecided → Wishlist
j3f0 (tevelized) wrote :

I can confirm this.

I have the same set up Ubuntu then installed Kubuntu. plus windows suse and a couple others, I had too much hard drive space and VM's are... well..... Kubuntu manages all grub related fun, but does not indicate it's Kubuntu in menu.lst. It would be great if it did!! especially for new/newer users. Also it would be nice if grub was pretty. I mean it's 2009 shouldn't everything be pretty?

just a thought.

Jonathan Kolberg (bulldog98) wrote :

Still happens in lucid.

Changed in grub (Ubuntu):
status: New → Confirmed
Jonathan Kolberg (bulldog98) wrote :

I finally got why it doesn’t work. As a workaround you can edit /etc/lsb-release to say Kubuntu instead of Ubuntu. But as a final fix for this bug, /etc/lsb-release should be an alternativ which can be configured by update-alternativ --config /etc/lsb-release

Regards Jonathan

lunix (bob-l-lewis) wrote :

Out of curiosity, why do a dual boot at all? Instead I was thinking one could install Ubuntu and then also install the KDE desktop. At login time you are allowed to choose which of many desktops you want to run for the session. This would give you both worlds without having to tie up so much disk space along with the added complexity of a dual boot I would think.

j3f0 (tevelized) wrote :

I used to dual boot these systems because installing both packages in a single instance created a number of dependency conflicts, broke a number of programs and was more difficult to sort out than simply dual booting. Currently Ubuntu, or Virtual box or some combination of the two, is causing my hard drives to fail in my laptop. Since it's a production machine and hard drives cost money I can't use it any more.

affects: grub (Ubuntu) → kubuntu-settings (Ubuntu)
Changed in kubuntu-settings (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-settings - 1:13.04ubuntu7

---------------
kubuntu-settings (1:13.04ubuntu7) raring; urgency=low

  * Add desktop/etc/default/grub.d/50_kubuntu.cfg (LP: #366535)
    This overrides the GRUB_DISTRIBUTOR value set in default/grub whenever
    it is 'Ubuntu'. As a result Grub will call Ubuntu entries Kubuntu as
    long as kubuntu-default-settings is installed.
    This is marked as a conffile, so the user may change the behavior.
  * Update boot artwork (grub, kubuntu-log, kubuntu-text) (LP: #1164854)
  * low-fat update:
    + kded:
      - appmenu - provides menus in window decorations
      - colord - no one knows what it does, supposedly it talks to colord
      - wacomtablet - special hardware integration
    + krunner:
      - kill runner - lists running applications to kill them
      - activitity runner - lists activities
    + kwin:
      - plastik is now aurorae based, so plugin is now aurorae and new
        aurorarerc sets plastik
    + activitymanager:
      - deactivate all acitivity manager plugins (short of being able
        to deactivate the entire thing)
 -- Harald Sitter <email address hidden> Fri, 05 Apr 2013 10:39:23 +0200

Changed in kubuntu-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers