Ubuntu

UEFI install broken when GRUB_DISTRIBUTOR!=Ubuntu (e.g. Kubuntu/UbuntuStudio)

Reported by yossarian_uk on 2013-10-20
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
High
Unassigned
grub2-signed (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned
kubuntu-settings (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Critical
Unassigned
shim-signed (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned
ubuntustudio-default-settings (Ubuntu)
Status tracked in Trusty
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Critical
Unassigned

Bug Description

[Impact]
After a installation of Kubuntu rebooting will leave the user with a unusable system since the relevant EFI files are not found. The uploaded package will fix this issue for all Kubuntu users and allow them to be able to boot their system.

[Test Case (shim-signed)]
1. On kubuntu, upgrade shim-signed from -updates.
2. Verify that /boot/efi/EFI/ubuntu/shimx64.efi and /usr/lib/shim/shim.efi.signed do NOT match.
3. Upgrade shim-signed from -proposed.
4. Verify that /boot/efi/EFI/ubuntu/shimx64.efi and /usr/lib/shim/shim.efi.signed DO match.

[Test Case]
--General: Verfiy UEFI bootmanager Entries--
If one has access to a UEFI shell that should be used to confirm UEFI bootmanager entries. When in need for a shell binary one can use [1] and place it as /boot/efi/shellx64.efi. Please note that unsigned shells will not work while SecureBoot is active.

To print the image table use:
bcfg boot dump

Output should contain an entry with
   Desc - kubuntu
and DevPath should contain \EFI\ubuntu (not \EFI\kubuntu)

If a shellx64.efi cannot be used use the command line tool efibootmgr instead:
* sudo efibootmgr -v

One of the entires should again be called kubuntu and contain \EFI\ubuntu in the File defintion. For example:
Boot0002* kubuntu HD(1,800,96000,e3e31484-1b57-40b2-a4b0-942debc6bea9)File(\EFI\ubuntu\grubx64.efi)

--Upgrade Test Case--
* Deactivate SecureBoot in BIOS
* Boot
* Verfiy UEFI bootmanager Entries (see above; should be broken and point to \EFI\kubuntu)
* Make sure there is no EFI/ubuntu present on your EFI partition (mv /boot/efi/EFI/ubuntu /boot/efi/EFI/ubuntu-bak)
* sudo apt-get update
* sudo apt-get install grub2-common grub-efi-amd64 grub-eif-amd64-signed
* Verfiy UEFI bootmanager Entries (see above)
* Verify that /boot/efi/EFI/ubuntu exists (again)
* Reboot and boot into the 'kubuntu' entry.
* Shutdown
* Activate SecureBoot in BIOS
* Boot

--Installation Test Case--
* Deactivate SecureBoot in BIOS
* Boot 13.10 ISO
* When doing a completely clean install:
* Delete all paritions using gparted or partitionmanager
* When NOT doing a completely clean install:
** Find your EFI partition (will be a rather small FAT partition); usually /dev/sda1 or sda2
** sudo mount /dev/$DEVICE /mnt
** Make sure there is no EFI/ubuntu present (mv /mnt/EFI/ubuntu /mnt/EFI/ubuntu-bak)
** sudo umount /mnt
* Ensure there are no 'kubuntu' UEFI boot manager entires
** sudo efibootmgr -v |grep kubuntu
** If there is one, delete it first
** sudo efibootmgr -b $NUMBER_PRECEDING_THE_NAME_IN_THE_DUMP -B
** Confirm .... sudo efibootmgr -v |grep kubuntu
* Ensure there is an active internet connection
* When testing from proposed make sure apt-setup will enable it by default
** sudo edit /usr/lib/ubiquity/apt-setup/generators/50mirror.ubuntu
** Find every occurrence of `if [ "$PROPOSED"....`
** Comment out all ifs and their corresponding fis
** To verify check /etc/sources.list after install, it should have proposed active
* Install
* Verfiy UEFI bootmanager Entries (see above)
* Reboot and boot into the 'kubuntu' entry.
* Shutdown
* Activate SecureBoot in BIOS
* Boot

[Regression Potential]
TBD

[1] http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=UEFI_Shell

-------------- original report

Kubuntu 13.10 is broken for UEFI installs. You will just get the grub2 cli after reinstall..

Its a really stupid bug - with a really easy fix - you just need to copy the kubuntu folder in the efi directory to ubuntu.

i.e

sudo cp -rv /boot/efi/EFI/kubuntu /boot/efi/EFI/ubuntu

Will 'fix' it.

It looks like its effecting various people

i.e - randomly found this.

http://www.kubuntuforums.net/showthread.php?63589-13-10-64Bit-Beta1-UEFI-GRUB-Not-Working-After-Install

To fix this surely the 13.10 .iso will have to be rebuilt?

This is a Kubuntu speficic bug - Ubuntu 13.10 is fine.

------------------------
1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu

13.10 - kubuntu

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

$ dpkg -l |grep grub

ii grub-common 2.00-19ubuntu2 amd64 GRand Unified Bootloader (common files)
ii grub-efi-amd64 2.00-19ubuntu2 amd64 GRand Unified Bootloader, version 2 (EFI-AMD64 version)
ii grub-efi-amd64-bin 2.00-19ubuntu2 amd64 GRand Unified Bootloader, version 2 (EFI-AMD64 binaries)
ii grub-efi-amd64-signed 1.22+2.00-19ubuntu2 amd64 GRand Unified Bootloader, version 2 (EFI-AMD64 version, signed)
ii grub2-common 2.00-19ubuntu2 amd64 GRand Unified Bootloader (common files for version 2)

3) What you expected to happen

The install to work

4) What happened instead

Install not able to boot - just grub2 cli - had to manually copy the efi directory to 'ubuntu' to 'fix' it

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: grub-efi-amd64 2.00-19ubuntu2
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
Date: Sun Oct 20 20:00:54 2013
InstallationDate: Installed on 2013-10-20 (0 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

yossarian_uk (morgancoxuk) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
yossarian_uk (morgancoxuk) wrote :

Various other examples of this effecting mutiple other people

https://plus.google.com/u/0/106659361713607102394/posts/Bp4KFtzKCfE

https://plus.google.com/108455687429720093522/posts/2M67maeijXH

https://plus.google.com/100410620541037707448/posts/ZHNqA6QskAn

In fact the Kubuntu Google plus 'ask and help' page is full of people not being able to run Kubuntu 13.10 with UEFI...

description: updated

I had the exact same bug (and I had also found the same fix).

However, does anybody know how to fix it more properly (i.e. make sure grub looks into EFI/kubuntu rather than EFI/ubuntu ?)

Harald Sitter (apachelogger) wrote :

build-efi-images references EFI/ubuntu:
"$grub_mkimage" -O "$platform" -o "$outdir/grub$efi_name.efi" \
 -d "$grub_core" -p /EFI/ubuntu $GRUB_MODULES

everything else in the world uses bootloader_id such that EFI/kubuntu gets used:
if [ "$bootloader_id" ] && [ -d "/boot/efi/EFI/$bootloader_id" ]; then

Since the images however reference EFI/ubuntu installations are broken... so I guess the options are
a) create 2 sets of images (one for /ubuntu and for /kubuntu)
b) find a way to make the images generic such that both work
c) change everything else in the world to not use bootloader_id

Changed in grub2 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Harald Sitter (apachelogger) wrote :

d) drop kubuntu override GRUB_DISTRIBUTOR

Colin Watson (cjwatson) wrote :

We need to use /EFI/ubuntu for all flavours in the Ubuntu archive.

Dimitri John Ledkov (xnox) wrote :

As per comment #7 "We need to use /EFI/ubuntu for all flavours in the Ubuntu archive."

summary: - UEFI install broken on Kubuntu 13.10
+ UEFI install broken when GRUB_DISTRIBUTOR!=Ubuntu (e.g.
+ Kubuntu/UbuntuStudio)
Changed in ubuntustudio-default-settings (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Changed in kubuntu-settings (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
Changed in grub2 (Ubuntu):
status: Triaged → Won't Fix
Changed in grub2 (Ubuntu):
status: Won't Fix → In Progress
description: updated
Changed in ubuntustudio-default-settings (Ubuntu Trusty):
assignee: nobody → Howard Chan (smartboyhw)
status: Confirmed → In Progress
Rohan Garg (rohangarg) on 2013-10-23
description: updated
yossarian_uk (morgancoxuk) wrote :

I tested the new packages- https://launchpad.net/~rohangarg/+archive/experimental

I Completely wiped drive and UEFI entries first - I :-

- installed kubuntu
- installed efibootmng
- mounted new root in /mnt/sda3
- mount /dev/sda1 in /mnt/sda3/boot/efi
- mount /proc, /dev, /sys in /mnt/sda3/[dev/sys/proc[
- chrooted

[in side chroot]
- added PPA for new grub
- did a apt-get update/dist-upgrade
- deleted old UEFI entry via efibootmng
- grub-update (no new uefi entry appeared)
- grub-install -> new entry appeared.

[rebooted]

*** OS Boots *** !

But... - as well as creating a kubuntu menu entry in creates an 'ubuntu' one also -this also boots kubuntu - but you cannot get rid of the entry .... i.e if you delete the entry using efibootmng it will come back on reboot ? if you delete the kubuntu one that doesn't come back automatically.

Don't know if relevant but /boot/efi/EFI/ubuntu also exists now..

I have found even if I remove /boot/efi/EFI/kubuntu the system still boots as long as /boot/efi/EFI/ubuntu exists....

I cannot get rid of the 'ubuntu' UEFI entry - I have used efibootmng and bcfg and after reboot it comes back - the only way to remove it is - remove entry and delete /boot/efi/EFI/ubuntu - that means kubuntu is unbootable though.

Hello yossarian_uk, or anyone else affected,

Accepted into saucy-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2 (Ubuntu Saucy):
status: New → Fix Committed
Changed in kubuntu-settings (Ubuntu Saucy):
status: New → Fix Committed
Changed in ubuntustudio-default-settings (Ubuntu Saucy):
status: New → Fix Committed
tags: added: verification-needed
yossarian_uk (morgancoxuk) wrote :

Hi

I have enabled saucy-proposed - i.e add to sources.list

'deb http://archive.ubuntu.com/ubuntu/ saucy-proposed restricted main multiverse universe'

sudo apt-get update

sudo apt-get -t saucy-proposed dist-upgrade

I see the following

---------------------------------------------------------------------------------
The following packages will be upgraded:
  glib-networking glib-networking-common glib-networking-services kubuntu-docs libglib2.0-0 libglib2.0-bin
  libglib2.0-data libmuonprivate1 libupower-glib1 muon muon-discover muon-notifier muon-updater plasma-nm
  python3-software-properties software-properties-common software-properties-kde upower

---------------------------------------------------------------------------------

i.e no grub update ?

Is this because i'm already running the version from the PPA - https://launchpad.net/~rohangarg/+archive/experimental ?

Changed in ubuntustudio-default-settings (Ubuntu Saucy):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.23

---------------
grub2-signed (1.23) trusty; urgency=low

  * Rebuild against grub-efi-amd64 2.00-19ubuntu3 LP: #1242417
 -- Rohan Garg <email address hidden> Thu, 24 Oct 2013 09:56:34 +0200

Changed in grub2-signed (Ubuntu Trusty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.00-19ubuntu3

---------------
grub2 (2.00-19ubuntu3) trusty; urgency=low

  * Adjust UEFI installation to cope with Kubuntu setting GRUB_DISTRIBUTOR
    (LP: #1242417).
 -- Colin Watson <email address hidden> Tue, 22 Oct 2013 09:36:32 +0100

Changed in grub2 (Ubuntu Trusty):
status: In Progress → Fix Released
Jonathan Riddell (jr) on 2013-10-24
Changed in grub2-signed (Ubuntu Saucy):
status: New → Fix Committed
Adam Conrad (adconrad) on 2013-10-24
Changed in grub2-signed (Ubuntu Saucy):
status: Fix Committed → In Progress
Adam Conrad (adconrad) wrote :

Hello yossarian_uk, or anyone else affected,

Accepted grub2-signed into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/grub2-signed/1.22.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in grub2-signed (Ubuntu Saucy):
status: In Progress → Fix Committed
yossarian_uk (morgancoxuk) wrote :

Hi. the Proposed updates do result in a bootable system.

I have just re-tested,

Blank drive - fresh install

- after install I chrooted into install (with efi, /dev,/sys,/proc mounted )
[in chroot]
- I added saucy-proposed to sources.list
- updated all grub packages from saucy-proposed
- rebooted

OS Boots fine!

System boots however adds a new 'kubuntu' + 'ubuntu' UEFI entry.

I cannot get rid of the 'ubuntu' entry - if I delete it with efibootmgr or bcfg it returns on reboot - whilst the /boot/efi/EFI/ubuntu folder exists.

The 'ubuntu' UEFI entry only appeared after installing the updated grub packages.

Both 'ubuntu' and the 2 'kubuntu' UEFI entries now boot to kubuntu 13.10.

I haven't installed ubuntu (was a blanked disk and I had also removed all UEFI entries pre install

tags: added: verification-done
removed: verification-needed
Jonathan Riddell (jr) wrote :

I also installed Kubuntu 13.10 on a machine where previous installs would not boot. I chrooted into the new install from the live system, enabled -proposed, updated and ran grub-update. Kubuntu now successfully boots. There is no Windows entry in the boot menu, Windows is the other OS on this machine, but I'm skeptical of this machine anyway (a sony Vaio) as the firmware had some known bugs last time I looked at it.

yossarian_uk (morgancoxuk) wrote :

Jonathan Riddell (jr) : That could be connected with the new unremovable 'ubuntu' entry perhaps?

Do you see that also?

I shall test dual booting also soon and report (dual booting with other Linux at least - I haven't ran Windows in some time)

On Sat, Oct 26, 2013 at 11:21 AM, yossarian_uk
<email address hidden> wrote:
> Jonathan Riddell (jr) : That could be connected with the new unremovable
> 'ubuntu' entry perhaps?

This is because of your firmware, as it gets recreated regardless of
how you delete it. Your firmware simply adds every EFI image folder to
the boot manager (supposedly to prevent people from breaking their BM
and ending up with an unbootable system...).

vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv

In other news:
I just confirmed that when installing with updates enabled one will
get the correct setup right away (also no EFI/kubuntu/ lingers around
like in the upgrade scenario).

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Harald Sitter (apachelogger) wrote :

Updated installation test case to document enabling proposed by default.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2 - 2.00-19ubuntu2.1

---------------
grub2 (2.00-19ubuntu2.1) saucy; urgency=low

  [ Colin Watson ]
  * Adjust UEFI installation to cope with Kubuntu setting GRUB_DISTRIBUTOR
    (LP: #1242417).
 -- Rohan Garg <email address hidden> Tue, 22 Oct 2013 09:36:32 +0100

Changed in grub2 (Ubuntu Saucy):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub2-signed - 1.22.1

---------------
grub2-signed (1.22.1) saucy; urgency=low

  * Rebuild against grub-efi-amd64 2.00-19ubuntu2.1 LP: #1242417
 -- Rohan Garg <email address hidden> Thu, 24 Oct 2013 10:00:15 +0200

Changed in grub2-signed (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5

---------------
shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Thu, 31 Oct 2013 17:06:21 -0700

Changed in shim-signed (Ubuntu Trusty):
status: New → Fix Released
Changed in kubuntu-settings (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in kubuntu-settings (Ubuntu Trusty):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2013-11-08
description: updated

Hello yossarian_uk, or anyone else affected,

Accepted shim-signed into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Precise):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Changed in shim-signed (Ubuntu Quantal):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello yossarian_uk, or anyone else affected,

Accepted shim-signed into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Raring):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello yossarian_uk, or anyone else affected,

Accepted shim-signed into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~13.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Saucy):
status: New → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello yossarian_uk, or anyone else affected,

Accepted shim-signed into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~13.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~13.10.1

---------------
shim-signed (1.5~13.10.1) saucy; urgency=low

  * Backport to Ubuntu 13.10.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:47:35 -0800

Changed in shim-signed (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~12.04.1

---------------
shim-signed (1.5~12.04.1) precise; urgency=low

  * Backport to Ubuntu 12.04 LTS.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Thu, 07 Nov 2013 10:29:43 -0800

Changed in shim-signed (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~12.10.1

---------------
shim-signed (1.5~12.10.1) quantal; urgency=low

  * Backport to Ubuntu 12.10.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:36:26 -0800

Changed in shim-signed (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~13.04.1

---------------
shim-signed (1.5~13.04.1) raring; urgency=low

  * Backport to Ubuntu 13.04.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:45:25 -0800

Changed in shim-signed (Ubuntu Raring):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Trusty branch merged and uploaded. Unsubscribing sponsors as there's nothing else to sponsor for now.

Changed in ubuntustudio-default-settings (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntustudio-default-settings - 0.50

---------------
ubuntustudio-default-settings (0.50) trusty; urgency=low

  * Revert the GRUB Distribution name change (LP: #1242417)
 -- Howard Chan <email address hidden> Wed, 13 Nov 2013 08:57:35 +0100

Changed in ubuntustudio-default-settings (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers