Ubuntu

Nvidia/Dual screen - No Taskbar/Kdemenu on default install Kubuntu 13.04

Reported by yossarian_uk on 2013-04-30
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
kubuntu-settings (Ubuntu)
Medium
Philip Muškovac
Raring
Medium
Philip Muškovac

Bug Description

[Impact]
If you have more than 1 display attached to the system during first login you end up with only 1 half configured panel on one display and with no panel on all other displays.
The initialization script assumes that the first panel is already there when setting up the panels for the additional displays and crashes when that's not the case.
More info on the IRC discussion:
http://irclogs.ubuntu.com/2013/05/01/%23kubuntu-devel.html#t20:57

[Test Case]
1) You need at least 2 displays connected to the PC (or 1 additional monitor attached to a notebook) before continuing
2) Create a new user and login
3) The primary display should have no panel at all, only one display should have a panel with an activity switcher widget on it.
4) Install kubuntu-settings from raring-proposed
5) reset the kde configuration by deleting ~/.kde
6) log in again
You should now have properly set up panels on all displays.

[Regression Potential]
Upstream also loads the first panel settings before setting up the desktops and other panels so it should be safe.

== Original description ==
On a new install I don't get a taskbar(panel) or kde menu - I only see one panel with just activitives on it - i.e only half a desktop...

This has occurred on multiple machines (all with Nvidia cards and dual monitors)

I have to add the panel manually or I don't have a taskbar/menu - you have one panel with just the activity launcher.

This occurs before installing the nvidia binary driver.

It's happened on 3 different work stations (all dual monitor/nvidia)

More info on this reddit thread

http://www.reddit.com/r/kde/comments/1d48wb/kubuntu_1304_released/

== Workaround ==
For those that need this to work before a fix is out and don't want to edit the panels by hand, edit
/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps/plasma-desktop/init/00-defaultLayout.js
there replace
panel.height = panels()[i].height = screenGeometry(0).height > 1024 ? 35 : 27
with
panel.height = screenGeometry(0).height > 1024 ? 35 : 27

after that reset your kde configuration by removing ~/.kde (or at least the plasma config in there), login and you'll have properly set up panels.

ProblemType: BugDistroRelease: Ubuntu 13.04
Package: kde-workspace 4:4.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Tue Apr 30 10:54:50 2013
InstallationDate: Installed on 2013-04-26 (3 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: allSourcePackage: kde-workspace
UpgradeStatus: No upgrade log present (probably fresh install)

yossarian_uk (morgancoxuk) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kde-workspace (Ubuntu):
status: New → Confirmed
description: updated
Philip Muškovac (yofel) wrote :

Thank you for taking your time to report this bug and helping to make Kubuntu better.

Turns out this is a bug in the plasma setup script which crashes when more than 1 monitor is attached during first login.

affects: kde-workspace (Ubuntu) → kubuntu-settings (Ubuntu)
Changed in kubuntu-settings (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Philip Muškovac (yofel) on 2013-05-01
Changed in kubuntu-settings (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
status: Triaged → In Progress
MrBl33t (mrbl33t) wrote :

This affects me too, but im new ish to kubuntu, when i add the kde launcher to the taskbar and reboot the launcher loads in the centre of the bar, i have to delete it and re-attach after each reboot. How can you fix this, its driving me mad and ive gone back to my win7 partion, which makes me feel dirty lol

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-settings (Ubuntu Raring):
status: New → Confirmed
Philip Muškovac (yofel) on 2013-05-02
Changed in kubuntu-settings (Ubuntu Raring):
assignee: nobody → Philip Muškovac (yofel)
importance: Undecided → Medium
status: Confirmed → In Progress
Philip Muškovac (yofel) on 2013-05-03
description: updated
Philip Muškovac (yofel) on 2013-05-09
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-settings - 1:13.10ubuntu1

---------------
kubuntu-settings (1:13.10ubuntu1) saucy; urgency=low

  [ Harald Sitter ]
  * Remove kubuntu-settings-low-fat as requested by Martin Graesslin
    numerous times.
  * Set kwallet settings to silently crete an initial wallet and don't
    prompt when an application requests access to a wallet (soon to land
    in kde-runtime)
  * Drop kwinrc. It only set coverswitch as switch format, but according to
    upstream it is sort of unmaintained. Also it looks rather terrible in
    general

  [ Philip Muškovac ]
  * desktop/share/apps/plasma-desktop/init/00-defaultLayout.js:
    Do the setup of the desktops and other panels after setting up the first
    panel like upstream does it to prevent a crash when setting up panels for
    additional screens. (LP: #1174689)
 -- Harald Sitter <email address hidden> Thu, 02 May 2013 10:28:55 +0200

Changed in kubuntu-settings (Ubuntu):
status: In Progress → Fix Released
Philip Muškovac (yofel) on 2013-05-10
Changed in kubuntu-settings (Ubuntu):
status: Fix Released → Opinion
status: Opinion → Fix Released

Hello yossarian_uk, or anyone else affected,

Accepted into raring-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kubuntu-settings (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Riley (steveriley) wrote :

Is bug 1180400 possibly a duplicate? That bug also mentions nVidia, but no details about the number of monitors. I'll ask the OP to add extra info.

Philip Muškovac (yofel) wrote :

Works as intended for me

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-settings - 1:13.04ubuntu13

---------------
kubuntu-settings (1:13.04ubuntu13) raring-proposed; urgency=low

  * desktop/share/apps/plasma-desktop/init/00-defaultLayout.js:
    Do the setup of the desktops and other panels after setting up the first
    panel like upstream does it to prevent a crash when setting up panels for
    additional screens. (LP: #1174689)
 -- Philip Muskovac <email address hidden> Thu, 09 May 2013 16:52:38 +0200

Changed in kubuntu-settings (Ubuntu Raring):
status: Fix Committed → Fix Released
Bas Roufs (basroufs) wrote :

The bug dealt with here still effects me - at two netbooks with Kubuntu 13.04. However, in both cases, I successfully used the 'workaround' explained at this page. Thanks, Philip!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers