There is a fake Kopete launcher in the KDE menu.

Bug #1090490 reported by Rafael Belmonte
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kubuntu-settings (Ubuntu)
Low
Harald Sitter

Bug Description

Kubuntu has by default a fake Kopete launcher in the KDE menu, this launcher is not functional because Kopete is not installed by default anymore.
Take a look to the screen-shot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: kubuntu-default-settings 1:12.10ubuntu10
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
Uname: Linux 3.5.0-19-generic i686
ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
Date: Fri Dec 14 18:45:20 2012
InstallationDate: Installed on 2012-12-14 (0 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: kubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Rafael Belmonte (eaglescreen) wrote :
Revision history for this message
Rafael Belmonte (eaglescreen) wrote :

New information about this issue. This only happens when you switch from plasma-netbook to plasma-desktop.
Steps to reproduce the bug:
1) Do a fresh install of Kubuntu in a netbook which loads plasma-netbook interface by default.
2) Switch to plasma-desktop interface via System Settings -> Workspace Behaviour -> Workpace -> Workspace Type.
3) After plasma-desktop is loaded, open Kickoff menu.
4) You will see a not functional Kopete launcher in favorites.

(Note that also you will have only one virtual desktop where having two virtual desktops is the expected default for Kubuntu plasma-desktop, and also minimize button is not there in Kwin ).

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-default-settings (Ubuntu):
status: New → Confirmed
Changed in kubuntu-settings (Ubuntu):
status: New → Confirmed
Revision history for this message
Nightfall (someoneelse) wrote :

The "Kopete" entry should probably be an "Instant Messenger Contacts" one.

Comparing kubuntu-settings/netbook/share/config/kickoffrc and kubuntu-settings/desktop/share/config/kickoffrc, there are more differing entries (e.g. Kmail vs. Kontact), which might not be intended...

Philip Muškovac (yofel)
Changed in kubuntu-settings (Ubuntu):
milestone: none → ubuntu-13.10
tags: added: kubuntu
no longer affects: kubuntu-default-settings (Ubuntu)
Changed in kubuntu-settings (Ubuntu):
status: Confirmed → Fix Committed
importance: Undecided → Low
assignee: nobody → Harald Sitter (apachelogger)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-settings - 1:13.10ubuntu4

---------------
kubuntu-settings (1:13.10ubuntu4) saucy; urgency=low

  [ Harald Sitter ]
  * Update netbook's kickoffrc to use KTP instead of Kopete (LP: #1090490)
  * Add desktop/kdedrc deactivating phonon device change windows entirely.
    This is going a bit further than the upstream change as it also
    deactivates the device window on ALSA setups. From a Kubuntu UX POV
    the window should however not be shown ever, the fact that only people
    who have opted out of PA will get it does not really improve its
    uselessness. (Also see kde-runtime b691686f)
  * Remove desktop/config/KPackageKit; not used and I wonder how that ever
    worked.

  [ Jonathan Riddell ]
  * Add kubuntu-logo-full.png and kcm-about-distrorc
  * Add desktop/share/apps/muon-discover files to customise muon
 -- Jonathan Riddell <email address hidden> Wed, 28 Aug 2013 16:41:44 +0100

Changed in kubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers