impossible mount floppy device in /media

Bug #103378 reported by Xavier Corredor Llano on 2007-04-05
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Kubuntu Default Settings
Confirmed
Undecided
Unassigned
kubuntu-settings (Ubuntu)
Undecided
Unassigned

Bug Description

In kubuntu /media for default is for manipulate system devices, but with floppy device not work!, simply is impossible mount floppy device in /media, because the floppy show only as folder.

In media:/ work fine but kubuntu feisty (and edgy) not work with this for default.

floppy device is a storage media relatively obsolete, but kubuntu not must unsoported floppy, this device is yet used.

 Architecture: i386
 Date: Tue Apr 5 2007
 DistroRelease: Ubuntu 7.04
 Uname: Linux kubuntu 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Superkatze (superkatze) wrote :

I can confirm this. So no way to easily mount a floppy disk.

confirmed, this happen in all computer and plataform.

description: updated
Stephan Ruegamer (sadig) wrote :

The bug has nothing to do with kubuntu-konqueror-shortcuts

Changed in kubuntu-konqueror-shortcuts:
status: Unconfirmed → Rejected

there are more problems with /media/ as manipulate of storage devices for default: show always folder of device unmounted (example: cdrom and floppy).

the possible solution to this is use media:/ for default in storage devices. The kioslaves media:/ work perfect in kubuntu feisty, please consider this in feisty release

Changed in kubuntu-default-settings:
status: Unconfirmed → Confirmed
J Janz (jjanz) wrote :

I used to have the same problem. So that I stopped using System Menu > Storage Media (which today's default is to point to /media) for read floppy disks, pen drives (they were using to left some of the folders in which they're mounted listed in /media) or any other storage media. Instead, I was launching System Menu > Home Folder and, by choosing Services side button in the then opened konqueror window, I selected in its tree, Storage Media (this one points to media:/). As you can see, it's a long way to get there!
So, I just copied /usr/share/apps/systemview/media.desktop to ~/.kde/share/apps/systemview/media.desktop (I created systemview folder there) and edited it from Path=/media to Path=media:/
Now, my System Menu > Storage Media points to media:/ and it is just neat!
So, I second the asking for considering it on feisty and even attach here my edited media.desktop file to make it even easier/faster to replace /usr/share/apps/systemview one in time for the release ;-)
Thanks in advance.

J Janz (jjanz) wrote :

Just adding: maybe placing it on /usr/share/kubuntu-default-settings/kde-profile/default/share/apps/systemview/media.desktop instead of /usr/share/apps/systemview/media.desktop could be used as an alternative (not tested) if it's desirable either to keep it in kubuntu-default-settings or just not to change original one from /usr/share/apps/systemview/

J Janz (jjanz) wrote :

Well, I tested placing it on /usr/share/kubuntu-default-settings/kde-profile/default/share/apps/systemview/media.desktop an it works but it'll only keep the original System menu order if you also copy /usr/share/apps/systemview/home.desktop there, 'cause /.../kubuntu-default-settings/.../systemview looks like preceding the list of item from /usr/share/apps/systemview and Storage Media starts appearing on first place, before all other items. Copying home.desktop there made it get first place again, putting Storage Media back to second place.
So, I'm not the most qualified to tell where's the best place to put his file (/.../kubuntu-default-settings/.../systemview or /usr/share/apps/systemview/) once I don't know the benefits or not of each of them.
I sent the wrong file before (a previous version), then I replaced it here now. Please notice that it's owner and group are set to rot and, if it will be released w/ feisty or if someone will use it, please change it's owner and group to the necessary ones (if needed).

J Janz (jjanz) wrote :

Sorry for the flood but I just noticed that konqueror's default web page also pointed "Storage Media" link to /media and, so, here it is, pointing it to media:/ , to replace /usr/share/apps/konqueror/about/launch.html , where it is from.

thanks Arnaldo Janz, two packages change:

/usr/share/apps/systemview/media.desktop > package affect > kdebase-kio-plugins

/usr/share/apps/konqueror/about/launch.html > package affect > konqueror

please test (please make mk5sum, not included), I hope this up in segurity upgrade.

what packages more modify?

J Janz (jjanz) wrote :

Hi, Epsilom.

I've been making a few tests yesterday and I've seen that there's some more thing to do ...
One of them is when you insert a new media and kubuntu asks you what do you wanna do with it: open in a new window, ... and do nothing. If you open it in a new window, you'll see that it's been opened over /media/[device]. It should be changed for the correct path by kioslave.
Also, when you're in a file saving dialog, if you select, on the left options, storage media, it's also /media.
So, I've been thinking, as kde or (k)ubuntu developer which I'm not (actually, far from it - yet), if there's no more clever, more centered, way to do it, in which we make a change in one place, instead of this way, changing lots of places with the risk of forgetting some ...
So, I ask who knows kubuntu *very* well (I don't know if it's your case, Epsilom, or someone else's but, whoever can answer with precision): is there?

J Janz (jjanz) wrote :

Epsilom,

Installed and tested both packages you attached and they're ok! System menu > Storage Media now opens media:/, as konqueror's default page now also does.
Still didn't lookup for a more centered place (if there's one) to get the changes I mentioned before (and other ones I maybe didn't find yet).

Hi Arnaldo

you are right, I am not kubuntu developer, the best is we hope that developer analyze this bug, the bad thing is that they are delayed much, because there are many bugs.

we wait that this bug see developers....

J Janz (jjanz) wrote :

Epsilom,

Just to complement, it's ok in feisty. I tested in edgy and the dependencies' versions there are not the ones it expects (feisty ones).

While no developer come (at least, effectively) to this bug, I'm trying to learn a bit more to, at least, try to have an idea about the possible solutions for it.

J Janz (jjanz) wrote :

Epsilom,

Just to complement, it's ok in feisty. I tested in edgy and the dependencies' versions there are not the ones it expects (feisty ones), so it breaks.

While no developer come (at least, effectively) to this bug, I'm trying to learn a bit more to, at least, try to have an idea about the possible solutions for it.

mlaverdiere (mlaverdiere) wrote :

I understand why it has been decided to not use the media:/ anymore in Kubuntu (see the reasons here: https://wiki.ubuntu.com/KubuntuKDEMedia) but with all the respect, the implementation of /media usage is somewhat a failure. I realy hope that the usage of media:/ kioslave will be reimplemented in Gutsy.

mlaverdiere (mlaverdiere) wrote :

Wel, this bug may me solved in Kubuntu Gutsy since it seems now that medias are accessed through "system:/media" in KDE. I can't test with a floppy drive though...

J Janz (jjanz) wrote :

Dudes, I really couldn't find in https://wiki.ubuntu.com/KubuntuKDEMedia any reason (I supose that there were good ones) to not use media:/ (maybe I did a poor reading). Could anyone explain it? I really saw were lots of complaints (the problems dealed in this bug) about the (weak) workaround of /media/, what I saw corrected in Gutsy by using, for my surprise (and as mlaverdiere wrote before), system:/media - ! - ...
Well, I thought that it was pretty different (better) than media:/ but (again, maybe I did poor testing but ...) it works (and looks) exactly alike! ... Can anyone see any difference?
I really don't get (I know that, as I said, in this case specifically, the current solution acts just like what we were proposing - unless I'm wrong - but I, at least, would like to understand) why not to use the corresponding kioslave to everything ...
I'm sorry but, honestly, without a good reason, it gives me the impression of kid stuff, you know (like "what we did was not good but we'll not use an old behaviour either")? ... This is why I'm intrigued about this (maybe small) issue ... I can't (and refuse to) be believe in this impression ... I don't think it'd be a big deal to go back to a (working) previous behaviour. I hope I'm wrong about this impression ...

Adriaan (a-tip) wrote :

After installing Kubuntu 7.10 directly I also encountered the problem of mounting a floppy. Of the various solutions found on the internet only the procedure

sudo mount -o rw -t msdos /dev/fd0 /media/floppy0

worked.

But I found out later that first installing Ubuntu and then adding the Kubuntu desktop through

sudo apt-get install kubuntu-desktop

and starting up Kubuntu I could now create a floppy desktop icon (right click desktop, create new, link to device, floppy device) by means of which I could now mount and unmount floppies. So, for me, the problem is solved.

O. Temon (smonfer) wrote :

Kubuntu 8.10
Found a solution for this bug combining some ideas from the forums.
1.
Make a "floppy" dir into "media" dir: sudo mkdir /media/floppy
2.
Add this to fstab: /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
3.
Mount floppy: sudo mount -o rw -t auto /dev/fd0 /media/floppy
4.
Maybe manually add floppy group to root and normal user.

Don't now yet if some of these can be made automaticaly.

Thank you all. I hope this may help others.
P.D.: I think this issue is not a cause to reject such a solid O.S., but "obsolete" is not a good argument for any distro of a console-lover-system...

O. Temon (smonfer) wrote :

Edit:
In steps 1 and 3 shoud be read "floppy0" instead of just "floppy".

Sorry.

I do confirm on Ubuntu natty.

Shimi Chen (shimi-chen) on 2012-05-26
affects: ubuntu → kubuntu-default-settings (Ubuntu)
affects: kubuntu-default-settings (Ubuntu) → kubuntu-settings (Ubuntu)
no longer affects: kubuntu-web-shortcuts
Harald Sitter (apachelogger) wrote :

Still a problem with 13.04?

Changed in kubuntu-settings (Ubuntu):
status: Confirmed → Incomplete
Changed in kubuntu-settings (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers