kde keeps prompting to install flash, despite always answering no

Bug #1579723 reported by Maria Schmidt on 2016-05-09
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
kubuntu-notification-helper (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

Dear maintainers,

kded5 [kdeinit5] opens a notification window every time after I logged in (title is translated s.th. like "install packages (KDE Daemon)") which spams me with a persuasion attempt to enhance Firefox with software I don't want (flash). It is not possible to tell it I am not interested and when I close it it will come back after the next login, which actually makes this notice spam.

I actually allowed the non-free section because I am forced to, not because of flash. I understand this is free software and I am eternally thankful for your great work (thanks alot)! I am also aware about the financial problems which come with free software. But please, do not use my own system for the advertise of bad software.

I'd expect the software to give the choice of not wanting to ever bring up the topic of a certain suggested piece of software.

Yours Maria

--
"If I wanted a hole in my computer I'd take a hammer and a nail!"

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: kded5 5.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-22.39-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: KDE
Date: Mon May 9 13:23:52 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-05-02 (6 days ago)
InstallationMedia: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: kded
UpgradeStatus: No upgrade log present (probably fresh install)

Steve Beattie (sbeattie) wrote :

I agree that kded should not keep continuing to prompt to install flash after it's been declined. Do note that you can work around this behavior (I believe, I'm not a kde user) as described in http://askubuntu.com/questions/616348/how-to-disable-extra-packages-can-be-installed-popup-in-kubuntu-15-04 . Thanks for your report!

summary: - produces Spam window notices
+ kde keeps prompting to install flash, despite always answering no
information type: Private Security → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kded (Ubuntu):
status: New → Confirmed
Changed in kded (Ubuntu):
importance: Undecided → High
the-noob (the-noob) wrote :

This is still happening in

Ubuntu 16.04.2 LTS
KDE Plasma: 5.8.6
KDE Framework: 5.34.0
Qt: 5.6.1

Still happening in Kubuntu 17.04.

DaDummy (dadummy) wrote :

Still happening in Kubuntu 17.10 Beta 2

Unluckily I don't know and can't check, as I changed to Debian in the
meantime.
Thanks - Maria

DaDummy:
> Still happening in Kubuntu 17.10 Beta 2
>

Dmitry Myachin (umnik) wrote :

Still reproduce on Kubuntu 17.10 Release

Gawarmel (gawarmel) wrote :

Annoying. Never needed flash.

Rik Mills (rikmills) on 2017-12-30
Changed in kded (Ubuntu Bionic):
status: Confirmed → Fix Committed
Changed in kubuntu-notification-helper (Ubuntu Bionic):
status: New → Fix Committed
importance: Undecided → High
no longer affects: kded (Ubuntu)
Rik Mills (rikmills) on 2017-12-30
no longer affects: kded (Ubuntu Bionic)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-notification-helper - 18.04ubuntu1

---------------
kubuntu-notification-helper (18.04ubuntu1) bionic; urgency=medium

  * In 2018, don't bug users to install flash plugin. (LP: #1579723)
  * Automatic translation updates from KDE

 -- Rik Mills <email address hidden> Sat, 30 Dec 2017 10:09:35 +0000

Changed in kubuntu-notification-helper (Ubuntu Bionic):
status: Fix Committed → Fix Released
Joe Johnson (say2joe) wrote :

Thanks for the fix... finally. Seeing Flash install popups is about as useful as a rash popping up on my ass.

Now, waiting for Bionic. And, I'm on KDE Neon. Geez.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers