whoopsie-upload-all crashed with PermissionError in process_report(): [Errno 13] Permission denied: '/var/crash/_usr_bin_akonadi_googlecalendar_resource.1000.crash'

Bug #1281884 reported by Andrew DeMarsh on 2014-02-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kubuntu-notification-helper (Ubuntu)
Medium
Harald Sitter

Bug Description

Release: Kubuntu 14.04
crashed after AntiChamber Install

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: kubuntu-notification-helper 14.04ubuntu3
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Feb 18 21:58:31 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/share/kde4/apps/kubuntu-notification-helper/whoopsie-upload-all
InstallationDate: Installed on 2014-02-15 (3 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140121.1)
InterpreterPath: /usr/bin/python3.3
ProcCmdline: /usr/bin/python3 /usr/share/kde4/apps/kubuntu-notification-helper/whoopsie-upload-all
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/kde4/apps/kubuntu-notification-helper/whoopsie-upload-all']
SourcePackage: kubuntu-notification-helper
Title: whoopsie-upload-all crashed with PermissionError in process_report(): [Errno 13] Permission denied: '/var/crash/_usr_bin_akonadi_googlecalendar_resource.1000.crash'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo

Andrew DeMarsh (andrewdemarsh) wrote :
tags: removed: need-duplicate-check
Changed in kubuntu-notification-helper (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-notification-helper (Ubuntu):
status: New → Confirmed
Harald Sitter (apachelogger) wrote :

Please post the output of the following command:
ls -lah /var/crash

Changed in kubuntu-notification-helper (Ubuntu):
status: Confirmed → Incomplete
Changed in kubuntu-notification-helper (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
Andrew DeMarsh (andrewdemarsh) wrote :

This is the Contents of of /var/crash as requested:

total 290M
drwxrwsrwt 2 root whoopsie 4.0K Mar 2 13:34 ./
drwxr-xr-x 13 root root 4.0K Jan 21 11:03 ../
-rw-rw---- 1 root whoopsie 0 Mar 2 13:19 .lock
-rw-r----- 1 andrew whoopsie 6.8M Feb 28 02:38 _usr_bin_emacs24-x.1000.crash
-rw-rw-r-- 1 andrew whoopsie 0 Feb 28 02:38 _usr_bin_emacs24-x.1000.upload
-rw------- 1 whoopsie whoopsie 0 Feb 28 02:40 _usr_bin_emacs24-x.1000.uploaded
-rw-r----- 1 andrew whoopsie 6.8M Feb 27 15:51 _usr_bin_jockey-kde.1000.crash
-rw-rw-r-- 1 andrew whoopsie 0 Mar 2 13:33 _usr_bin_python3.4.1000.drkonqi-accept
-rw-r----- 1 andrew whoopsie 72M Mar 2 01:36 _usr_bin_skype.1000.crash
-rw-r----- 1 andrew whoopsie 17M Mar 1 13:28 _usr_bin_virtuoso-t.1000.crash
-rw-r----- 1 andrew whoopsie 2.3M Feb 27 21:25 _usr_games_gtkatlantic.1000.crash
-rw-rw-r-- 1 andrew whoopsie 0 Feb 27 21:25 _usr_games_gtkatlantic.1000.upload
-rw------- 1 whoopsie whoopsie 0 Feb 27 21:25 _usr_games_gtkatlantic.1000.uploaded
-rw-r----- 1 andrew whoopsie 164M Mar 2 13:13 _usr_lib_jvm_java-7-openjdk-amd64_jre_bin_java.1000.crash
-rw-rw-r-- 1 andrew whoopsie 0 Mar 2 13:13 _usr_lib_jvm_java-7-openjdk-amd64_jre_bin_java.1000.upload
-rw------- 1 whoopsie whoopsie 0 Mar 2 13:13 _usr_lib_jvm_java-7-openjdk-amd64_jre_bin_java.1000.uploaded
-rw-r----- 1 root whoopsie 266K Feb 27 15:51 _usr_sbin_bluetoothd.0.crash
-rw-r----- 1 andrew whoopsie 22M Mar 2 13:34 _usr_share_apport_apport-kde.1000.crash
-rw-rw-r-- 1 andrew whoopsie 0 Mar 2 13:34 _usr_share_apport_apport-kde.1000.upload
-rw------- 1 whoopsie whoopsie 0 Mar 2 13:34 _usr_share_apport_apport-kde.1000.uploaded

Harald Sitter (apachelogger) wrote :

too late unfortunately. anyway, it should now handle this particular error correctly.

Changed in kubuntu-notification-helper (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers