Ugly mount point name used for removable media

Bug #48104 reported by Toby Dickenson on 2006-06-02
12
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

The names of mountpoints in /media/ created by Breezy were taken from the filesystem label on a removeable media. very nice.

Dapper (on kubuntu) does not.... mount points are /media/sdb1 etc.
This happens when plugging in the device, or when clicking on the kde desktop icon.

Interestingly I do still see the filesystem label using:
$ hal-device |grep desired_mount_point

I also still get the correct mountpoint used when mounting the device using pmount-hal.

Im happy to investigate further, but Im not sure how this is supposed to work.

SilentPh03nix (silentph03nix) wrote :

I'm seeing this behaviour as well. This makes things very difficult to have a consistent mount point between GNOME and KDE. I use this with an external hard drive that I don't have plugged in all the time but do use between GNOME and KDE.

Donatas Glodenis (dgvirtual) wrote :

I think this is an important usability issue, that should be solved somehow.

Frode M. Døving (frode) wrote :

This seems to be fixed in current Edgy.

Ylan (ylan-segal) wrote :

I found something that might be helpful for people affected by this bug:

When I plug in a USB drive in Kubuntu 3.06 (with KDE 3.5.4 ), get the described behaviour, it mounts to:

/media/sdb1

However, if I left-click on the desktop icon I see that the desired mount point is set to:

/media/filesystem_label

There is a checkbox underneath. When selected, the USB drive now mounts to both mountpoints, which at least for me, solves the problem.

Toby Dickenson (toby-tarind) wrote :

Confirmed fixed in edgy, and 355 on dapper

Andrew Ash (ash211) wrote :

Great. If it's a problem later, just let us know. Thanks for helping make Kubuntu better.

Changed in kubuntu-meta:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers