dist-upgrade wants to delete almost kde packages while migrating from breezy to dapper

Bug #39658 reported by fred2k on 2006-04-15
32
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
High
Unassigned

Bug Description

Hi,

I met some other people wich have encountered this bug, but without relevant solution on the forums.

After checking if kubuntu-desktop is well installed, changing the breezy entries to dapper in my sources.list and making the apt-get update, the apt-get dist-upgrade wants to delete almost every kde related packages (and I'm not very confident about letting it uninstall those packages to get caught in a situation where i might not be able to reinstall the new kbuntu-desktop)

I think it is related to some dependancies problem cos when I try an apt-get install kubuntu-desktop with the dappers sources, I get a dependancy error message : the dependancies of kubuntu-desktop are not resoved with the current
adept, bluez-cups, cupsys, cupsys-driver-gutenprint, hplip, kdnssd, keep, ksplash-engine-moodin, ktorrent, language-selector-qt, libarts1-akode, openoffice.org,-kde, skim
packages.

My sources.list is very common : I only added the plf repositories (w32,dvdcss,...) and the kubuntu.org updates for Amarok, kde 3.5.2 and koffice

Michael Vogt (mvo) wrote :

Could you please attach your sources.list to this bugreport? That would make reproducing it easier.

As you can see it's a very common one

only a copy of de breezy sources.list with the irrelevant entries commented.

I also tried without commenting those lines

thx for your help

The log I get when apt-getting kubuntu-desktop

fred2k (fbranger) wrote : akode log

It seems that libarts is the key of de dep problem

Albert Cardona (cardona) wrote :

I had the same problem today. After replacing 'breezy' to 'dapper' in the sources.list and running apt-get dist-upgrade, my KDE vanished along with the entire kubuntu-desktop (ooffice, etc). So I had to reinstall the kubuntu-desktop and all was almost good.
The hplip can't be installed properly, and cupsd pushes the pedal to 98% in a 'top'.

 * Starting HP Linux Printing and Imaging System [fail]
invoke-rc.d: initscript hplip, action "start" failed.
dpkg: error processing hplip (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 hplip
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also, some settings where there but not effective such as the command key as the control for my powerbook, but check/uncheck and apply did the job after a X server restart (not just kde restart).
And dragging on the adept tags textarea crashes it badly.

upgrade of fully up to date default kubuntu

Changed in kubuntu-meta:
status: Unconfirmed → Confirmed

installing kubuntu-desktop afterwards installs alot:

root@lap-loan4:~# apt-get install kubuntu-desktop
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
  hplip k3b keep kmplayer-base kmplayer-konq-plugins ktorrent language-selector-qt libakode2 libarts1-akode libk3b2 libnss-mdns librsync1
  libskim0 openoffice.org openoffice.org-base rdiff-backup scim-qtimm skim wlassistant
Suggested packages:
  python-qt3 k3b-i18n normalize-audio toolame sox movixmaker-2 libk3b2-mp3 k3b-mp3 nscd zeroconf openoffice.org-help menu oooqs-kde unixodbc
  prelink openoffice.org-thesaurus msttcorefonts xlibmesa-gl libgl1 openoffice.org-officebean openclipart-openoffice.org pstoedit
  openoffice.org-filter-so52 ooqstart-gnome openoffice.org-mimelnk openoffice.org-gnomevfs openclipart libmyodbc odbc-postgresql tdsodbc
  mdbtools libmysql-java libpg-java libsapdbc-java openoffice.org-gcj scim-chewing scim-pinyin scim-hangul scim-m17n scim-tables-additional
  scim-tables-ja scim-tables-ko scim-tables-zh scim-uim
Recommended packages:
  vcdimager
The following packages will be REMOVED
  openoffice.org-l10n-en
The following NEW packages will be installed
  hplip k3b keep kmplayer-base kmplayer-konq-plugins ktorrent kubuntu-desktop language-selector-qt libakode2 libarts1-akode libk3b2
  libnss-mdns librsync1 libskim0 openoffice.org openoffice.org-base rdiff-backup scim-qtimm skim wlassistant
0 upgraded, 20 newly installed, 1 to remove and 1 not upgraded.
Need to get 11.9MB of archives.
After unpacking 13.8MB of additional disk space will be used.

Michael Vogt (mvo) wrote :

If you have update-manager installed, could you please try runing it like this (with the breezy sources.list):
$ sudo update-manager -d

and after clicking on "upgrade" in the top button if it suggests a better upgrade or fails? In either case, please attach a copy of /var/log/dist-upgrade*.log to this report.

Thanks,
 Michael

Changed in kubuntu-meta:
status: Confirmed → Needs Info
Kenny Duffus (kduffus) wrote :

update-manager is not a kubuntu application it is for use with gnome

Changed in kubuntu-meta:
status: Needs Info → Confirmed
Tom Matelich (matelich) wrote :

I tried synaptic and update-manager, they all gave the same report, you have to remove all your kde packages. I'm not a power user, so I didn't dig into the details, but I'd guess the dependency issue above.

apt-get dist-upgrade too

As asked, the log files

As asked, the log files

Looking over the dist-upgrade logs it seems like it makes sensible descisions.

The problem seems to be the backport repositories for kde 3.52. Could you please disable them (and koffice1.5) and see if the apts dist-upgrade works better then?

Thanks,
 Michael

Kenny Duffus (kduffus) wrote :

kubuntu-desktop is removed with or without the backports

arild (info-abergh) wrote :

I can confirm this bug also, here is the sources.list:

# Automatically generated sources.list
# http://www.ubuntulinux.nl/source-o-matic
#
# If you get errors about missing keys, lookup the key in this file
# and run these commands (replace KEY with the key number)
#
# gpg --keyserver subkeys.pgp.net --recv KEY
# gpg --export --armor KEY | sudo apt-key add -

# Ubuntu supported packages (packages, GPG key: 437D05B5)
deb http://uk.archive.ubuntu.com/ubuntu dapper main restricted
deb http://uk.archive.ubuntu.com/ubuntu dapper-updates main restricted
deb http://security.ubuntu.com/ubuntu dapper-security main restricted

# Ubuntu community supported packages (packages, GPG key: 437D05B5)
deb http://uk.archive.ubuntu.com/ubuntu dapper universe multiverse
deb http://uk.archive.ubuntu.com/ubuntu dapper-updates universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security universe multiverse

# Seveas' packages (packages, GPG key: 1135D466)
deb http://mirror.ubuntulinux.nl dapper-seveas all

# Ubuntu backports project (packages, GPG key: 437D05B5)
deb http://uk.archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse

# Cipherfunk multimedia packages (packages, GPG key: 33BAC1B3)
deb ftp://cipherfunk.org/pub/packages/ubuntu/ dapper main

# Penguin Liberation Front (packages)
deb ftp://ftp.free.fr/pub/Distributions_Linux/plf/ubuntu/plf/ breezy free non-free

#deb http://honk.physik.uni-konstanz.de/~wolfi/inkscape sarge

deb http://wine.budgetdedicated.com/apt dapper main

my sources.list

Wanted to mention that I am experiencing the same problem. In my case the update wants to remove my eclipse packages as well!?

same problem here.

Skaman (skamanna) wrote :

i think i got the same problem..I'll try to install kubuntu-desktop
i got almost this error: "no /home/skaman/.xsession file, no session manager, no window manager, no terminal, aborting"
Really Crap :S

Juan (ghurujuan) wrote :

Hi, i am newbie so be patient.
I had the same problem, but having 2 hd I decide to proceed anyway and I did it with the packg. manager.The sistem was ubuntu breezy with both gnome and kde... running with kde during upgrade.
All seemed to be fine but I had to reboot for other reasons and the only session type at the start was gnome.
after logging I had no menu, the desktop was empty, only the shortcuts of the previous version but no way of using them. So I had to reboot and install again all the way. end: all gone, and have to remount the /ext3/hdb with all datas inside... not done yet.
any suggestion?
Thanks

Zimzat (zimzat) wrote :

I was having this problem as well but have managed to get around it. I used Adept's "Safe Upgrade" command to slowly upgrade a few dozen packages at a time. I found a package that seemed mostly harmless, told it to upgrade it, then did "Safe Upgrade". One thing the "Safe Upgrade" option didn't like is that a lot of packages were uninstalled of one version and installed of another (e.g. removed something1.6 and installed something1.6a) or needed an additional dependency ("Safe" only assumed it was safe if it didn't have to remove or install anything, although I think installing additional packages is still safe).

If I recall correctly, these are the packages that conflicted with the rest of the KDE packages:
Amarok
k3b-mp3
kuickshow

My recommendation for getting around this particular dependency recursion is to manually mark "kde-base" for upgrade. Review the changes and manually reselecting some packages for install but undoing any changes that make it uninstall KDE again. Once you've gotten a few go ahead and commit them. Repeat this and it should be able to get most of the packages.

PS: The odd thing is that I managed to get Amarok and libk3b2-mp3 (as replacement for k3b-mp3) reinstalled. I'm figuring it's actually kuickshow that is the real show stopper but it doesn't have a candidate version to install anymore.

PPS: I've found Gwenview a better replacement of kuickshow if you need something to replace it.

ViTa (juane) wrote :

I have the same problem
Here is my apt-get dist-upgrade log and the sources.list

------------------------------------------------
http://www.vita.com.ar/distupgrade.log
http://www.vita.com.ar/sources.list

Josseck (langer-mann) wrote :

Any ideas on this one? Or did everybody just give up and reinstalled?

Patrick Kramp (sonic-) wrote :

I just reinstalled and forgot about it. Would be nice if it won't happen with the next release again though.

I got kde running with help from the forum (try searching for 'breezy
upgrade or something, I can;t find the link). However, my wireless
connection (wpa encryption/dell) is still not working. I'll stick to windows
now till I find the courage and time to fix it :-(

2006/7/29, Patrick Kramp <"<email address hidden>>:
>
> I just reinstalled and forgot about it. Would be nice if it won't happen
> with the next release again though.
>
> --
> dist-upgrade wants to delete almost kde packages while migrating from
> breezy to dapper
> https://launchpad.net/bugs/39658
>

--
Marc

www.m4rc.nl

Adam Pond (adpond) wrote :

I just re-installed and decided to switch to ubuntu instead for a bit of change. Next time I have to re-install, I'll consider Kubuntu then, but so far I'm happy with the gnome counterpart.

I've already added a note to my to-do list to get people to test for this, when dist-upgrading to edgy :)

Marco Cimmino (cimmo) wrote :

seems that upgrading from dapper to edgy produce the same bug!
Very stupid bug that is not fixed!

Someone can confirm?

Scott Kitterman (kitterman) wrote :

Dist-upgrade from Edgy to Feisty works correctly. If it wasn't fixed earlier, it's fixed now.

Changed in kubuntu-meta:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers