kubuntu-desktop missing "KDE" in description

Bug #235121 reported by Lars Noodén on 2008-05-27
8
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: kdesktop

Updated: This issue is about confusion due to not being able to find the kubuntu-desktop package by searching for KDE.

When I install the KDE4 version of Hardy, and then add KDE3.5.x after the fact,
the menu item 'system settings' is missing from the K menu
The old menu has
    systemsettings -caption "%c" %i %m

This was from kubuntu as installed from kubuntu-8.04-alternate-i386.iso plus recent updates.

Yuriy Kozlov (yuriy-kozlov) wrote :

Thank you for filing this bug. How did you install kde 3? Did you use kubuntu-desktop or another metapackage? Are you looking for/expecting system settings from KDE 3 or 4 to be in the menu?

Changed in kdebase:
status: New → Incomplete

I installed kde3 with something like
              apt-get install kdesktop

I am expecting KDE3 system settings to be in the menu, since it is KDE 3.

"kdesktop" is just the program that displays the desktop wallpaper and icons. By installing it you got a basic KDE desktop through dependencies, but did not get all the software KDE or Kubuntu ships. If you want a complete Kubuntu KDE3 desktop, including system settings, please install kubuntu-desktop. If you just want to add system settings to what you have now, install kde-systemsettings. I am closing this report since this is not a bug.

Changed in kdebase:
status: Incomplete → Invalid

Ok. I've just run through the whole thing on a fresh system. The actual installation process that created the problem was
   apt-get install kdesktop kdebase

However, the problem is with the package description for kubuntu-desktop

Can the string KDE be added to the description for Kubuntu-desktop? e.g.

  "Kubuntu's KDE desktop system"

or something similar.

Yes. The complete Kubuntu KDE 3.x desktop is what I was looking for. So this bug is not with kdesktop or kdebase, but with the package descriptions.

There are too many KDE apps to rummage through manually. [1] So the description and other metadata must help. Searching with apt-cache[2] helps me find kubuntu-kde4-desktop, edubuntu-desktop-kde, and kdesktop, but not the kubuntu-desktop (see below)

 $ apt-cache search kubuntu-desktop
 kubuntu-desktop - Kubuntu desktop system

====

[1]
 $ apt-cache search kde |sort|wc -l
 1589

[2]
 apt-cache search kde |grep desktop|sort
 amor - a KDE creature for your desktop
 amor-kde4 - a KDE creature for your desktop
 chemical-mime-data - chemical MIME and file type support for desktops
 desktop-base - common files for the Debian Desktop
 desktop-effects-kde - compiz setup tool for KDE
 desktop-profiles - framework for setting up desktop profiles
 edubuntu-addon-kde - Edubuntu add-on packages for the KDE desktop
 edubuntu-desktop-kde - edubuntu desktop system with KDE desktop
 education-desktop-kde - DebianEdu KDE desktop applications
 education-desktop-other - DebianEdu desktop applications, non-GNOME- and non-KDE-specific
 extragear-plasma-data - extras for the desktop and panel user interface tool for KDE4 - data
 extragear-plasma - extras for the desktop and panel user interface tool for KDE4
 gpe-appmgr - application manager for GPE desktop
 jockey-kde - KDE user interface and desktop integration for driver management
 kdesktop - miscellaneous binaries and files for the KDE desktop
 kdiamond-kde4 - A three-in-a-row game for the KDE 4 desktop
 kerry - a KDE frontend for the Beagle desktop search daemon
 kicker - desktop panel for KDE
 kopete-plugin-desklist - Kopete plugin which displays online contacts on desktop
 kpager - desktop pager for KDE
 krecordmydesktop - kde frontend to recordmydesktop
 krusader - twin-panel (commander-style) file manager for KDE (and other desktops)
 kstars-data - data files for KStars desktop planetarium
 kstars-data-kde4 - data files for KStars desktop planetarium
 kstars - desktop planetarium for KDE
 kstars-kde4 - desktop planetarium for KDE 4
 kubuntu-kde4-desktop - Kubuntu desktop system
 libplasma1 - library for the plasma KDE 4 desktop
 libplasma-dev - development files for the plasma KDE 4 desktop
 matchbox-desktop - desktop application launcher for resource-limited systems
 matchbox-desktop-dev - desktop application launcher [development files]
 qalculate-kde - Powerful and easy to use desktop calculator - KDE version
 stalonetray - Standalone freedesktop.org and KDE systray implementation
 trayer - lightweight GTK2-based systray for UNIX desktop

The problem is with the descriptive metadata in the package kubuntu-desktop, not kdesktop as originally reported

Changed in kdebase:
status: Invalid → New
description: updated
Changed in kubuntu-meta:
importance: Undecided → Wishlist
status: New → Triaged
Jonathan Thomas (echidnaman) wrote :

This debdiff should fix the bug.

Thanks.

Should the short description also be changed from "Kubuntu desktop system" to "Kubuntu's KDE desktop system? Or is the debdiff above enough to cause kubuntu-desktop to turn up in output from 'apt-cache search kde" ?

Terence Simpson (tsimpson) wrote :

apt-cache will search the full description, so the debdiff will fix that.

Jonathan: can you please take a look at it?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-meta - 1.76

---------------
kubuntu-meta (1.76) intrepid; urgency=low

  [ Jonathan Thomas ]
  * Change the package description to clarify that this package will
    install a full KDE desktop, closes LP: #235121

  [ Jonathan Riddell ]
  * Update update.cfg for intrepid

 -- Jonathan Thomas <email address hidden> Thur, 29 May 2008 19:36:23 -0500

Changed in kubuntu-meta:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers