Can't change Documents or Desktop paths

Bug #208253 reported by Olaf Lenz on 2008-03-28
26
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned
kubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: kubuntu-desktop

I'm using a fresh installation of Kubuntu 8.04beta (Heron) and I tried both the i386 and AMD64 versions.

When trying to change the Desktop or Documents paths to anything else, the changes are reset to ~/Desktop and ~/Documents when logging out and in again. What's more, when trying to change the Desktop path, all contents of the root path (/) are added to the desktop.

Steps to reproduce:

(0. Create a test user account not to destroy your own account.)
1. Open Kmenu -> System Settings -> About Me -> Paths
2. Change "Desktop path" to anything else (e.g. ~/KDesktop).
-> The new path is created, and the files from your Desktop are moved there.
-> However, the desktop shows the contents of the root directory (/).
3. If you try to change the Desktop path again, it will try to move all files from the root directory to the new directory, which will not suceed but require a number of warning messages to be confirmed.
4. Log out and in again.
-> The Desktop is empty, and the path has been reset to ~/Desktop.

The bug seems to be closely related to bug #174532.

I've tried manually changing [Paths] in ~/.kde/share/config/kdeglobals, but to no avail.

Olaf Lenz (olenz) wrote :

Rereading the comments of bug #174532, I noticed that when I change the path in the System Settings and click "Apply", the changes are correctly reflected in ~/.config/user-dirs.dirs, where the line

XDG_DESKTOP_DIR[$e]="/home/olenz/KDesktop"

occurs, however, I also get

> kde-config --userpath desktop
/
>

Olaf Lenz (olenz) wrote :

After some more digging into the problem, I've found a workaround, and I think that I also found the bug itself:

The KDE Control Center Module that changes the path creates an entry in ~/.config/user-dirs.dirs that has the form

XDG_DESKTOP_DIR[$e]="/home/olenz/KDesktop"

When removing the "[$e]" with an editor, and logging out and in again, the changed path persists, and everything works as intended.

The "[$e]" seems to originate from KDE, where it is found in the lines in ~/.kde/share/config/kdeglobals.
In ~/.config/user-dirs.dirs however, the "[$e]" has to be omitted.

I think the bug is therefore in the KDE control center module that edits the latter file. Now I wonder: is this a bug in KDE, or in Kubuntus modifications?

Zorael (zorael) wrote :

Confirmed on Hardy RC, x64 flavor.

The workaround works, too!

anigel (sarah-anigel) wrote :

In my case the bug and workaround is actually much simpler.

~/.config is left as root/root after the upgrade to hardy

chown ~/.config to your user and restart x and this fixes the problem.

TTL (supernova-2149) wrote :

I could not change the Documents folder from the KDE configuration as well, moreover not all directories mentioned in the user-dirs.dirs are visible in the KDE configuration utility.

JonnyT (jonnyt886) wrote :

I can confirm that in my case the [$e] does indeed seem to be the culprit. I had no ~/.config/user-dirs.dirs at all until changing the settings via KMenu->System Settings. Once I had changed those settings, the new directory I specified for Desktop appeared in user-dirs.dirs with the [$e]. Logging out and back in revealed no change (the contents of the root directory was still on the desktop), but removing the [$e] from the lines in there and logging out/back in then fixes the problem.

I'm a little puzzled that the Desktop directory was set to / even without the presence of user-dirs.dirs in my home directory (does this imply that some system-wide setting is using / as the default Desktop directory for new users?), and also that others have not mentioned this [$e] when documenting their workarounds (in this bug and bug #174532).

Zorael (zorael) on 2008-06-22
Changed in kubuntu-meta:
status: New → Confirmed
Changed in kubuntu-meta:
importance: Undecided → Medium
Jonathan Thomas (echidnaman) wrote :

Doesn't affect Intrepid.

Changed in kubuntu-meta:
status: Confirmed → Fix Released
Changed in kdebase:
status: New → Fix Released
tuxo (beat-fasel) wrote :

Jonathan Thomas wrote:

> Doesn't affect Intrepid.

>** Changed in: kubuntu-meta (Ubuntu)
> Status: Confirmed => Fix Released

>** Changed in: kdebase (Ubuntu)
> Status: New => Fix Released

There was no fix released for KDE 3.5.

What about Hardy Heron 8.04? It is an LTS version and you forget about all those people that have production machines running using the KDE 3.5 environment and that cannot upgrade to Intrepid as KDE 4 is not yet ready for prime time and will not be for at least another year.

Can this bug not be retargeted at Hardy Heron 8.04?

Jonathan Thomas (echidnaman) wrote :

Kubuntu 8.04 was not an LTS, and even if it was it wouldn't warrant special treatment for bugs such as this. You just get security releases and paid Canonical support available for longer with LTS releases.

If users don't feel they want to upgrade, then that's too bad. Another big problem is that we don't know which of the numerous changes since KDE4 development started fixed this bug. Upgrading to KDE4 fixes this bug, and if you don't want to upgrade there is nothing we can do.

tuxo (beat-fasel) wrote :

Jonathan Thomas wrote:

> If users don't feel they want to upgrade, then that's too bad.
>
> Upgrading to KDE4 fixes this bug, and if you don't want to upgrade there is nothing we can do.

Excellent attitude. Look, there are people out there who earn money using their computers and cannot upgrade every 6 months with all the regressions that come with each release.

What about *fixing bugs* instead of waiting for upstream to bring out a whole new version and push it right onto users before it is mature? Or is Kubuntu targeted at hobbyists only?

Olaf Lenz (olenz) wrote :

What about *fixing the bug yourself*, instead of bugging people who work on creating a useful distribution voluntarily and in there free time? It's all open source.

I wonder what would happen in a commercial OS. Probably you would have to buy a new version, before the bug got fixed. At least, I have never heard that anybody even got an answer on a bug report to Microsoft, commercial or not.

I've given a workaround somewhere above, so it is not impossible to work with this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers