Ubuntu

Kubuntu does not have the same "magic" than Ubuntu

Reported by usr on 2007-10-07
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LiveCreator
Undecided
Unassigned
Network Share Manager
Undecided
Unassigned
Ubufox Extension
Undecided
Unassigned
baobab
Invalid
Undecided
Unassigned
displayconfig-gtk
Undecided
Unassigned
gnome-codec-install
Invalid
Undecided
Unassigned
migration-assistant
Invalid
Undecided
Unassigned
samba-gtk
Invalid
Undecided
Unassigned
desktop-base (Fedora)
Invalid
Undecided
Unassigned
kubuntu-meta (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Brian Murray
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray
usb-creator (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Brian Murray

Bug Description

GNOME had more lacks than KDE. Ubuntu's developers have solved it, and the proof of this is that in Ubuntu's 7.10 GNOME already it is not necessary to open a terminal to configure the system.

For it, I think that now it is the moment to offer a bit more of contribution to the Kubuntu project, and to obtain this way a distro as perfect as Ubuntu, but with the whole potential that KDE offers (¡It 's possible rip audio CDs with "copy & paste"!), which will be, undoubtedly (in my opinion), the definitive desktop.

With this I want to say, that, you should put the same "magic" simultaneously in both distributions.
An example: It has been necessary to wait to kubuntu 7.10 to have GDebi-KDE (GDebi is in GNOME since Ubuntu 6.06).
They are a lot of automations that are not in Kubuntu, but yes in Ubuntu. For it, my request for to have in Kubuntu the same magic that exists in Ubuntu, and at the same time.

--------------------------------------------------

Here, the wiki of features: https://wiki.kubuntu.org/Kubuntu/UbuntuFeatureParity

Related Ubuntu brainstorm ideas:
- Idea #478: Support Kubuntu and KDE the way you support Ubuntu and GNOME: http://brainstorm.ubuntu.com/idea/478/
- Idea #14276: Create a website to donate money for one more paid developer for Kubuntu: http://brainstorm.ubuntu.com/idea/14276/

--------------------------------------------------

I trust that you will not leave Kubuntu delayed, like it has been till now.
I would like to make reference to bug #1.

Thank you for Kubuntu, it's the only O.S. that I used every day and I installing to my friends.
I wish the best you, to give the best us.

usr (usrlp) wrote :

Thank you for Kubuntu, it's the only O.S. that I use every day and I am installing to my friends.
I wish the best thing you, to give the best thing us.

P.S: Excuse me for my poor English.

Martin Böhm (martin.bohm) wrote :

Thank you for your feedback!

We (the Kubuntu developers) know that Kubuntu is behind Ubuntu. We are trying hard to implement the best things from Ubuntu into Kubuntu, but we are never going to be equal - we have less developers and marketing than Ubuntu does.

On the other hand, we believe Kubuntu is the most user-friendly KDE-centric Deb-based distribution out there and we are constantly trying to improve it.

Most of your suggestions are currently being developed for the next version of Kubuntu, Kubuntu 8.04 Hardy Heron. There is going to be a new printer config applet, an upgraded driver manager, automatic codec installation for Kaffeine and more. Please stay with us and keep informing us about the features you would like to see in Kubuntu.

Changed in kubuntu-meta:
assignee: nobody → kubuntu-team
importance: Undecided → Wishlist
status: New → In Progress
usr (usrlp) wrote :

- adept_manager:
Ubuntu's update manager shows in the system tray a restart icon (with the respective emergent message) when you makes an important update. adept_manager does not show any icon or message in the system tray.

Terence Simpson (tsimpson) wrote :

Adept Notifier does that too

usr (usrlp) wrote :

"Adept Notifier does that too"
OK.
--

"More "magic" for Kubuntu"
Related bugs:
- Bug #126579
- Bug #189828

usr (usrlp) wrote :

BulletProofX for Kubuntu.

http://wiki.ubuntu.com/BulletProofX

usr (usrlp) on 2008-02-13
description: updated
description: updated
description: updated
description: updated
description: updated
usr (usrlp) on 2008-02-13
description: updated
usr (usrlp) on 2008-02-17
description: updated
usr (usrlp) on 2008-02-17
description: updated
usr (usrlp) on 2008-03-07
description: updated
description: updated
usr (usrlp) on 2008-03-07
description: updated
description: updated
usr (usrlp) on 2008-03-07
description: updated
usr (usrlp) on 2008-03-09
description: updated
usr (usrlp) on 2008-03-09
description: updated
usr (usrlp) on 2008-03-22
description: updated
Martin Fitzpatrick (mfitzp) wrote :

Is part of the problem that currently there is KDE 3.x and KDE 4.x to support? It means duplicated effort in getting KDE up to speed - and any improvements worked over from Gnome to KDE will need to go to both versions of the desktop (for the forseeable future). So, where do you need most help? This bug & the brainstorm keeps getting featured on KDE's dot ( http://dot.kde.org/1206954953/1207066710/ ) so if you ask, perhaps you'll get the awareness and developers you need!

I'd like to help (have worked on bugchecking etc.) although the current situation seems kind of overwhelming to dig into. Any suggestions?

usr (usrlp) on 2008-04-30
description: updated
description: updated
description: updated
usr (usrlp) on 2008-04-30
description: updated
usr (usrlp) on 2008-04-30
description: updated
usr (usrlp) on 2008-04-30
description: updated
usr (usrlp) on 2008-04-30
description: updated
description: updated
MohamadReza Mirdamadi (mohi) wrote :

its really nice to have firefox-kde-support specially in Hardy with the FF's ugly face there!

usr (usrlp) on 2008-05-15
description: updated
description: updated
usr (usrlp) on 2008-05-15
description: updated
usr (usrlp) on 2008-05-15
description: updated
description: updated
description: updated
description: updated
usr (usrlp) on 2008-05-15
description: updated
usr (usrlp) on 2008-05-15
description: updated
description: updated
description: updated
usr (usrlp) on 2008-05-22
description: updated
description: updated
description: updated
usr (usrlp) on 2008-05-22
description: updated
description: updated
usr (usrlp) on 2008-05-29
description: updated
usr (usrlp) on 2008-06-30
description: updated
description: updated
description: updated
usr (usrlp) on 2008-06-30
description: updated
usr (usrlp) on 2008-06-30
description: updated
usr (usrlp) on 2008-06-30
description: updated
usr (usrlp) on 2008-06-30
description: updated
description: updated
usr (usrlp) on 2008-06-30
description: updated
description: updated
usr (usrlp) on 2008-07-05
description: updated
description: updated
usr (usrlp) on 2008-07-05
description: updated
usr (usrlp) on 2008-07-05
description: updated
description: updated
kko (kko) wrote :

Could you enlighten me please, why is there a Fedora task for a Kubuntu bug?

usr (usrlp) wrote :

I don't have any flashlight, but you must:
1.) Try a clean installation of Fedora with GNOME.
2.) Try a clean installation of Fedora with KDE.

usr (usrlp) on 2008-09-08
description: updated
usr (usrlp) on 2008-09-09
description: updated
description: updated
Changed in kubuntu-meta:
assignee: kubuntu-bugs → nobody
usr (usrlp) on 2008-09-18
description: updated
description: updated
usr (usrlp) on 2008-10-01
description: updated
usr (usrlp) on 2008-10-01
description: updated
usr (usrlp) on 2008-10-10
description: updated
dotancohen (dotancohen) wrote :

I think that what usr is trying to express is that Fedora with KDE works as well as Fedora with Gnome. Actually, in my own opinion with the distro it works better. Same for Mandriva, Suse, and most other distros. The system is more polished and the system management tools are better integrated. In contract, Kubuntu feels like KDE slapped onto a Gnome system.

That said, I agree that the word "Fedora" should be removed from Affects. How did it get there in the first place?

Sokraates (sokraates) wrote :

I concurr with the general idea and most of the mentioned features. However:

- [Wishlist: Ubuntu 6.06] When kdesudo requests the password, the rest of the screen must fade to grayscale like with gksudo.

Please don't. Just don't. It's not nice to be forced to focus on the password field when you perhaps want to finish something else first . To comment more productively: before any decision on such feature, a usabilty study should be made.

- [Wishlist: Ubuntu 8.04] PolicyKit.
- [Wishlist: Ubuntu 8.04] PulseAudio by default. GUI for PulseAudio too.

Are these actually necessary? At least with Phonon in KDE4, PulseAudio by default seems redundant.

Harald Sitter (apachelogger) wrote :

Pulseaudio will not be implemented unless there is an uber good reason to do so. KDE had a sound server once, and we all know how that went.
Besides, pulseaudio mostly is just fixing a problem resulting from crappy ALSA implementations, so it is essentially just a work around, while the proper solution would be to fix the ALSA support for broken applications.

usr (usrlp) on 2008-10-24
description: updated
usr (usrlp) on 2008-10-24
description: updated
usr (usrlp) on 2008-10-24
description: updated
usr (usrlp) on 2008-10-24
description: updated
usr (usrlp) on 2008-10-25
description: updated
usr (usrlp) on 2008-10-25
description: updated
Harald Sitter (apachelogger) wrote :

Stop doing pointless description changes!

kko (kko) wrote :

"Stop doing pointless description changes!"

I respectfully disagree. At least one usr cares about how Kubuntu performs compared to Ubuntu and how much love it gets compared to its counterpart enough to bother tracking the development, and I'm thankful for that.

Yes, the spam is a bit annoying even if I can live with it, and in an ideal world the past two days' changes could've perhaps been done all in a bunch, but the changes as such aren't pointless.

Also, after Intrepid and Jaunty, there's K. The K release would be a *really* good point to put some LOVE in Kubuntu with KDE 4 and polish it real good, and following on this *use the K name* to put some more marketing & media buzz behind Kubuntu as well.

(That said, I concur with Sokraates on this one: *Forcing* the user to focus on a password field (bug 55299) does *not* increase the "magic" / usability of KDE / Kubuntu. The user is fully capable of deciding on their own what they want to do, thank you.)

Terence Simpson (tsimpson) wrote :

"At least one usr cares about how Kubuntu performs compared to Ubuntu"
Yeah, because we obviously don't care, that's why we devote our free time to it. Right?

kko (kko) wrote :

My apologies if you read that as provocative.

For me it is a given that the developers *do* care, and because of this I respect and am grateful for the work that you do.

Which is why I was a bit surprised by Harald Sitter's reaction. I think what users can contribute to the development of FOSS, including tracking bugs and feature requests, is also valuable (and shows that *also* users care), so I objected to the statement that what usr was doing was "pointless".

Yes, having a few more e-mails in the box more than the minimum necessary may be a bother, but hey, accidents happen and we don't live in an ideal world, so I wanted to urge for a bit more tolerance instead of the negation of usr's contribution implied by "pointless".

Respect goes both ways.

Again, thank you for your work.

kko (kko) wrote :

And let me add that skimming through the earlier comments in this bug, the mutual respect is there, and I'm glad it is.

Terence Simpson (tsimpson) wrote :

The objection was not just to the latest edits, but the many previous edits[1]. So it's not just a few more emails, it's many.
This type of thing would be more suited to a wiki page, for instance the Kubuntu TODO wiki page[2]. Many of us don't even class this as a "bug" as such; Bugs are specific items to be addressed, this is more of a concept and a list to other bugs. When one of those bugs gets updated we get an email from that bug, then an edit from this bug. This does get frustrating after a while as it adds to the "noise" we have to wade through to deal with other bugs.

[1] https://bugs.launchpad.net/ubuntu/+source/kubuntu-meta/+bug/150333/+activity
[2] https://wiki.kubuntu.org/Kubuntu/Todo

kko (kko) wrote :

Thanks for your response. I'm aware of the history, and I can understand handling the bug traffic does involve work, though there may be ways around it.

However, if the issue is that "this would be more suited to a wiki page", I think Harald Sitter could've said as much, instead of his exclamation above. The exclamation was in direct contrast to Martin Böhm's first comment above - "Thank you for your feedback! ... Please stay with us and keep informing us about the features you would like to see in Kubuntu."

I think that tracking Kubuntu's status in this manner (compared with Ubuntu) within the bug tracker is a useful exercise - individual bugs do sometimes get lost and abandoned in the mass, and this report helps by keeping the big picture updated. If the developers are going to disagree and say that elsewhere, like on the Kubuntu Todo wiki page you referenced, would be preferable, that's for you to decide. (From the viewpoint of a user however, Launchpad is a very accessible medium.)

Terence Simpson (tsimpson) wrote :

It would definitely be more suited to a wiki IMO, there's also the Kubuntu Developers MailingList for direct communication with the development team: https://lists.ubuntu.com/mailman/listinfo/kubuntu-devel
Using the bugtracker for this seems a bit clumsy, using wiki-like features for updates and comments for communication (wiki + email).
Don't forget we also have #kubuntu-devel on irc.ubuntu.com (irc.freenode.net) where you can talk to the development team live and discuss things that are bothering you (and help out ;)
Different mediums are suited for different things, probably the reason no one has yet come up with the one killer communication medium.

usr (usrlp) on 2008-10-26
description: updated
description: updated
description: updated
usr (usrlp) wrote :

Hi, Kubuntu friends!
I'm sorry, excuse me for the editions. It was not my intention to do any wrong. I hope that my edits do not do problems between us.

Terence Simpson, thank you for the links.

To all: It is possible to make a wiki where we (the users) can write about the features that we like see at Kubuntu?

Thanks to all for the help and for contribute to make Kubuntu better!
I apologize for the inconvenience. :-(

Jonathan Thomas (echidnaman) wrote :

https://wiki.kubuntu.org/Kubuntu/UbuntuFeatureParity
I just copy/pasted the description into the new page, so it need some tidying up. (But I trust you can do that?)
Go wild. ;-)

Changed in kubuntu-meta:
status: In Progress → Invalid
Changed in desktop-base:
status: New → Invalid
usr (usrlp) wrote :

Thank you, Jonathan. I write better the wiki page.

But this bug is "in progress" also (not "invalid"), because the problem exits for now.

description: updated
description: updated
Changed in kubuntu-meta:
status: Invalid → In Progress
Harald Sitter (apachelogger) wrote :

a) kko: do one week of daily bug triage and then think about what you wrote (FYI Martin didn't do that either) and if there were more than 4 people working on Kubuntu bugs (in the amount necessary) I would probably have no problem with this bug. But since this is not the case, the 4 of us have to ensure that every new and old bug gets the attention it needs to be resolved. I for one don't see why I should get flooded with formatting changes in a metabug that is not bug and certainly shouldn't be a metabug.
This is not that I disrespect the report or the work put into this "bug", I also understand that usr wants this to be looking good and easy understandable, but 90% of the changes done to this bug are either moving stuff around or changing word order. I guess everyone can understand that with a frequency of around 100 bug changes per day I am not willing to deal with _unnecessary_ updates to any bug.

b) usr: It is invalid.
kubuntu-meta is not in any way responsible for this, nor any other package, it is not a bug at all. It is not a wish either, it is a collection of wishes and status reports and comparisions, If you want you could refer to it as status tracking. This particular bug report is not discussion implimentation details or necessarity of the suggested changes, it just tracks their progress.
If you take a look at https://wiki.ubuntu.com/FeatureSpecifications it will make it quite obvious that everything this bug is, doesn't belong into a bug tracker, but a blueprint. Also this "bug" is in fact multiple ones, which is usually an unaccepted way to track "bugs" because it causes unnecessary updates and makes handling for bug triagers more difficult.
So, please follow the feature specifciation page from above or report regression bugs to their appropriate bugs, but this bug as it is is invalid.

Changed in kubuntu-meta:
status: In Progress → Invalid
usr (usrlp) wrote :

OK. I apologize and thanks again.

kko (kko) wrote :

Terence Simpson:

"Different mediums are suited for different things, probably the reason no one has yet come up with the one killer communication medium."

Indeed. And that's why we have video in telephones that can do textual communication etc. :-)

Different mediums are also differently suited for different people.

Harald Sitter:

"This is not that I disrespect the report or the work put into this "bug", I also understand that usr wants this to be looking good and easy understandable, but 90% of the changes done to this bug are either moving stuff around or changing word order."

Alright, thank you - I don't want to continue arguing about the relevance of the changes. Apologies for interfering.

However, I'm glad this seems settled, and that hopefully a suitable and appropriate medium for status tracking - a blueprint or a wiki page - can now be found.

(Apparently one can also get e-mail updates from a blueprint and/or the wiki page.)

Rafael Belmonte (eaglescreen) wrote :

Fixed for usb-creator 0.2.2.

Changed in usb-creator (Ubuntu):
status: New → Fix Released
Harald Sitter (apachelogger) wrote :

Thanks for not reading the previous comments \o/
Here's to another bug that affects a billion packages but still no one will care any more about it.

Jonathan Thomas (echidnaman) wrote :

Closing unused upstream bug watches.

Changed in displayconfig-gtk:
status: New → Invalid
Changed in live-creator:
status: New → Invalid
Changed in network-share:
status: New → Invalid
Changed in ubufox:
status: New → Invalid
Changed in baobab:
status: New → Invalid
Changed in gnome-codec-install:
status: New → Invalid
Changed in migration-assistant:
status: New → Invalid
Changed in samba-gtk:
status: New → Invalid
usr (usrlp) wrote :

@Harald Sitter:
I am reading https://wiki.kubuntu.org/Kubuntu/Todo
I read the previous comments but some months ago and the link had not any of the things that now are in this page.

Excuse me, but with sarcasms is not going anywhere.

Rafael Belmonte (eaglescreen) wrote :

Please make a ubuntuone-client-kde for Kubuntu.

Jonathan Thomas (echidnaman) wrote :

Please don't use this trainwreck of a bug report for anything. There is a bug tracking a KDE ubuntu one client at bug 375145.

Changed in ubuntuone-client (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints