kde plasma5 crashes on login

Bug #1448677 reported by jrose
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

This is for kubuntu. I just upgraded from 14.10 to 15.04 using `do-release-upgrade`.
As far as I could tell, there were no errors during the upgrade process.

I'm using sddm. On startup, I get the login screen, I enter my password,
then I see the progress bar briefly before the screen flickers and ultimately returns me to
the login screen.

I'm looking at syslog, and I see some suspicious messages:
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: QXcbConnection: Failed to get the primary output of the screen
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: kdeinit5: Fatal IO error: client killed
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: klauncher: Exiting on signal 15
Apr 26 08:13:26 john-M17xR4 org.gtk.vfs.Daemon[3102]: A connection to the bus can't be made
Apr 26 08:13:26 john-M17xR4 org.gtk.vfs.Daemon[3102]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: QXcbConnection: Failed to get the primary output of the screen
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: The X11 connection broke (error 1). Did the X11 server die?
Apr 26 08:13:26 john-M17xR4 org.a11y.Bus[3102]: g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Apr 26 08:13:26 john-M17xR4 org.a11y.atspi.Registry[3154]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":1"
Apr 26 08:13:26 john-M17xR4 org.kde.kglobalaccel[3102]: QXcbConnection: Failed to get the primary output of the screen
Apr 26 08:13:26 john-M17xR4 org.kde.kglobalaccel[3102]: The X11 connection broke (error 1). Did the X11 server die?
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: The X11 connection broke (error 1). Did the X11 server die?
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: klauncher: Exiting on signal 11
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: crashing... crashRecursionCounter = 2
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: Application Name = kdeinit5 path = /usr/bin pid = 2992
Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: Arguments: /usr/bin/kdeinit5 --fd=8
Apr 26 08:13:26 john-M17xR4 org.a11y.atspi.Registry[3154]: after 29 requests (29 known processed) with 0 events remaining.
Apr 26 08:13:26 john-M17xR4 kernel: [ 817.274492] QSGRenderThread[3186]: segfault at 7f97d5a284b0 ip 00007f97d5a284b0 sp 00007f97c35ee488 error 14 in locale-archive[7f97d5abc000+2c9000]

Any idea where I should go from here?

Thanks,
-John

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1448677/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
jrose (jroesler)
affects: ubuntu → kubuntu-meta (Ubuntu)
tags: added: vivid
Revision history for this message
jrose (jroesler) wrote : Re: [Bug 1448677] Re: kde plasma5 crashes on login
Download full text (3.3 KiB)

Just a quick update. I couldn't afford to wait, and I had nothing obvious
to try, so I just backed everything up and reinstalled 15.04 from disc.

The tracpad was disabled by default, which was weird, but otherwise it's
working fine now.

Sorry I deprived you of the debug opportunity. Hopefully it was just
something weird in my system state.

Thanks,
John
** Tags added: vivid

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1448677

Title:
  kde plasma5 crashes on login

Status in kubuntu-meta package in Ubuntu:
  New

Bug description:
  This is for kubuntu. I just upgraded from 14.10 to 15.04 using
`do-release-upgrade`.
  As far as I could tell, there were no errors during the upgrade process.

  I'm using sddm. On startup, I get the login screen, I enter my password,
  then I see the progress bar briefly before the screen flickers and
ultimately returns me to
  the login screen.

  I'm looking at syslog, and I see some suspicious messages:
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: QXcbConnection: Failed
to get the primary output of the screen
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: kdeinit5: Fatal IO
error: client killed
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: klauncher: Exiting on
signal 15
  Apr 26 08:13:26 john-M17xR4 org.gtk.vfs.Daemon[3102]: A connection to the
bus can't be made
  Apr 26 08:13:26 john-M17xR4 org.gtk.vfs.Daemon[3102]:
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying
GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: QXcbConnection: Failed
to get the primary output of the screen
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: The X11 connection broke
(error 1). Did the X11 server die?
  Apr 26 08:13:26 john-M17xR4 org.a11y.Bus[3102]:
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying
GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
  Apr 26 08:13:26 john-M17xR4 org.a11y.atspi.Registry[3154]: XIO: fatal IO
error 11 (Resource temporarily unavailable) on X server ":1"
  Apr 26 08:13:26 john-M17xR4 org.kde.kglobalaccel[3102]: QXcbConnection:
Failed to get the primary output of the screen
  Apr 26 08:13:26 john-M17xR4 org.kde.kglobalaccel[3102]: The X11
connection broke (error 1). Did the X11 server die?
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: The X11 connection broke
(error 1). Did the X11 server die?
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: klauncher: Exiting on
signal 11
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: crashing...
crashRecursionCounter = 2
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: Application Name
= kdeinit5 path = /usr/bin pid = 2992
  Apr 26 08:13:26 john-M17xR4 org.kde.kded5[2985]: KCrash: Arguments:
/usr/bin/kdeinit5 --fd=8
  Apr 26 08:13:26 john-M17xR4 org.a11y.atspi.Registry[3154]: after 29
requests (29 known processed) with 0 events remaining.
  Apr 26 08:13:26 john-M17xR4 kernel: [ 817.274492] QSGRenderThread[3186]:
segfault at 7f97d5a284b0 ip 00007f97d5a284b0 sp 00007f97c35ee488 error 14
in locale-...

Read more...

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in kubuntu-meta (Ubuntu):
importance: Undecided → Critical
Changed in kubuntu-meta (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Francesco Belladonna (fire-dragon-dol) wrote :

@Alberto I think I found the reason.

The bug is that startup scripts containing `exit` (0 or 1 or whatever exit code) added through the UI "stops" the user from logging in.

I think this is a regression, had this problem before, but I had this script for long time (starts yakuake) and only today it started causing problems.

Revision history for this message
Francesco Belladonna (fire-dragon-dol) wrote :

Just to be clear, "added through ui" in ubuntu means the script is in .config/plasma-workspace/env/yourscript.sh

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers