installing package from konqueror uses dpkg, does not provide automatic dependency resolution

Bug #123111 reported by Ben Aceler on 2007-06-29
2
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Wishlist
Martin Böhm

Bug Description

Binary package hint: konqueror

If I have some .deb files in a directory, I want to install it using right-click menu. I can do it, but konqueror use dpkg, and dpkg cannot resolve dependencies automatically. Please, use some more sophisticated software, like aptitude or something else.

Ignoring the issues of the user being incorrect (we cant replace dpkg with aptitude - aptitude is a frontend to dpkg, as is apt)...

Martin, i'm assuming that you've either fixed this, or will fix this with your gdebi-kde, to pull dependancies in first?

On second thoughts though - because the deb is not from a repository, the dependencies may or may not exist in a repository on the users system, we could only install the ones that do - which in no way are guaranteed to be all of them. Feel free to mark this as invalid, or implement this in some way.

Changed in kdebase:
assignee: nobody → martin.bohm
importance: Undecided → Wishlist
Daniel Hahler (blueyed) wrote :

Aceler, what do you pick from the context menu, so that dpkg gets used?

I have GDebi and KPackage available in the "Open With" submenu, but not dpkg nor "Install".

Ben Aceler (aceler) wrote :

By default, Kubuntu does not contain GDebi or KPackage. When I right-click on a deb file, I have only "Kubuntu Package Menu", which consists only "Install package", "Uninstall package" and "Show package info". All of this points lead to dpkg. GDebi is a good thing, thanks, but it doesn't included in kubuntu.

Also, if I have several pakages, like OpenOffice do (without any dependencies problems), I still have to install it one by one, and resolve them with my hand.

And the last - the problem is not with the particular deb file.

Martin Böhm (martin.bohm) wrote :

This feature is already implemented in Kubuntu 7.10 "Gutsy Gibbon", which will be released in October. It is not a critical bug, and therefore we don't plan to release the fix for Feisty Fawn.

In Kubuntu Gutsy the Kubuntu Package menu is removed completely and a GDebi Package Installer for KDE (gdebi-kde) is present. Gdebi-kde should automatically download dependencies from the repositories, if the required packages are present. If you want to test it, feel free to upgrade to the current development release - Kubuntu Gutsy Tribe 2. Try this new frontend, and report the bugs you found. Thank you.

I am marking it as "Fix Released" because this feature is already implemented in the development version of Kubuntu.

Changed in kubuntu-meta:
status: New → Fix Released
Ben Aceler (aceler) wrote :

OK, thank you! If I'll find a new bug for gdebi-kde, I'll start a new bug entry.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers