make non-essential packages Recommends and not Depends

Bug #119467 reported by Luka Renko on 2007-06-09
22
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Medium
Jonathan Riddell
Gutsy
Medium
Jonathan Riddell

Bug Description

Binary package hint: kubuntu-desktop

Since kubuntu-desktop installs all packages in Recommends, it would make a lot of sense to move all non-essential packages from Depends to Recommends. This will allow users to remove some packages that they may not need or in cases they would like to use own version (fro example from SVN). This have already been done in past for digikam, kipi-plugins, knetworkmanager...

This will also prevent workarounds like this:
http://apachelog.blogspot.com/2007/06/free-injections.html

Hobbsee has provided a list of current Depends: http://rafb.net/p/RromAg15.html

From this list, I would say this are candidates for "demotion" to Recommends:
amarok
cdrdao
cdparanoia
dvd+rw-tools
k3p
kaffeine-xine
kamera
kate
keep
kfind
kmailcvt
konversation
kooka
kopete
kpdf
kpf
kppp
krdc
krfb
ksysguard
ktorrent
wodim

Is there any side-effect of doing this?

Harald Sitter (apachelogger) wrote :

There is a side-effect, a pretty ugly one actually:

Micheal is using Ubuntu, he recently discovered the love KDE is offering and wants to switch to comple Kubuntu Desktop. $SEARCHWEBSITE is telling him, that by installing kubuntu-desktop he will get a complete Kubuntu environemnt. Micheal apt-gets kubuntu-desktop, but soon has to discover, that he doesn't have a music player, a bruning application, a IM-client etc. Micheal is kinda disappointed and switches back to Ubuntu.

apt installs recommends by default now, doesn't it?

I don't understand the problem.

kubuntu-desktop is just a meta package so if you deinstall one of it's dependencies you don't have installed the kubuntu-desktop meta package anymore so it will be removed. (and only kubuntu-desktop package not its other dependencies)

And no apt does not install recommends by default.

So it is not a bug it's a feature.

Luka Renko (lure) wrote :

apt will install Recommends by default - this was changed in Feisty (or even Edgy). I think this is only true for meta packages.
The only difference is that you can remove Recommended package without removal of kubuntu-desktop. If you remove kubuntu-desktop, you will not get new packages that may have been added between releases.

Harald Sitter (apachelogger) wrote :

This would mean that making almost every application recommended instead of depending is just a logical result.

But... there is most likely a problem with upgrading. Considering almost every app is recommend (as mostly kubuntu-desktop needs to depend on basic KDE), the user can remove any app he wants to, now if he does a dist-upgrade it either installs every recommend again (therefore the whole delete that app thing was useless) or it doesn't do so, but then also doesn't install new recommends (i.e. if a new app is added to -desktop with recommend it will not get installed when upgrading).

Means: this thought has to start all over again :|

If peaple deinstall a default application they choose not to use the kubuntu-desktop default package selection so kubuntu-desktop is removed.

If new packages are added in a new release they will not get them by default because they choose not to use the default package selection. They can however install them manually, so where is the problem?

You have to decide between default package selection and customized package selection you can't have both.

aptitude installs recommended packages by default apt doesn't.

Let's try to see this fixed for tribe 2.

Jonathan Riddell (jr) wrote :

I'm not altogether happy with making everything a recommends. Packages are recommends where there's good reasons for people to remove them but still have a Kubuntu Desktop. If you start removing all applications you may as well just not install kubuntu-desktop.

Allcolor-g (allcolor) wrote :

What the hell is this ?

Could it be removed ? Aren't email address verified on launchpad before permitting to someone to post ?

Tom Haddon (mthaddon) wrote :

Comment deleted. Emails do have to be verified before posting to Launchpad, but that doesn't always prevent malicious users from posting offensive comments.

Martin Pitt (pitti) wrote :

This should rougly follow the approach of ubuntu-desktop: applications which can be considered 'optional' for a KDE desktop and are likely to be replaced with an alternative by many users should become a Recommends. Those are still installed by default, but changing a single application won't break updates any more.

E. g. in Ubuntu we did this for evolution and firefox because many people prefer thunderbird and epiphany. We also did it for network-manager, since it breaks for many users, and they should be able to uninstall it without much fuss. Other good candidates are CJK fonts, documentation, etc.

Changed in kubuntu-meta:
assignee: nobody → jr
importance: Undecided → Medium
status: Unconfirmed → Confirmed

So make 90% of the applications recommended because in the linux world almost every program can be replaced by another.

Download full text (9.0 KiB)

Accepted:
 OK: kubuntu-meta_1.37.tar.gz
 OK: kubuntu-meta_1.37.dsc
     -> Component: main Section: base

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 26 Jun 2007 01:26:20 +1000
Source: kubuntu-meta
Binary: kubuntu-desktop
Architecture: source
Version: 1.37
Distribution: gutsy
Urgency: low
Maintainer: Jonathan Riddell <jriddell at ubuntu.com>
Changed-By: Sarah Hobbs <hobbsee at ubuntu.com>
Description:
 kubuntu-desktop - Kubuntu desktop system
Changes:
 kubuntu-meta (1.37) gutsy; urgency=low
 .
   * Refreshed dependencies
   * Added adept to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added amarok to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added cdparanoia to desktop-recommends-i386, desktop-recommends-
     amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added cdrdao to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added dolphin to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc
   * Added dvd+rw-tools to desktop-recommends-i386, desktop-recommends-
     amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added fortune-mod to desktop-recommends-i386, desktop-recommends-
     amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added k3b to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added kaffeine-xine to desktop-recommends-i386, desktop-recommends-
     amd64, desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added kamera to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added kate to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added keep to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added kfind to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, desktop-recommends-hppa
   * Added klipper to desktop-recommends-i386, desktop-recommends-amd64,
     desktop-recommends-powerpc, desktop-recommends-ia64, desktop-
     recommends-sparc, deskto...

Read more...

Changed in kubuntu-meta:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers