language-support-* packages depend on Firefox, Thunderbird and Open Office Writer on Ubuntu and Kubuntu

Bug #114503 reported by Eero Tamminen
32
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Invalid
Medium
Unassigned
openoffice.org-l10n (Ubuntu)
Fix Released
High
Unassigned
ubuntu-meta (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

language-support-LANG packages depend on language-support-translations-LANG, which in turn depend on openoffice-help-LOCALE, mozilla-firefox-locale-LOCALE and thunderbird-locale-LOCALE. These last three packages in turn depend on OpenOffice Writer, Firefox and Thunderbird.

Users who want language support do not necessarily also want to install large extra user applications, particularly not on Kubuntu where, for example, Firefox is not the default browser. It also means that anyone who uninstalls any of these applications will be told that they need to uninstall their language packs too.

This problem holds on Edgy, Feisty, Gutsy and Hardy.

ORIGINAL DESCRIPTION:
Version:
- Kubuntu: Feisty Fawn, 7.04

Test-case:
- Install Kubuntu from live-CD with default options
- Once overything is installed, use add/remove packages and install language-support, e.g. for "fi"

Expected outcome:
- Packages related to support of that language are installed

Actual outcome:
- Also Firefox and Thunderbird are installed, which are not part of Kubuntu, nor something I need (because they are very large)

Could the language selection be a bit less dumb and actually check what things are needed?
Or maybe the support could be a bit more finegrained so that large language packs like Firefox & Thunderbird etc can be selected separately when installing languages?
(Maybe similarly how Windows installers by default have all components selected but user can leave out some of them)

(This is somewhat related edgy bug 64200)

Revision history for this message
Nicolas Piguet (npiguet) wrote :

I can confirm that problem, although I tried to install language_support_zh.

And I can also confirm that it's very annoying, especially when you are on a dead slow internet connection in china, and that downloading all the firefox and thunderbird packages take several hours.

Revision history for this message
Rich Johnson (nixternal) wrote :

CONFIRMED! Wow, this can't be all that great. If anything I think the the firefox language packs should "SUGGEST" firefox and not depend on it.

Package: language-support-fi
Priority: optional
Section: translations
Installed-Size: 40
Maintainer: Martin Pitt <email address hidden>
Architecture: all
Version: 1:7.04+20070209
Depends: mozilla-firefox-locale-fi-fi, openoffice.org-l10n-fi, thunderbird-locale-fi, tmispell-voikko, libenchant-voikko, openoffice.org-voikko, openoffice.org-hyphenation
Recommends: language-pack-fi
Filename: pool/main/l/language-support-fi/language-support-fi_7.04+20070209_all.deb
Size: 2406
MD5sum: e33243d413f2a3187cae057266230fed
SHA1: 92ac5eb5376bfceb8bc085a25e383c0b65f4cf62
SHA256: d99bb98afa77bcb39f62858becf7ef85afca5cd1a53bb907e3a75e5ce5ce9de4
Description: metapackage for Finnish language support
 This metapackage depends on all packages that provide native language
 support for applications in Ubuntu (like spell
 checkers, dictionaries, OpenOffice and Mozilla locale packages,
 etc.).
 .
 If you also want your applications and the desktop to be translated,
 please additionally install language-pack-fi.
 .
 Language: Finnish
Bugs: mailto:<email address hidden>
Origin: Ubuntu

============

Package: mozilla-firefox-locale-fi-fi
Priority: optional
Section: web
Installed-Size: 748
Maintainer: Ubuntu Core Developers <email address hidden>
Original-Maintainer: Cesar Martinez Izquierdo <email address hidden>
Architecture: all
Source: mozilla-firefox-locale-all
Version: 2.0.0.1ubuntu-1
Depends: firefox | language-support-fi
Conflicts: firefox (<< 1.99), firefox (>> 2.0.999)
Filename: pool/main/m/mozilla-firefox-locale-all/mozilla-firefox-locale-fi-fi_2.0.0.1ubuntu-1_all.deb
Size: 172406
MD5sum: 253cfd36f05c9d2e9039e255ee37feaa
SHA1: e7c122d0ea870afbbb1c6d019e2d2e76363a6d82
SHA256: aa180e4ef2c23769c03b4caacc1962c7866752367244f26f520b377d5653625a
Description: Mozilla Firefox Finnish language/region package
 Menu and message resource and region property package
 for Mozilla Firefox (Finnish language, fi-FI).
 .
 Homepage: http://www.mozilla.org
Bugs: mailto:<email address hidden>
Origin: Ubuntu

=============

Changed in kubuntu-meta:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Revision history for this message
Rich Johnson (nixternal) wrote :

I just emailed the kubuntu-devel list asking if it is possible to switch the depends on the firefox and thunderbird locales to suggest for thunderbird and firefox. This would prevent both from being installed.

Revision history for this message
Eero Tamminen (oak-helsinkinet) wrote :

> Package: language-support-fi
...
> Depends: mozilla-firefox-locale-fi-fi, openoffice.org-l10n-fi, thunderbird-locale-fi, tmispell-voikko,
> libenchant-voikko, openoffice.org-voikko, openoffice.org-hyphenation
> Recommends: language-pack-fi
...
> Package: mozilla-firefox-locale-fi-fi
...
> Depends: firefox | language-support-fi

Hm. A circular dependency. And how Firefox is a dependency alternative to language-support-fi???

Anyway, what I *would like* to see is that the language installation thing would create
the locale specific language support metapackage on the fly based on what packages are
installed to the system and just install that. This would work automatically right on all
Ubuntu variants.

That kind of a package would be trivial to create:
  if dpkg -s firefox; then
     depends += mozilla-filrefox-locale-$locale
  fi
etc.

And as to the versioning of that package, that package version needs just to increase
each time, it doesn't need to be tied to anything else.

Once a language support is installed once, it could have an option that it checks e.g.
monthly whether new packages are installed which need language support and ask
user whether they should be installed.

Alternatively solution would be an apt hook that checks new packages against a list
of packages which need locale specific language pack and which would install the selected
locale(s) package for them automatically.

I think both of these solutions are superior (work better for the user) than just fiddling
with fixed metapackage dependencies.

Revision history for this message
karaluh (karaluh) wrote :

> Once a language support is installed once, it could have an option that it checks e.g.
> monthly whether new packages are installed which need language support and ask
> user whether they should be installed.

It's bad idea. If I install new software I want it to be in language I specified with the first start of this app, not in a month.

> Alternatively solution would be an apt hook that checks new packages against a list
> of packages which need locale specific language pack and which would install the selected
> locale(s) package for them automatically.

IMHO it would be the best option in the long term.

description: updated
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

First, the mozilla-firefox-locale-* will disappear soon, since they are for Firefox 2, and with Firefox 3 we'll get the translations directly in the language packs.

Also, all dependencies are actually designed in a way to *not* pull in the application itself:

  Package: openoffice.org-l10n-fi
  Depends: openoffice.org-common (>= 1:2.4.0~rc2) | language-support-fi

  Package: thunderbird-locale-de
  Depends: thunderbird | language-support-de

and so on, thus the oo-l10n-* packages can be installed *without* openoffice itself being installed. The alternative dependency will make sure that installing l-support-* won't install the application, but installing thunderbird-locale-fr will properly pull in thunderbird itself if you don't have the French language-support package installed.

Revision history for this message
Martin Pitt (pitti) wrote :

Not an ubuntu-meta bug

Changed in ubuntu-meta:
status: New → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Not a kubuntu-meta bug.

Changed in kubuntu-meta:
status: Confirmed → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Ah, I found the culprit:

  Package: openoffice.org-help-fr
  Depends: openoffice.org-l10n-fr, openoffice.org-writer

Those must become "Depends: openoffice.org-l10n-fr, openoffice.org-writer | language-support-fr", or simply "Depends: openoffice.org-l10n-fr".

Changed in language-support-translations-en:
assignee: nobody → ccheney
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Triaged
Revision history for this message
Mary Gardiner (puzzlement) wrote : Re: [Bug 114503] Re: language-support-* packages depend on Firefox, Thunderbird and Open Office Writer on Ubuntu and Kubuntu

On Thu, Apr 03, 2008, Martin Pitt wrote:
> Also, all dependencies are actually designed in a way to *not* pull in
> the application itself:
>
> Package: thunderbird-locale-de
> Depends: thunderbird | language-support-de

Ah, for me the problem is that aptitude decides it wants both of them. I
can manually mark thunderbird as not to be installed without breaking
the dependency resolution but by default it selects an imperfect
solution that installs it. So it's not a bug in the dependencies so much
as a UI problem in aptitude: typically, users trust the presented
solution.

Revision history for this message
Chris Cheney (ccheney) wrote :

I believe that this problem has been fixed in OpenOffice in Hardy so I am marking it as Fix Released.

It now shows up as:

Package: openoffice.org-help-fr
Depends: openoffice.org-l10n-fr, openoffice.org-writer | language-support-translations-fr

Changed in openoffice.org-l10n:
assignee: ccheney → nobody
status: Triaged → Fix Released
milestone: ubuntu-8.04 → none
Revision history for this message
Erik Hill (thepurr) wrote :

In fact, installing Chinese language support after-the-fact on an English language Ubuntu still manages to install thunderbird on its own...

Not that I have anything against thunderbird...

Revision history for this message
Mary Gardiner (puzzlement) wrote :

language-support-translations-zh depends on thunderbird-locale-zh-(cn|tw). They depend on thunderbird OR language-support-zh, so language-support-zh itself satisfies the dependency.

Which package are you installing to get Chinese language support, and which program (apt-get, aptitude, synaptic... are you using to install it)?

Revision history for this message
Erik Hill (thepurr) wrote : Re: [Bug 114503] Re: language-support-* packages depend on Firefox, Thunderbird and Open Office Writer on Ubuntu and Kubuntu

I used System->Administration->Language Support, which I think uses
Synaptic to do its work.

On Thu, Apr 10, 2008 at 10:36 PM, Mary Gardiner <email address hidden> wrote:
> language-support-translations-zh depends on thunderbird-locale-
> zh-(cn|tw). They depend on thunderbird OR language-support-zh, so
> language-support-zh itself satisfies the dependency.
>
> Which package are you installing to get Chinese language support, and
> which program (apt-get, aptitude, synaptic... are you using to install
> it)?
>
>
>
> --
> language-support-* packages depend on Firefox, Thunderbird and Open Office Writer on Ubuntu and Kubuntu
> https://bugs.launchpad.net/bugs/114503
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Eero Tamminen (oak-helsinkinet) wrote :

see also bug 220817 (about openoffice).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers