Package kubuntu-desktop requires too many exotic fonts

Bug #108266 reported by Justin Sheckler on 2007-04-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Wishlist
Unassigned
Gutsy
Wishlist
Unassigned

Bug Description

Binary package hint: kubuntu-desktop

Kubuntu-desktop requires a whole slew of fonts for exotic languages that speakers of Western languages don't need. Fonts for Urdu, Lao, Oriya, Kannada and Thai are all included, as well as less uncommon languages like Arabic and Japanese. For me, these fonts are an inconvenience: none of them is of any use to me, and there's nearly as many included as there are Western fonts. If I remove these fonts, I break kubuntu-desktop, which can cause dist-upgrade to fail. Can't these fonts be rolled into separate language support packages, and be installed only when needed? The installer asks the user's language as its first step, after all. Or at the very least, could they be 'recommended' rather than 'required'?

Richard Johnson (nixternal) wrote :

Confirming and wishlisting this. It would be tough to do exactly what you want, but I am not counting it out. The reason for all of the language fonts is so Kubuntu is "internatialized" out of the box. I never realized that some of them packages are pushing 30+ MB in size once installed.

Changed in kubuntu-meta:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed

certainly some of these could be recommends, if not put into a language pack. Might be worth discussing at the meeting.

Currently, the only ones which you *cant* remove are...

 * x-ttcidfont-conf
 * ttf-bitstream-vera
 * ttf-dejavu # includes characters missing in Vera
 * ttf-freefont

The rest are all recommends. We cant remove them by default, unless we change the way langpack support is handled.

Paul Marques Mota (pmota) wrote :

I find those useful to read wikipedia. Can you access http://www.wikipedia.org/ without seeing weird boxes? You may also want to have a look at http://en.wikipedia.org/wiki/Palestine (check the Arabic and Hebrew characters at the beginning of the page) for an everyday example.

Okay, I think we've fixed this as much as we should, then.

Changed in kubuntu-meta:
status: Confirmed → Fix Released

Thank you very much Sarah!

no problem :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers