Ubuntu

xubuntu-desktop kubuntu-desktop etc. no longer upload crash reports as of Precise

Reported by Chris Bainbridge on 2012-05-19
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
edubuntu-meta (Ubuntu)
Undecided
Unassigned
kubuntu-meta (Ubuntu)
Undecided
Unassigned
lubuntu-meta (Ubuntu)
Undecided
Unassigned
mythbuntu-meta (Ubuntu)
Undecided
Unassigned
ubuntustudio-meta (Ubuntu)
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Since the final release of Precise, crash reporting was changed to that crashes are no longer uploaded to Launchpad by apport, instead crashes are uploaded to another database by the whoopsie package, and apport is just used as a front-end. See:

    bug #997283 - Apport no longer uploads bugs to Launchpad (since final version of Precise)
    bug #957177 - support multiple crashdbs.

ubuntu-desktop added a dependency for whoopsie. Unfortunately none of the other desktops did, so crash reporting is now broken on all of them:

$ apt-cache rdepends whoopsie
whoopsie
Reverse Depends:
  whoopsie:i386
  activity-log-manager-control-center:i386
  activity-log-manager-control-center:i386
  ubuntu-desktop
  activity-log-manager-control-center
  activity-log-manager-control-center

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xubuntu-desktop 2.152

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.154

---------------
xubuntu-meta (2.154) quantal; urgency=low

  * Refreshed dependencies
  * Added fonts-lklug-sinhala to desktop-recommends
  * Added fonts-sil-abyssinica to desktop-recommends
  * Added fonts-sil-padauk to desktop-recommends
  * Added fonts-tibetan-machine to desktop-recommends
  * Added ubuntu-drivers-common to desktop
  * Added whoopsie to desktop-recommends lp: #1001630
  * Removed nvidia-common from desktop [amd64 i386]
  * Removed rarian-compat from desktop
  * Removed ttf-freefont from desktop
 -- Lionel Le Folgoc <email address hidden> Sun, 15 Jul 2012 13:09:09 +0200

Changed in xubuntu-meta (Ubuntu):
status: New → Fix Released
Evan Dandrea (ev) wrote :

To be clear, this never broke crash reporting on any Ubuntu derivative. Error reports during development are still sent to Launchpad bugs. They're also now sent during development *and* post-release to the Ubuntu error tracker when whoopsie is installed.

> They're also now sent during development *and* post-release to the Ubuntu error tracker when whoopsie is installed.

Yes, but when whoopsie wasn't installed (which it wouldn't be because it wasn't a dependency of ${derivative-desktop}), and apport was enabled, then in post-release ubuntu, apport would detect the crash, offer to send a crash report, and when the user clicked yes, no crash report would be sent. The user had to figure out that apport requires whoopsie, and then manually install it. I haven't checked if this behaviour is still the case, but that is how it was. It appears that ubuntu-desktop is still the only desktop that has an actual depend entry for whoopsie, so I'd guess this is still a problem?

Also, I just noticed that at https://help.ubuntu.com/community/ReportingBugs it says "Apport is disabled by default in stable releases. To enable it, edit the file: /etc/default/apport and change: enabled=0 to: enabled=1". This does not appear to be true. I am running precise, and by default apport is enabled (apt-get purge apport; apt-get install apport leaves enabled=1 in /etc/default/apport).

Changed in ubuntustudio-meta (Ubuntu):
assignee: nobody → Howard Chan (smartboyhw)
status: New → In Progress
Philip Muškovac (yofel) wrote :

Maybe I'm missing something, but is there are reason why apport doesn't at least recommend whoopsie? That would be the usual resolution for this as it's the application that relies on it. I couldn't figure out how to do much with whoopsie without using apport as an interface for it.

Brian Murray (brian-murray) wrote :

lubuntu-meta (0.42) quantal; urgency=low

  * Refreshed dependencies
  * Added firefox to desktop [powerpc]
  * Added ubuntu-release-upgrader-gtk to desktop
  * Added whoopsie to desktop
  * Removed jockey-gtk from desktop
  * Removed midori from desktop [powerpc]
  * Removed osmo from desktop

 -- Julien Lavergne <email address hidden> Fri, 27 Jul 2012 17:37:37 +0200

Changed in lubuntu-meta (Ubuntu):
status: New → Fix Released
Brian Murray (brian-murray) wrote :

The edubuntu-meta package depends on the the ubuntu-desktop metapackage so this specific task is invalid.

Changed in edubuntu-meta (Ubuntu):
status: New → Invalid
Changed in ubuntustudio-meta (Ubuntu):
assignee: Howard Chan (smartboyhw) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in mythbuntu-meta (Ubuntu):
status: New → Confirmed
Changed in kubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers