Thunderbird and Firefox fonts messed up in Gnome after installing and using KDE4 once

Bug #1196954 reported by Jens on 2013-07-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kubuntu-kde4-meta (Ubuntu)
Undecided
Unassigned

Bug Description

"kubuntu-desktop" is the package I installed, but I'm not 100% sure it is the right package to report against.

When using Firefox or Thunderbird in Gnome's Unity desktop after having used KDE4 once, the fonts in (at least) these two applications are messed up and cannot be restored with Gnome configuration tools (including MyUnity, "extended settings" and the like). See attached screenshots.

I tried removing Firefox's profile (~/.mozilla) which didn't help. I removed ~/.kde, ~/.kderc, ~/.gtkrc-2.0-kde4, .compiz, .dconf, .gnome2*, and almost everything else, and it didn't help. Only after removing *all* hidden directories and files - and thus restoring Gnome font settings to the defaults too - did Thunderbird and Firefox regain the ability to correctly display the fonts in use.

Note that the actual font which Firefox used for its UI *did* change when I changed the font in the Gnome settings tool. Only it looked totally ugly (without hinting?).

I would expect KDE4 not to touch Gnome settings while it is not running as a desktop environment - and vice versa. At the very least I would expect KDE4 not to change settings which cannot be restored with built-in configuration tools of the respective other desktop environment.

Jens (jens-launchpad-net) wrote :
Jens (jens-launchpad-net) wrote :
Ads20000 (ads20000) wrote :

Ubuntu (etc...) version number please, thanks

Changed in kubuntu-kde4-meta (Ubuntu):
status: New → Incomplete
Jens (jens-launchpad-net) wrote :

Oops. Next time I'll use the bugreport utility.

Ubuntu / Kubuntu 12.04.2 with all updates as of 2013-07-02 applied. I don't have the machine any more so I cannot report specific versions.

Changed in kubuntu-kde4-meta (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-kde4-meta (Ubuntu):
status: New → Confirmed
Nathan Osman (george-edison55) wrote :

I am seeing this exact problem with Ubuntu 14.10. I began with a clean installation of ubuntu-desktop and later installed ubuntu-gnome-desktop and kubuntu-desktop. After removing all but ubuntu-desktop, I am unable to restore Firefox and Thunderbird's original font. I've tried removing configuration files in ~ but it doesn't seem to make a difference. Also, creating a new Firefox profile didn't help.

Nathan Osman (george-edison55) wrote :

I figured out a workaround in the meantime. If you delete "~/.config/fontconfig/fonts.conf", close Firefox/Thunderbird, and reopen them - the original font is restored.

TenLeftFingers (tenleftfingers) wrote :

Thanks Nathan Osman, that works for me on 14.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers