Wrong driver shown as active; Selecting proprietary driver seems to have no effect

Bug #1785761 reported by Yann Salmon
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kubuntu-driver-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I am trying to activate nvidia-driver-390 for my graphics card instead of nouveau. The graphical interface of the Driver Manager detects my GPU and the available drivers but selecting nvidia-driver-390 seems to have no effect (the packages have already been installed but nouveau is still used).

Running kcmshell5 kcm_driver_manager in the console enabled me to get the following messages. Usage was to select nvidia-driver-390 and click Apply.

QDBusArgument& operator<<(QDBusArgument&, const DeviceList&) is noop
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
const QDBusArgument& operator>>(const QDBusArgument&, DeviceList&)
Dev(
  id: "/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0"
  modalias: "pci:v000010DEd000013BBsv000010DEsd00001098bc03sc00i00"
  model: "GM107GL [Quadro K620]"
  vendor: "NVIDIA Corporation"
  driver("nvidia-driver-396" recommended[true] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-driver-390" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-340" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("xserver-xorg-video-nouveau" recommended[false] free[true] fromDistro[true] builtin[true] manualInstall[false] fuzzyActive[false] package[0x0])
)
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
not reporting "xserver-xorg-video-nouveau" because it is builtin
("nvidia-driver-390") ("nvidia-340", "nvidia-driver-396")
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
const QDBusArgument& operator>>(const QDBusArgument&, DeviceList&)
Dev(
  id: "/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0"
  modalias: "pci:v000010DEd000013BBsv000010DEsd00001098bc03sc00i00"
  model: "GM107GL [Quadro K620]"
  vendor: "NVIDIA Corporation"
  driver("nvidia-driver-396" recommended[true] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-driver-390" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-340" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("xserver-xorg-video-nouveau" recommended[false] free[true] fromDistro[true] builtin[true] manualInstall[false] fuzzyActive[false] package[0x0])
)
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded
kf5.kwidgetsaddons: No frame loaded

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: kubuntu-driver-manager 15.10ubuntu4
Uname: Linux 4.17.0-996-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Aug 7 09:32:36 2018
InstallationDate: Installed on 2016-09-07 (698 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: kubuntu-driver-manager
UpgradeStatus: Upgraded to bionic on 2018-07-01 (36 days ago)

Revision history for this message
Yann Salmon (yannsalmon) wrote :
Revision history for this message
Yann Salmon (yannsalmon) wrote :

I managed to activate NVIDIA driver instead of nouveau by adding "blacklist=nouveau rdblacklist=nouveau" to my kernel parameters.

But KDE Driver Manager still claims that nouveau is in use, when it is not the case :

compare kcmshell5 kcm_driver_manager

Dev(
  id: "/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0"
  modalias: "pci:v000010DEd000013BBsv000010DEsd00001098bc03sc00i00"
  model: "GM107GL [Quadro K620]"
  vendor: "NVIDIA Corporation"
  driver("nvidia-340" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-driver-390" recommended[false] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("nvidia-driver-396" recommended[true] free[true] fromDistro[false] builtin[false] manualInstall[false] fuzzyActive[false] package[0x0])
  driver("xserver-xorg-video-nouveau" recommended[false] free[true] fromDistro[true] builtin[true] manualInstall[false] fuzzyActive[false] package[0x0])
)

with /var/log/gpu-manager.log :

Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:191d
BusID "PCI:0@0:2:0"
Is boot vga? no
Vendor/Device Id: 10de:13bb
BusID "PCI:1@0:0:0"
Is boot vga? yes
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"
Skipping "/dev/dri/card1", driven by "i915"
Skipping "/dev/dri/card0", driven by "nvidia-drm"

summary: - Selecting proprietary driver seems to have no effect
+ Wrong driver shown as active; Selecting proprietary driver seems to have
+ no effect
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-driver-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers