Kubuntu driver manager shows nothing, even after refreshing driver list

Bug #1316563 reported by Nick Dowson on 2014-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kubuntu-driver-manager (Ubuntu)
Low
Unassigned

Bug Description

Please see attached screenshot for what this looks like.

I'm using Kubuntu 14.04 (just installed). I did choose not to install the restricted extras during installation (I'd like to have an installation as close to fully free as easily possible), not sure if that would relate to this.

The package installed is v: 14.04ubuntu9

Cheers,
Nick

Nick Dowson (nickmdowson) wrote :
Harald Sitter (apachelogger) wrote :

It's because there are no proprietary drivers found for your system.

I commited a fix in our git repo to show a label when this is the case.

Changed in kubuntu-driver-manager (Ubuntu):
importance: Undecided → Low
milestone: none → ubuntu-14.10
status: New → Fix Committed
tags: added: kubuntu

OK thanks.

I was a little surprised by that as I'm pretty sure the network drivers
for my system are non-free: iwlwifi for intel and the realtek one r8169
- but then they're included in the kernel as default?

Cheers,
Nick

On 06/05/14 12:54, Harald Sitter wrote:
> It's because there are no proprietary drivers found for your system.
>
> I commited a fix in our git repo to show a label when this is the case.
>
> ** Changed in: kubuntu-driver-manager (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: kubuntu-driver-manager (Ubuntu)
> Status: New => Fix Committed
>
> ** Changed in: kubuntu-driver-manager (Ubuntu)
> Milestone: None => ubuntu-14.10
>
> ** Tags added: kubuntu
>

Jonathan Riddell (jr) on 2014-12-19
Changed in kubuntu-driver-manager (Ubuntu):
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

11:43 < sitter> 15.04 is blocked on debconf and 14.04 probably didn't have the fixes

Changed in kubuntu-driver-manager (Ubuntu):
milestone: ubuntu-14.10 → none
status: Fix Released → Fix Committed
milestone: none → ubuntu-15.04
peterstan (stasnel) on 2015-01-16
Changed in kubuntu-driver-manager (Ubuntu):
status: Fix Committed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kubuntu-driver-manager (Ubuntu):
status: New → Confirmed
DA-9901081534 (da9901081534) wrote :

It's happening here as well. Had to manually install driver from Muon.

NVIDIA-brand Geforce 750 TI here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-driver-manager - 15.04ubuntu2

---------------
kubuntu-driver-manager (15.04ubuntu2) vivid; urgency=medium

  * Add build-dep on extra-cmake-modules
 -- Jonathan Riddell <email address hidden> Fri, 19 Dec 2014 18:01:58 +0100

Changed in kubuntu-driver-manager (Ubuntu):
status: Confirmed → Fix Released
FoxHunter (foxhunt3r) wrote :

No it's not fixed even as of Neon 5.6

@ foxhunt3r

Neon has it's own bug-base :: pls report this there then.

In case this is still not solved or appears newly in Xenial :: pls consider to open a new bug-report.

tags: added: trusty

@ foxhunt3r:

For 16.04 this would be bug #1530523 (kcm_driver_manager: Infinitely shows Collecting information), status= confirmed, affects 58 people (right now). Comment #29 seems to list a workaround.

Just there click on "yes, I'm affected too" And the numb3r raises to 59. ;-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers