kubuntu-driver-managers leaves apt in a broken state when switching drivers on a nvidia machine

Bug #1311583 reported by Rohan Garg on 2014-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
kubuntu-driver-manager (Ubuntu)
High
Rohan Garg
Trusty
High
Rohan Garg
Utopic
High
Harald Sitter

Bug Description

[Impact]
When switching drivers on a nvidia machine, kubuntu-driver-manager screws up apt post driver install since it removes xserver-xorg-video-nouveau.

[Test Case]

* run driver manage via: alt+f2 -> kcmshell4 driver_manager
* change driver to nvidia
* try and install something via apt-get
* apt-get complains
* update to package from proposed
* change driver to nvidia
* try to install something via apt-get
* apt-get should not complain

[Regression Potential]

None

[Other Info]

None

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: kubuntu-driver-manager 14.04ubuntu7 [modified: usr/lib/kde4/kcm_driver_manager.so usr/share/kde4/services/kcm_driver_manager.desktop]
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Apr 23 12:02:49 2014
InstallationDate: Installed on 2014-04-16 (6 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140415)
SourcePackage: kubuntu-driver-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Rohan Garg (rohangarg) wrote :
Rohan Garg (rohangarg) on 2014-04-23
description: updated
Harald Sitter (apachelogger) wrote :

fix committed to git repo

Changed in kubuntu-driver-manager (Ubuntu Untitled):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Harald Sitter (apachelogger)
importance: Medium → High
Changed in kubuntu-driver-manager (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Rohan Garg (rohangarg)
milestone: none → ubuntu-14.04.1

Hello Rohan, or anyone else affected,

Accepted into trusty-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in kubuntu-driver-manager (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: added: kubuntu
Rohan Garg (rohangarg) wrote :

I can confirm I can install applications from muon and from the command line just fine after this update

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-driver-manager - 14.04ubuntu9

---------------
kubuntu-driver-manager (14.04ubuntu9) trusty; urgency=medium

  [ Harald Sitter ]
  * DriverWidget: do not list builtin drivers as not selected.
    + This avoids breaking the system by trying to remove essential packages
      such as xserver-xorg-video-nouveau for being not selected.
    LP: #1311583

  [ Rohan Garg ]
  * Add a apport hook to provide more debug info when reporting bugs

kubuntu-driver-manager (14.04ubuntu8) trusty; urgency=medium

  * Prevent crashes by properly locking the GUI while applying changes
    LP: #1311075
    + New function DriverWidget::setSelectionEnabled, disabling or enabling
      all QAbstractButtons inside the respective DriverWidget, leaving the
      header label unaffected to give a nicer visual experience.
  * Prevent state confusion caused by allowing 'defaults' to trigger a reload
    even when the manager is currently busy applying changes. Since we have
    no button control inside the KCM we simply turn load() noop while the
    manager is active. This is unfortunately not the nicest behavior, however
    the module will reload whenever the manager finishes, so implicitly we
    will simply execute the requested action once the manager is idle again.
    LP: #1311079
    + Introduce new function DriverManager::isActive evaluating the transaction
      pointer (nullptr when idle).
 -- Rohan Garg <email address hidden> Wed, 23 Apr 2014 13:45:47 +0200

Changed in kubuntu-driver-manager (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for kubuntu-driver-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-driver-manager - 14.04ubuntu9

---------------
kubuntu-driver-manager (14.04ubuntu9) trusty; urgency=medium

  [ Harald Sitter ]
  * DriverWidget: do not list builtin drivers as not selected.
    + This avoids breaking the system by trying to remove essential packages
      such as xserver-xorg-video-nouveau for being not selected.
    LP: #1311583

  [ Rohan Garg ]
  * Add a apport hook to provide more debug info when reporting bugs

kubuntu-driver-manager (14.04ubuntu8) trusty; urgency=medium

  * Prevent crashes by properly locking the GUI while applying changes
    LP: #1311075
    + New function DriverWidget::setSelectionEnabled, disabling or enabling
      all QAbstractButtons inside the respective DriverWidget, leaving the
      header label unaffected to give a nicer visual experience.
  * Prevent state confusion caused by allowing 'defaults' to trigger a reload
    even when the manager is currently busy applying changes. Since we have
    no button control inside the KCM we simply turn load() noop while the
    manager is active. This is unfortunately not the nicest behavior, however
    the module will reload whenever the manager finishes, so implicitly we
    will simply execute the requested action once the manager is idle again.
    LP: #1311079
    + Introduce new function DriverManager::isActive evaluating the transaction
      pointer (nullptr when idle).
 -- Rohan Garg <email address hidden> Wed, 23 Apr 2014 13:45:47 +0200

Changed in kubuntu-driver-manager (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers