Typos and missing entity in Kubuntu 11.10 documentation

Bug #852519 reported by Yuri Chornoivan on 2011-09-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
kubuntu-docs (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

New XMLs contain typos and missing entity (&muonmenu;). See the patch attached.

It also be better to replace Kino (obsolete) with Kdenlive in video section.

Yuri Chornoivan (yurchor-gmail) wrote :

The attachment "patch.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Yuri Chornoivan (yurchor-gmail) wrote :
Gabor Kelemen (kelemeng) wrote :

This bug is about the original strings -> invalid in Ubuntu Translations.

Changed in ubuntu-translations:
status: New → Invalid
Little Girl (littlergirl) wrote :

[IMPACT]

There are typographical errors and a missing (or incorrect) entity in the Kubuntu Oneiric Ocelot 11.10 documentation, and patches were attached as suggested fixes.

The reason for backporting these fixes to the stable release is that some of the errors were present in the stable releases and the development version as well.

The patches were used as an initial guide, and more issues relating to this bug were found and fixed, as seen below:

* Fixes have been committed to the Oneiric kubuntu-docs as revision 250 and 251.
* Fxes have been committed to the Precise kubuntu-docs as revision 276 and 277.
* Fixes have been committed to the Quantal kubuntu-docs as revision 381 and 382.

The Oneiric changes can be seen here:
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/oneiric/revision/250?start_revid=250
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/oneiric/revision/251?start_revid=251

The Precise changes can be seen here:
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/precise/revision/276?start_revid=276
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/precise/revision/277?start_revid=277

The Quantal changes can be seen here:
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/quantal/revision/381?start_revid=381
 * http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/quantal/revision/382?start_revid=382

[TESTCASE]

Follow these steps to reproduce the bug:

 1. Grab a copy of the Launchpad Bazaar repository of the Oneiric kubuntu-docs by using this command in a terminal window:

    bzr branch lp:kubuntu-docs/oneiric -r 249

 2. Do a recursive grep search for these terms/phrases by using each of these commands in a terminal window:

    grep -r "&menumuon;" *
    grep -r "<userinput>irc.freenode.net</userinput>. The most secure port to use is <userinput>8001</userinput>." *
    grep -r "LoCoTeam" *
    grep -r "Administation" *
    grep -r "If the <application>Kicker</application> is locked," *
    grep -r "Worksapce" *
    grep -r "<menuchoice><guimenu>Bookmarks</guimenu><guimenuitem>Edits" *
    grep -r "<phrase>Kubuntu</phrase> Kubuntu ships with" *

[Regression Potential]
Regression should not be an issue with these fixes because they don't reference versions of software or paths to files that might change at a later date.

[Other Info]

The original bug reporter suggested that it might also be a good idea to replace Kino with Kdenlive in the video section. That was not done in the committed fixes above. I suggest filing a separate bug for that if it's still desired.

Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :
Little Girl (littlergirl) wrote :

Two of the files I committed to the Launchpad Bazaar server had duplicate msgids, which were kindly fixed by the original bug reporter and have been committed:

* docs/web/po/web-es.po - duplicate msgid removed by yurchor-gmail to satisfy error in import of file modified in last commit.
* docs/web/po/web-it.po - duplicate msgid removed by yurchor-gmail to satisfy error in import of file modified in last commit.

See the changes here:

http://bazaar.launchpad.net/~ubuntu-core-doc/kubuntu-docs/oneiric/revision/252?start_revid=252

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-docs - 12.10.0ubuntu1

---------------
kubuntu-docs (12.10.0ubuntu1) quantal; urgency=low

  * Updates for Quantal by <email address hidden>
  * Fixes various typos LP: #852519
 -- Jonathan Riddell <email address hidden> Wed, 18 Jul 2012 15:41:48 +0100

Changed in kubuntu-docs (Ubuntu Quantal):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

Uploaded to quantal
Fixes uploaded to precise-proposed for SRU review
oneiric bzr and package is strangely out of sync so I can't upload that one, sorry

Changed in kubuntu-docs (Ubuntu Oneiric):
status: New → Won't Fix
Changed in kubuntu-docs (Ubuntu Precise):
status: New → Fix Committed

Hello Yuri, or anyone else affected,

Accepted kubuntu-docs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/kubuntu-docs/12.04.0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Scott Kitterman (kitterman) wrote :

I installed the updated package and verified that the intended corrections are present. Verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-docs - 12.04.0ubuntu1.1

---------------
kubuntu-docs (12.04.0ubuntu1.1) precise-proposed; urgency=low

  * Typos in docs by <email address hidden>, LP: #852519
 -- Jonathan Riddell <email address hidden> Wed, 18 Jul 2012 15:35:40 +0100

Changed in kubuntu-docs (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers