default homepage nonexistant

Bug #67586 reported by Ace Suares on 2006-10-22
10
Affects Status Importance Assigned to Milestone
kubuntu-docs (Ubuntu)
Low
Unassigned

Bug Description

in Edgy, my gnome webbrowser (the default browser?)
opens with
file:///usr/share/ubuntu-artwork/home/locales/index-C.html
which does not exist.

Jonh Wendell (wendell) wrote :

Hi. Thanks for your bug report.

Recently there were some updates related to firefox and initial pages. Can you tell us if now the things are correct?

And, do you use firefox as web browser? I guess so :)

The right place would be file:///usr/share/ubuntu-artwork/home/index.html, if you use English version.

Ace Suares (acesuares) wrote :

Hi,

This was about gnome webbrowser...

When I use firefox, it opens with
http://www.ubuntu.com/download/releasenotes/610
but this page does not exist.

Cheers,
ace

Jonh Wendell (wendell) wrote :

Gnome webbrowser you're talking is epiphany or firefox?
You can verify by clicking on Help->About

Ace Suares (acesuares) wrote :

help->about doesn't say what browser but it links to
http://www.gnome.org/projects/epiphany

so I guess it's epiphany

cheers!

Jonh Wendell (wendell) wrote :

Are you using a translated version of epiphany?
If so, try this command from a terminal window:

LANGUAGE=C epiphany

And see if the right initial page is showed.

Here in my system the file /usr/share/ubuntu-artwork/home/locales/index-C.html exists and is a link to actual file, /usr/share/ubuntu-artwork/home/firefox-index.html

Ace Suares (acesuares) wrote :

I don't know about 'translated', it's kind of a standard breezy updated to dapper updated to edgy...

but this is the entire contents of
/usr/share/ubuntu-artwork/home

index.html -> /etc/alternatives/firefox-homepage

So, we've got no 'locales' here.

Jonh Wendell (wendell) wrote :

Hmmm...

Install the package ubuntu-docs and restart your browser.

Tell us if it works now.

John Vivirito (gnomefreak) wrote :

Changing this to needs info. Helps keep us more organized.

Jonh Wendell (wendell) wrote :

And then?

Did you do that? It's working now?

Ace Suares (acesuares) wrote :

installed ubuntu-docs (it wasn't installed).

Same problem. Here is the contents of /usr/share/ubuntu-artwork/home/

-rw-r--r-- 1 root root 2281 2006-09-26 07:17 firefox-index.html
lrwxrwxrwx 1 root root 6 2006-10-25 17:04 img -> ../img
lrwxrwxrwx 1 root root 34 2006-01-27 14:32 index.html -> /etc/alternatives/firefox-homepage
drwxr-xr-x 2 root root 4096 2006-10-25 17:04 locales-ubuntu
lrwxrwxrwx 1 root root 13 2006-10-25 17:04 ubuntu.css -> ../ubuntu.css

It seems that there is a 'locales-ubuntu', but not a 'locale'

Jonh Wendell (wendell) wrote :

Hmmmm, it seems to be something goes wrong...

Did you hit ctrl-c or have you interrupt the installation of ubuntu-docs?

That installation should have created that links.

Try to run the script: (from a terminal window)
sudo /var/lib/dpkg/info/ubuntu-docs.postinst

Explanation: The script above is executed automatically when ubuntu-docs is installed. If it was not run, you can run it manually.

Ace Suares (acesuares) wrote :

No, I didn't hit ctrl-c (that would be a weird thing to do :-)

I ran the script but (of course) nothing changed...

Bummer !

Sebastien Bacher (seb128) wrote :

could you run "update-alternatives --display firefox-homepage" and copy that to a comment?

Ace Suares (acesuares) wrote :

Sure:

# update-alternatives --display firefox-homepage
firefox-homepage - status is auto.
 link currently points to /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html
/usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html - priority 40
/usr/share/ubuntu-artwork/home/firefox-index.html - priority 40
 slave firefox-homepage-locales: /usr/share/ubuntu-artwork/home/locales-ubuntu
Current `best' version is /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html.

Sebastien Bacher (seb128) wrote :

do you have kubuntu-docs installed? is /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html available?

Ace Suares (acesuares) wrote :

# ll /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html
-rw-r--r-- 1 root root 7629 2006-09-22 05:12 /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html

should ubuntu-docs and kubuntu-docs be installed automatically? Or did I remove them some day? I mean, if it's working on each normal upgrade from dapper to edgy, then why spent more time on it ? I just wanted to report a 'bug' in the sense that I found something that didn't work after upgrding to edgy.

I originally installed Kubuntu Breezy, then upgraded to dapper and now edgy.
I used apt-get or synaptic to instrall the gnome desktop....

# apt-get install kubuntu-docs
Reading package lists... Done
Building dependency tree
Reading state information... Done
kubuntu-docs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.

Cheers!

Le jeudi 26 octobre 2006 à 21:49 +0000, Ace Suares a écrit :
> # ll /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html
> -rw-r--r-- 1 root root 7629 2006-09-22 05:12 /usr/share/doc/kde/HTML/en/kubuntu/about-kubuntu/index.html
>
> should ubuntu-docs and kubuntu-docs be installed automatically? Or did I
> remove them some day? I mean, if it's working on each normal upgrade
> Cheers!

ubuntu-docs is supposed to be installed on Ubuntu, kubuntu-docs on
kubuntu probably. That looks like a kubuntu-docs issue, reassigning

Richard Johnson (nixternal) wrote :

This isn't a Kubuntu docs issue either I don't believe, but this should fix your problem:

At the command line (terminal, console) type:

sudo update-alternatives --config firefox-homepage

enter your password

Select the option that looks like:

/usr/share/ubuntu-artwork/home/firefox-index.html

In my case it is option 1, so I would type 1 and press enter. If it is option 2 for you, then select 2 and press enter. You want the firefox-index.html selected. I think this is due to borkage from upgrading from Breezy to Dapper to Edgy. Possibly locations and/or filenames changed during these times and didn't upgraded correctly.

Changed in kubuntu-docs:
importance: Undecided → Low
status: Unconfirmed → Needs Info
Richard Johnson (nixternal) wrote :

I am rejecting this bug at this time due to no answer since Oct. 31. This issue was more of a support request, and the last post by me on Oct. 31 should have fixed the problem. If it hasn't fixed the problem, and you are still having issues, please do not hesitate to reopen this bug, and myself or someone else will work with you in order to resolve it. Thank you.

Changed in kubuntu-docs:
status: Needs Info → Rejected
Ace Suares (acesuares) wrote :

Yes, please reject the bug since it is not a big thing. However, all the things I did, except the last answer (0ct 31) which I somehow missed, didn't solve the problem. I did a clean install of edgy then, for other reasons than this bug obviously :-) and of course from then on I had firefox as browser (not epiphany, which was installed before the clean install), and all the homepages were intact. I guess it's a problem indeed resulting from dapper->breezy->edgy, nevertheless, it's a bug. But not an important one and one that we'll never see again :-)

Thanks for the help and the time to investigate this bug. Some other bugs that are much more grave, I haven't had an answer :-(

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers