bad diction in english original makes translation difficult or impossible

Bug #472668 reported by Steffen Eibicht on 2009-11-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kubuntu-docs (Ubuntu)
Undecided
David Wonderly
Natty
Undecided
David Wonderly

Bug Description

Binary package hint: kubuntu-docs

The english texts in Kubuntu-docs have sometimes really bad diction which makes translation into german (and I am sure into any other language) nearly impossible.

Example:

»You may also wish to increase the number of programs available to install through your package managers. Not all the programs that exist for Kubuntu are installed by default.«

which is in the middle of nowhere in between a description of package managers. What does it mean? Does it mean that the user can increase the number of installable packages by using a package manager? Or does it mean that a user can increase the number of available packages if he wants? Or does it maybe mean something else I am not aware of?
The diction itself requires heavy changes on the context, to get a satisfying result in german. Additional the diction is not clear cut (what does it mean?). So the result is awful in german.

This is just a single and simple example of one english text which is dicted in a bad way. Surely there are many more texts which are dicted worse than that.
So please guys, be a bit thoughtful about the translators and formulate the texts a bit nicer in more commonly used words, avoid involved periods (which is a big problem too in Kubuntu-Docs) and follow the guidelines on help-texts.

Another problem is the always repeated description to the user how to start/open a certain application.

Example:

»Software Management is launched through the Kickoff Application Launcher at <menuchoice><guimenu>Kickoff Application Launcher</guimenu><guisubmenu>Applications</guisubmenu><guisubmenu>System</guisubmenu><guimenuitem>Software Management (KPackageKit)</guimenuitem></menuchoice>

in the above text you see the description (between <menuchoice> and </menuchoice>). This is the first description in the help-text. In the following strings which describe tasks, involving the package manager, there is always repeatedly described how to open the package Manager. This is not necessary as for example the Ubuntu-docs show. It is also annoying to read for the user. And it is annoying and frustrating for the translator.
So please do not repeat the steps for opening/ starting applications resp. files over and over.

Thanks and best regards
Steffen

Related branches

David Wonderly (david.wonderly) wrote :

Thanks for reporting this. Our goal will be to get everything fixed for Lucid, with possible upload to Karmic to fix as well
Assigning myself

Changed in kubuntu-docs (Ubuntu):
assignee: nobody → Darkwing Duck (darkwingduck)
status: New → In Progress
Changed in kubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-docs - 10.04.2

---------------
kubuntu-docs (10.04.2) lucid; urgency=low

  * Fixing Firefox Installer docs
  * This uploaded fixes the following bugs as well:
    - (LP: #459383)
    - (LP: #534622)
    - (LP: #436224)
    - (LP: #437725)
    - (LP: #438927)
    - (LP: #441256)
    - (LP: #441280)
    - (LP: #441531)
    - (LP: #441439)
    - (LP: #441442)
    - (LP: #441496)
    - (LP: #441997)
    - (LP: #443054)
    - (LP: #444585)
    - (LP: #445831)
    - (LP: #447184)
    - (LP: #448347)
    - (LP: #448718)
    - (LP: #449564)
    - (LP: #458128)
    - (LP: #459112)
    - (LP: #460352)
    - (LP: #472668)
    - (LP: #473206)
    - (LP: #473211)
    - (LP: #486309)
    - (LP: #487556)
    - (LP: #487559)
    - (LP: #487574)
    - (LP: #524445)
 -- <email address hidden> (Richard A. Johnson) Sat, 27 Mar 2010 23:42:59 -0500

Changed in kubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in kubuntu-docs (Ubuntu):
status: Fix Released → Incomplete

Hi,

thanks for your work in fixing/ updating the Kubuntu Docs.
At first I am very thankful that you have deleted these awful repeatings of hints how to open applications.

Unfortunatly there are still (new!) texts which are dicted in an awful way. They even do not make sense in english!

Example:

»<acronym>KDE</acronym> is similar to <phrase>GNOME</phrase> in many ways, but there are distinct differences which distinguish <acronym>KDE</acronym> as a desktop environment. «

two times differences...the first one is a »distinct difference« which »distinguishes«... to distinguish something is the nature of a difference ;-) Anyway, to get a good translation to some degree (it is then still far far away from perfect) I'll have to cut out words and the sense would be for sure different to the sense which was intended by the original Author.
If we do it like this, we do not need to translate. Then every language team can create their own texts. Which makes no sense either.

praising something as good, distinct and so on is generally okay. But the result should be that the text still makes sense.

With this, the translation of Kubuntu Docs is AGAIN very difficult, I have to cut out lots of words - the sense is different in german --> resulting in the same as before.

There are of course still lots of more examples for bad dictions in the (new) Kubuntu Docs. It is still very difficult to translate Kubuntu Docs and the results are not professional.

Please review your texts and change your mind regarding formulation style.

Thanks & regards
Steffen

Changed in kubuntu-docs (Ubuntu):
status: Incomplete → New
David Wonderly (david.wonderly) wrote :

Steffen, when we do our next review of the docs for Maverick Meerkat we will make sure that they read better for the translations. Thank you for your work.

DW

Changed in kubuntu-docs (Ubuntu):
status: New → Confirmed
milestone: none → later
Moritz Baumann (mo42) wrote :

Thanks for listening! If you need assistance in improving the documentation, please contact us (the German Ubuntu translation team). Some of us would be willing to help with the next version. In many situations I almost completely rewrote the English original as it wasn't helpful at all or over-complicated, so I could provide a lot of suggestions based on the current text.

Many formulations aren't all too clear in the original either and therefore impossible to translate, somtimes it seems like someone tried very hard to squeeze the brand name »Kubuntu« into a paragraph at least 5 times and I could name a few cases where the information provided be the manual is too sparse for an average user.

Jonathan Jesse (jjesse) wrote :

Moritz

If you are interested in helping out with the Kubuntu docs we need all the help we can get... join us on #ubuntu-docs and reach out to either DarkwingDuck or myself (jjesse). also feel free to send me an email (jjesse AT gmail DOT com) on things we need help with for Natty.

Or you could just send the proposed changes to myself in a .diff format that I can apply to the branch

Jonathan Jesse (jjesse) wrote :

Did we get all of this resolved in the Maverick release? Please let us know if this bug is still out there

Moritz Baumann (mo42) wrote :

It is, but unfortunately I didn't have enough time to create diffs. There are still quite a few problematic/weird sentences in the English original.
If you need help for Natty, you can contact me via email (flamingmo AT online DOT de).

Jonathan Jesse (jjesse) wrote :

Mortiz,

I sent you an email about this, let me know if you are interested in working together on things this

Changed in kubuntu-docs (Ubuntu):
milestone: later → none
milestone: none → ubuntu-11.04
Changed in kubuntu-docs (Ubuntu Natty):
milestone: none → natty-updates
status: New → Confirmed
Changed in kubuntu-docs (Ubuntu):
milestone: ubuntu-11.04 → none

As this will be an ongoing issue with people writing docs I am marking it opinion. I will be listing this on the upcoming Kubuntu documentation handbook along with our todo lists.

Thank you for any and all feedback from our translators.

Changed in kubuntu-docs (Ubuntu Natty):
assignee: nobody → David Wonderly (david.wonderly)
Changed in kubuntu-docs (Ubuntu):
status: Confirmed → Opinion
Changed in kubuntu-docs (Ubuntu Natty):
status: Confirmed → Opinion
milestone: natty-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers