Please update kubuntu-docs translation templates in Launchpad

Bug #460352 reported by David Planella on 2009-10-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
kubuntu-docs (Ubuntu)
Undecided
Jonathan Jesse

Bug Description

Binary package hint: kubuntu-docs

The translation templates in Launchpad have not been updated for some time. This is what would need to be done:

* Generate up-to-date POT files from the source xml files in the package.
* Either upload a new version of the package with updated templates to the archive (preferred, but we're already quite late in the cycle) or upload a tarball with all updated translation templates directly into Launchpad (much quicker).
* Confirm the obsolete templates and let the ubuntu-translations-coordinators team know. So far, I believe the following templates are obsolete and can be disabled in Launchpad:
  * preface
  * basic-concepts
  * desktopguide
  * programming

Please consider updating them and telling us about the obsolete templates, since otherwise it is a considerable waste of effort for translators to translate obsolete strings which should in fact not be exposed for translation.

Thanks.

Related branches

David Planella (dpm) on 2009-10-25
summary: - Please update translation templates in Launchpad
+ Please update kubuntu-docs translation templates in Launchpad
Changed in ubuntu-translations:
importance: Undecided → High
description: updated
Adi Roiban (adiroiban) wrote :

I am happy to help with this issue

Changed in ubuntu-translations:
status: New → Confirmed
assignee: nobody → Adi Roiban (adiroiban)
Jonathan Jesse (jjesse) on 2009-11-07
Changed in kubuntu-docs (Ubuntu):
assignee: nobody → Jonathan Jesse (jjesse)
milestone: none → ubuntu-10.04
Gabor Kelemen (kelemeng) wrote :

milestone: none → ubuntu-10.04

Please, don't do this. This has to be fixed in an update, in Karmic. I can't offer much help, but I'd like to say, this is a way too visible problem to be left unfixed.

On the personal side, I tought kubuntu-docs is something worth translating, then we put quite some effort to reach 100% - I'm sure that ignoring this would scare off at least that new contributor, who did the most of this work alone, and opened half the current bugs in this package.

Richard Johnson (nixternal) wrote :

* Generate up-to-date POT files from the source xml files in the package.

This was done with the last upload of the kubuntu-docs package. Everytime we commit a change in bzr, we also update the POT files. These then go through LP when we upload the latest kubuntu-docs package.

* Either upload a new version of the package with updated templates to the archive (preferred, but we're already quite late in the cycle) or upload a tarball with all updated translation templates directly into Launchpad (much quicker).

Re: the previous comment. Every upload gets updated templates, as I do this for the kubuntu-docs package.

* Confirm the obsolete templates and let the ubuntu-translations-coordinators team know. So far, I believe the following templates are obsolete and can be disabled in Launchpad:
  * preface
  * basic-concepts
  * desktopguide
  * programming

I can confirm this and asked a while back about this. For Lucid we want all of them removed as we are starting fresh with the documentation.

The current status of kubuntu-docs is about as close to garbage as one can imagine. This is due to the time people who are involved were able to commit over the past couple of development cycles. The text is really out of date, the images are just as out of date, and the layout was draft at best. I plan on fixing this in Lucid, but if I can help with anything in Karmic, please let me know. Thanks!

Changed in kubuntu-docs (Ubuntu):
status: New → In Progress

Am Freitag, den 20.11.2009, 22:59 +0000 schrieb Richard Johnson:
> * Generate up-to-date POT files from the source xml files in the
> package.
>
> This was done with the last upload of the kubuntu-docs package.
> Everytime we commit a change in bzr, we also update the POT files. These
> then go through LP when we upload the latest kubuntu-docs package.
>
> * Either upload a new version of the package with updated templates to
> the archive (preferred, but we're already quite late in the cycle) or
> upload a tarball with all updated translation templates directly into
> Launchpad (much quicker).
>
> Re: the previous comment. Every upload gets updated templates, as I do
> this for the kubuntu-docs package.
>

(I'll need to investigate some more before replying to this)

> * Confirm the obsolete templates and let the
> ubuntu-translations-coordinators team know. So far, I believe the
> following templates are obsolete and can be disabled in Launchpad:
> * preface
> * basic-concepts
> * desktopguide
> * programming
>
> I can confirm this and asked a while back about this.

Thanks, I have now disabled them in the web UI (Karmic and Lucid -though
they were still hidden to translators in the latter-), so that they are
not exposed for translation. In the future, when contacting the
translations team, please consider:

      * Filing a support request against the ubuntu-translations project
        (https://answers.launchpad.net/ubuntu-translations/+addquestion)
        (Recommended for more technical requests)
      * Using any of the other communication channels listed here
        (https://wiki.ubuntu.com/Translations/Contact/)
      * In doubt, you can ping me (dpm) any time on IRC

> For Lucid we want
> all of them removed as we are starting fresh with the documentation.
>

I have not yet disabled them in Lucid, since:

      * They will not be exposed to translators until Alpha-3
      * If any of the new templates has got the same name as the current
        ones it will be replaced on upload anyway
      * If any of the strings in the current docs is kept, the
        translation can be reused.

In short, when you do the upload of the new docs, simply ping the
translation team and we'll make sure the templates are in shape.

> The current status of kubuntu-docs is about as close to garbage as one
> can imagine. This is due to the time people who are involved were able
> to commit over the past couple of development cycles. The text is really
> out of date, the images are just as out of date, and the layout was
> draft at best. I plan on fixing this in Lucid, but if I can help with
> anything in Karmic, please let me know. Thanks!
>

Thanks a lot for the update on the situation of kubuntu-docs. Regarding
how you can help: simply by regular communication with the translations
team, i.e. letting us know when the first upload happens, letting us
know if there is any way we can help you, making sure that translations
are exported on NonLanguagePackDeadline and informing translators if
there have been any issues, etc.

--
David Planella
Ubuntu Translations Coordinator
david(dot)planella(at)ubuntu(dot)com
www.ubuntu.com

Adi Roiban (adiroiban) on 2009-11-24
Changed in ubuntu-translations:
importance: High → Low
assignee: Adi Roiban (adiroiban) → nobody
Adi Roiban (adiroiban) wrote :

Hi Richard,

The Kubuntu docs translations from Launchpad only reflect kubuntu-docs revision 107.

Since then Jonathan Jesse has done some changes and not all were reverted by Matthew East.

https://code.edge.launchpad.net/~ubuntu-core-doc/kubuntu-docs/karmic

Since there were not to many changes I consider them updated. Now we need to figure out how to include them in Karmic. See https://bugs.edge.launchpad.net/ubuntu-translations/+bug/459476

Changed in ubuntu-translations:
status: Confirmed → Fix Released

On Tue, Nov 24, 2009 at 10:19 PM, Adi Roiban <email address hidden> wrote:
> Since then Jonathan Jesse has done some changes and not all were
> reverted by Matthew East.

Note that none of those changes are present in the Ubuntu distribution
- they are simply changes which may be made in the future, pending
some further discussion of the proper process for a SRU of this type
which causes string changes. Whatever approach is taken, it must
include some time for translators to translate any changed strings
before the SRU is uploaded.

Jonathan Jesse (jjesse) wrote :

the reason i have been making changes as Matthew mentions is because we are
working on an SRU policy. THere were a ton of bugs in the Kubuntu-Docs
release for Karmic, a lot of menu problems and even references to KDE 3
stuff. Probablly our worst documentation release and a lot of it is my
fault.

On Tue, Nov 24, 2009 at 5:44 PM, Matthew East <email address hidden>wrote:

> On Tue, Nov 24, 2009 at 10:19 PM, Adi Roiban <email address hidden> wrote:
> > Since then Jonathan Jesse has done some changes and not all were
> > reverted by Matthew East.
>
> Note that none of those changes are present in the Ubuntu distribution
> - they are simply changes which may be made in the future, pending
> some further discussion of the proper process for a SRU of this type
> which causes string changes. Whatever approach is taken, it must
> include some time for translators to translate any changed strings
> before the SRU is uploaded.
>
> --
> Please update kubuntu-docs translation templates in Launchpad
> https://bugs.launchpad.net/bugs/460352
> You received this bug notification because you are a member of Ubuntu
> Documentation Committers, which is subscribed to kubuntu-docs in ubuntu.
>
> Status in Ubuntu Translations (internationalization and localization): Fix
> Released
> Status in “kubuntu-docs” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: kubuntu-docs
>
> The translation templates in Launchpad have not been updated for some time.
> This is what would need to be done:
>
> * Generate up-to-date POT files from the source xml files in the package.
> * Either upload a new version of the package with updated templates to the
> archive (preferred, but we're already quite late in the cycle) or upload a
> tarball with all updated translation templates directly into Launchpad (much
> quicker).
> * Confirm the obsolete templates and let the
> ubuntu-translations-coordinators team know. So far, I believe the following
> templates are obsolete and can be disabled in Launchpad:
> * preface
> * basic-concepts
> * desktopguide
> * programming
>
> Please consider updating them and telling us about the obsolete templates,
> since otherwise it is a considerable waste of effort for translators to
> translate obsolete strings which should in fact not be exposed for
> translation.
>
> Thanks.
>
>
>

Adi Roiban (adiroiban) wrote :

No problem. If those changes will be pushed to Karmic, from the translations point of view it is better to wait and see them updated in Rosetta and annonce the Ubuntu Translators. After a week or two we can expect some of those translations to be done and we can also update the translation in kubuntu-docs package.

Feel free to ping us on #ubuntu-translators

Cheers

Jonathan Jesse (jjesse) wrote :

that's the goal, to do as many bug fixes against the karmic branch as
possible and create one new upload to Rosetta instead of uploading multiple
times. I will contact you all on #ubuntu-translators :)

On Wed, Nov 25, 2009 at 10:13 AM, Adi Roiban <email address hidden> wrote:

> No problem. If those changes will be pushed to Karmic, from the
> translations point of view it is better to wait and see them updated in
> Rosetta and annonce the Ubuntu Translators. After a week or two we can
> expect some of those translations to be done and we can also update the
> translation in kubuntu-docs package.
>
> Feel free to ping us on #ubuntu-translators
>
> Cheers
>
> --
> Please update kubuntu-docs translation templates in Launchpad
> https://bugs.launchpad.net/bugs/460352
> You received this bug notification because you are a member of Ubuntu
> Documentation Committers, which is subscribed to kubuntu-docs in ubuntu.
>
> Status in Ubuntu Translations (internationalization and localization): Fix
> Released
> Status in “kubuntu-docs” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: kubuntu-docs
>
> The translation templates in Launchpad have not been updated for some time.
> This is what would need to be done:
>
> * Generate up-to-date POT files from the source xml files in the package.
> * Either upload a new version of the package with updated templates to the
> archive (preferred, but we're already quite late in the cycle) or upload a
> tarball with all updated translation templates directly into Launchpad (much
> quicker).
> * Confirm the obsolete templates and let the
> ubuntu-translations-coordinators team know. So far, I believe the following
> templates are obsolete and can be disabled in Launchpad:
> * preface
> * basic-concepts
> * desktopguide
> * programming
>
> Please consider updating them and telling us about the obsolete templates,
> since otherwise it is a considerable waste of effort for translators to
> translate obsolete strings which should in fact not be exposed for
> translation.
>
> Thanks.
>
>
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-docs - 10.04.2

---------------
kubuntu-docs (10.04.2) lucid; urgency=low

  * Fixing Firefox Installer docs
  * This uploaded fixes the following bugs as well:
    - (LP: #459383)
    - (LP: #534622)
    - (LP: #436224)
    - (LP: #437725)
    - (LP: #438927)
    - (LP: #441256)
    - (LP: #441280)
    - (LP: #441531)
    - (LP: #441439)
    - (LP: #441442)
    - (LP: #441496)
    - (LP: #441997)
    - (LP: #443054)
    - (LP: #444585)
    - (LP: #445831)
    - (LP: #447184)
    - (LP: #448347)
    - (LP: #448718)
    - (LP: #449564)
    - (LP: #458128)
    - (LP: #459112)
    - (LP: #460352)
    - (LP: #472668)
    - (LP: #473206)
    - (LP: #473211)
    - (LP: #486309)
    - (LP: #487556)
    - (LP: #487559)
    - (LP: #487574)
    - (LP: #524445)
 -- <email address hidden> (Richard A. Johnson) Sat, 27 Mar 2010 23:42:59 -0500

Changed in kubuntu-docs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers