Ubuntu

Translations not included in kubuntu-docs

Reported by Adi Roiban on 2009-10-23
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Kubuntu Documentation
Invalid
Undecided
Unassigned
Ubuntu Translations
Medium
Unassigned
kubuntu-docs (Ubuntu)
Medium
David Wonderly
Precise
Medium
David Wonderly
Quantal
Medium
David Wonderly

Bug Description

Binary package hint: kubuntu-docs

The current kubuntu-docs package does not provide the translated HTML files

I have created a source package that creates the required HTML files
https://code.edge.launchpad.net/~adiroiban/ubuntu-translations/kubuntu-docs-pkg

Since translating the XML and creating the HTML files take a lot of time I did not create them in the Makefile

to translate XML and create HTML files you should use: xml-translate.sh and html-create.sh

report-create-index.sh will create some index.html files in build/ to report the current status of kubuntu-docs translations

----
To build the deb file on my system I had to change the architecture from all to any

----

I have created a kubuntu-docs containing the translated HTML files, but after installing on my system khelpcenter is still showing the EN kubuntu-docs files.

This is how I tried to test it:
$ LANG=es_ES.UTF-8 khelpcenter

I don't know how to test them and if I need to do some changes in khelpcenter. The UI is in spanish , but all HTML files are in english.

I will attach the filelist and also the package

Adi Roiban (adiroiban) wrote :
Adi Roiban (adiroiban) wrote :

Here is the filelist

Changed in ubuntu-translations:
assignee: nobody → Adi Roiban (adiroiban)
Changed in kubuntu-docs (Ubuntu):
status: New → In Progress
Changed in ubuntu-translations:
importance: Undecided → Critical
status: New → In Progress
David Planella (dpm) on 2009-10-25
Changed in kubuntu-docs:
status: New → Invalid
David Planella (dpm) wrote :

Also see the related bug 460352 for the part where the translation templates are not up to date in Launchpad. A package upload with up-to-date POT templates would mostly fix that one as well.

tags: added: i18n kubuntu
Adi Roiban (adiroiban) wrote :

I think this bug also affect kubuntu-docs since it is the source for debian/* files.

We should wait until Richard Johnson comes back and see how to solve this bug

Changed in kubuntu-docs:
status: Invalid → Confirmed
Changed in ubuntu-translations:
importance: Critical → Medium
Matthew East (mdke) wrote :

We don't use the upstream project for tracking bugs, closing that task. It's sufficient that the bug remains open in Ubuntu (kubuntu-docs).

Changed in kubuntu-docs:
status: Confirmed → Invalid
Jimhu (huyiwei) wrote :

I can confirm this bug.

Adi Roiban (adiroiban) wrote :

Richard, can you please take a look at this bug and the related branch?

Changed in kubuntu-docs (Ubuntu):
assignee: nobody → Richard Johnson (nixternal)
Changed in kubuntu-docs:
status: Invalid → Confirmed
David Planella (dpm) on 2009-11-20
Changed in kubuntu-docs:
status: Confirmed → Invalid
Adi Roiban (adiroiban) on 2009-12-07
Changed in ubuntu-translations:
assignee: Adi Roiban (adiroiban) → nobody
Richard Johnson (nixternal) wrote :

Anyone able to update me on what the next should be? jjesse? If everything is ready, I will go ahead and work on the package and getting it uploaded.

Jonathan Jesse (jjesse) wrote :

Sorry guys I feel behind on everything for the last cycle, but getting back involved, where does this stand and what is the status of this bug? Back up and rocking for Natty

Did we get this fixed? Richard? Jonathan?

Timo Jyrinki (timo-jyrinki) wrote :

No, there are no kubuntu-docs translations included in natty.

While fixing this, I have a wish: regardless of what's the cut-off percent for translations you are using, please include Finnish (fi) translations in the next upload! There is considerable work done to ensure there would be at least a good first impression and beginner instructions translated, even though as a whole kubuntu-docs translation percentage is not near 100% for fi. This is certainly a case where including (some of the) translations would be far better experience than not including at all.

David Planella (dpm) wrote :

Translations were shipped in Oneiric, thus marking as fixed.

Changed in ubuntu-translations:
status: In Progress → Won't Fix
status: Won't Fix → Fix Released
Changed in kubuntu-docs (Ubuntu):
assignee: Richard Johnson (nixternal) → nobody

Translations were not completed by the freeze for 12.04. The plan is to finish translations and have them shipped as an SRU for 12.04.1

Changed in kubuntu-docs (Ubuntu):
importance: Undecided → Medium
assignee: nobody → David Wonderly (david.wonderly)
milestone: none → ubuntu-12.04.1
margaret yeager (1shult) on 2012-05-27
Changed in kubuntu-docs (Ubuntu):
status: In Progress → Confirmed
status: Confirmed → Fix Released
Changed in kubuntu-docs (Ubuntu):
status: Fix Released → Fix Committed
Changed in ubuntu-translations:
status: Fix Released → Fix Committed
Stéphane Graber (stgraber) wrote :

What's the status of this SRU?

Changed in kubuntu-docs (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → David Wonderly (david.wonderly)
milestone: none → ubuntu-12.04.1
Changed in kubuntu-docs (Ubuntu Quantal):
milestone: ubuntu-12.04.1 → none
Stéphane Graber (stgraber) wrote :

Reverting to In progress as the fix isn't in -proposed that I can see.

Changed in kubuntu-docs (Ubuntu Precise):
status: Fix Committed → In Progress
Changed in kubuntu-docs (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2
Colin Watson (cjwatson) on 2013-02-13
Changed in kubuntu-docs (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3

Should we close this as the result of kubuntu-docs deprecation ?

Hendrik Knackstedt (hennekn) wrote :

From our side that's fine.

Gabor Kelemen (kelemeng) wrote :

@Pierre: Can be considered valid for Precise. But if no one wants to push a new version, then sure.

Changed in kubuntu-docs (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in kubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
Changed in kubuntu-docs (Ubuntu Precise):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers