instructions to run apps from Application Launcher slightly wonky.

Bug #367256 reported by skierpage on 2009-04-26
6
Affects Status Importance Assigned to Milestone
kubuntu-docs (Ubuntu)
Medium
Richard Johnson

Bug Description

Binary package hint: kubuntu-docs

I'm new to Kubuntu, I just installed 9.04.

A lot of the doc says to start an application with "Application Launcher → some section → Application name", e.g. help:/kubuntu/internet/browsers.html says
  Open Konqueror by going to Application Launcher → Internet → Web Browser.

I figured out Application Launcher is the lower-left K icon, since its tooltip says Kickoff Application Launcher. But clicking it doesn't work, I don't see an "Internet" section. I had to click it, choose the Applications tab at its bottom, then choose Internet → Web Browser. It defauls to showing a "Favorites" tab with no sections.

I figured it out, eventually people will figure it out. You could either change all these instances to add "→ Applications tab", e.g. Application Launcher → Applications tab → Internet → Web Browser, or maybe explain this once somewhere. "Application launcher" might be already in the doc, but I can't search and the glossary doesn't have "Application Launcher".

Richard Johnson (nixternal) wrote :

This looks to be a problem with some of the &menuapp; entities that I can see. Thanks for the heads up on this and I will take a look at getting it fixed.

Changed in kubuntu-docs (Ubuntu):
assignee: nobody → Richard Johnson (nixternal)
importance: Undecided → Medium
status: New → Confirmed
Jonathan Jesse (jjesse) wrote :

working on this one, stealing it from rich

Changed in kubuntu-docs (Ubuntu):
assignee: Richard Johnson (nixternal) → Jonathan Jesse (jjesse)
status: Confirmed → In Progress
Richard Johnson (nixternal) wrote :

Hey Johnny boy, where did you get with this stuff? I don't know if I fixed most of this a while back or not, can't remember :)

i thought you fixed tthis one as well, i don't remember what the status of
this is

On Fri, Aug 7, 2009 at 8:38 PM, Richard Johnson <email address hidden> wrote:

> Hey Johnny boy, where did you get with this stuff? I don't know if I
> fixed most of this a while back or not, can't remember :)
>
> --
> instructions to run apps from Application Launcher slightly wonky.
> https://bugs.launchpad.net/bugs/367256
> You received this bug notification because you are a member of Ubuntu
> Documentation Committers, which is subscribed to kubuntu-docs in ubuntu.
>

Richard Johnson (nixternal) wrote :
Download full text (47.4 KiB)

=== modified file 'docs/add-applications/C/add-applications.xml'
--- docs/add-applications/C/add-applications.xml 2009-06-09 02:51:13 +0000
+++ docs/add-applications/C/add-applications.xml 2009-09-01 16:07:27 +0000
@@ -90,7 +90,7 @@
 installing software on your Kubuntu system. Software Management enables you to manage
 your software and your software repositories.</para>
 <para>
-Software Management is launched through the Application Launcher at &menukpackagekit;.
+Software Management is launched through the Kickoff Application Launcher at &menukpackagekit;.
 </para>
 </sect1>

=== modified file 'docs/config-desktop/C/config-desktop.xml' ...

Changed in kubuntu-docs (Ubuntu):
assignee: Jonathan Jesse (jjesse) → Richard Johnson (nixternal)
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kubuntu-docs - 9.10.1

---------------
kubuntu-docs (9.10.1) karmic; urgency=low

  * Initial release of the Karmic documentation, fixes a bunch of bugs:
    - Default package manager has to be changed (LP: #353327)
    - Link fails in doc index for viewing Windows partition (LP: #367224)
    - Application Launcher instructions confusing (LP: #367256)
    - Konversation still listed as default IRC client (LP: #353377)
    - Office section listed OpenOffice.org version 2 (LP: #353381)
    - kdesu in printing section (LP: #354000)
    - string error in network section (LP: #355975)
    - hyperlinks on index page were messed up (LP: #367243)
    - Typo in internet section (LP: #416715)
    - Reference to feisty in add-applications (LP: #385026)
    - Typo (LP: #413695)
    - Two printer configurator (LP: #417150)
    - Pringing section listed System Settings in Favorites (LP: #417177)
    - Firefox bookmark handling UI changed (LP: #416502)
    - Ugly hyperlinks and then some in Konqueror (LP: #367243)
  * debian/rules:
    - commented out translations section until final release
    - changed khelpdesktop location to fix FTBFS
    - removed index-table.css as it isn't used anymore
    - removed libs/*.html for contribs and legal as it isn't needed anymore
    - changed basic-concepts to basic-commands
    - changed programming to development
  * debian/compat: bumped to 7 for debhelper
  * debian/control: bumped to 7 for debhelper, 3.8.3 for standards, added
    shlibs and misc depends
  * debian/kubuntu-systemdocs: removed (temporarily?)
  * debian/source.lintian-overrides: removed, not needed anymore
  * debian/postinst: removed, replaced with kubuntu-docs.links
  * debian/prerm: removed, not needed anymore
  * debian/kubuntu-docs.links: added to link css and kubuntu index file

 -- <email address hidden> (Richard A. Johnson) Wed, 02 Sep 2009 01:48:34 -0500

Changed in kubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers