[Suggestion]Change the list of Adblock filters

Bug #99535 reported by Guillaume Martres on 2007-03-31
12
Affects Status Importance Assigned to Milestone
kubuntu-default-settings (Ubuntu)
High
Anthony Mercatante

Bug Description

Binary package hint: kubuntu-default-settings

According to http://adblockplus.org/en/faq_project#filterset.g Filterset.G is Bad  , maybe we could change this list to one of this: http://adblockplus.org/en/subscriptions , some people have complained about Konqueror being slow, this could be the reason.

description: updated
Richard Johnson (nixternal) wrote :

I am confirming this as filterset.g is evil and just checked and it is top of the list in konqueror adblock. I hadn't noticed this before. Good find.

Changed in kubuntu-default-settings:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Guillaume Martres (smarter) wrote :

Filterset.g is still present in Gutsy, and the filter list hasn't been updated since 2006-10-02.

We need to fix this - this list is no longer freely distributable.

The offending file is kubuntu-default-settings/kde-rc-files/khtmlrc

Changed in kubuntu-default-settings:
assignee: nobody → tonio
importance: Low → High
Guillaume Martres (smarter) wrote :

Easylist(http://easylist.adblockplus.org/easylist-element.htm ) seems to be a good candidate for replacement, unfortunately adblocK does't support whitelisting and some adblock plus specific characters.

Anthony Mercatante (tonio) wrote :

kubuntu-default-settings (1:7.10-26) gutsy; urgency=low

  * Fixed khtmlrc, now uses easylist instead of filterset.g. Fixes LP:
    #99535

 -- Anthony Mercatante <email address hidden> Sat, 29 Sep 2007 11:41:52 +0200

Changed in kubuntu-default-settings:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers